02-02-2011 04:54 AM - edited 07-03-2021 07:45 PM
Hi,
I have configured Cisco 2801 with HWIC-3G-GSM to work as a GPRS router.
The configuration is:
chat-script gsm "" "atdt*99***1#" TIMEOUT 60 "CONNECT"
chat-script pin "" "at+cpin=xxxx"
interface Cellular0/1/0
ip address negotiated
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
ppp chap hostname ""
ppp chap password 0 ""
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string gsm
dialer persistent delay initial 20
dialer-group 1
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
line 0/1/0
script startup pin
script dialer gsm
no exec
rxspeed 236800
txspeed 118000
Normally it works fine, but when the signal level is very low it stops to respond. So this is normal, but when the signal is back again, the connection is still lost, or more specific, in my eyes the router (dialer?) doesn't know that the connection is lost.
The test scenario looks like this:
- ping 172.16.1.1 repeat 500
- ping response is received
- I'm disconnecting an antenna
- pings stops working
- connecting back the antenna
- pings are still not working, and all I can do is just to reboot router
I think that it might be a problem with interoperability with a specific GSM carrier.
I have checked what is going on with modem during this test and it looks like this:
- before test
Data Connection Information
===========================
Data Transmitted = 145108 bytes, Received = 139940 bytes
Profile 1, Packet Session Status = ACTIVE
IP address = 172.25.188.5
Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = EDGE (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = POL, Network = PLUS
Mobile Country Code (MCC) = 260
Mobile Network Code (MNC) = 1
Location Area Code (LAC) = 31942
Routing Area Code (RAC) = 4
Cell ID = 33761
Primary Scrambling Code = 0
PLMN Selection = Automatic
Registered PLMN = Plus GSM , Abbreviated = PLUS
Service Provider =
Radio Information
=================
Current Band = GSM 900, Channel Number = 1
Current RSSI = -56 dBm
Band Selected = GSM all band
Modem Security Information
==========================
Card Holder Verification (CHV1) = Enabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
- after the antenna has been disconnected
Data Connection Information
===========================
Data Transmitted = 359592 bytes, Received = 346840 bytes
Profile 1, Packet Session Status = ACTIVE
IP address = 172.25.188.5
Network Information
===================
Current Service Status = Emergency Only, Service Error = None
Current Service = Combined
Packet Service = None
Packet Session Status = Active
Current Roaming Status = Roaming
Network Selection Mode = Automatic
Country = POL, Network = Orange
Mobile Country Code (MCC) = 260
Mobile Network Code (MNC) = 3
Location Area Code (LAC) = 40100
Routing Area Code (RAC) = 110
Cell ID = 40085
Primary Scrambling Code = 0
PLMN Selection = Automatic
Radio Information
=================
Current Band = GSM 900, Channel Number = 99
Current RSSI = -95 dBm
Band Selected = GSM all band
Modem Security Information
==========================
Card Holder Verification (CHV1) = Enabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
- when I plug back the antena
Data Connection Information
===========================
Data Transmitted = 359592 bytes, Received = 346840 bytes
Profile 1, Packet Session Status = ACTIVE
IP address = 172.25.188.5
Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = EDGE (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = POL, Network = PLUS
Mobile Country Code (MCC) = 260
Mobile Network Code (MNC) = 1
Location Area Code (LAC) = 31942
Routing Area Code (RAC) = 4
Cell ID = 33761
Primary Scrambling Code = 0
PLMN Selection = Automatic
Registered PLMN = Plus GSM , Abbreviated = PLUS
Service Provider =
Radio Information
=================
Current Band = GSM 900, Channel Number = 1
Current RSSI = -58 dBm
Band Selected = GSM all band
Modem Security Information
==========================
Card Holder Verification (CHV1) = Enabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
I don't really know where is the problem, maybe someone had a similar problem?
02-08-2011 11:54 PM
Hi Piotr,
I would be interested to see following debugs throughout this complete operation:
debug ppp nego
debug chat
debug async state
debug dialer
debug ppp packet
When you disconnect the antenna, I would assume ppp keepalives start failing and detect the disconnection and bring down the ppp/dialer connection.
After the antenna is back up, can you please get:
show dialer
show interface dialer 1
show caller time
show cellular 0 all
show ip route
Many thanks,
Steven
04-06-2011 01:58 AM
Hi,
I want to sent some more info;
I have 2 g.shdls conneciton and one 3g ..dialer0 and dilaer1 works for g.shdsl and dialer 3 for 3G conneciton.
IZMIR_BURO# sh dialer
Ce0/2/0 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 5, priority 0
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is physical layer up
Dial reason: Persistent Dialer Profile
Interface bound to profile Di3
Time until disconnect never
Current call connected 00:00:04
Connected to internet
Di0 - dialer type = DIALER PROFILE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 0
Dial String Successes Failures Last DNIS Last status
Di1 - dialer type = DIALER PROFILE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 0
Dial String Successes Failures Last DNIS Last status
Di3 - dialer type = DIALER PROFILE
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is physical layer up
Number of active calls = 1
Dial String Successes Failures Last DNIS Last status
internet 18479 2 00:00:04 successful Default
IZMIR_BURO#
IZMIR_BURO#sh int dialer 3
Dialer3 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address will be negotiated using IPCP
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Ce0/2/0
Last input never, output never, output hang never
Last clearing of "show interface" counters 2w0d
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 6339
Queueing strategy: weighted fair
Output queue: 0/1000/64/6339 (size/max total/threshold/drops)
Conversations 0/1/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 42 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
169997 packets input, 201362608 bytes
94633 packets output, 17498566 bytes
Bound to:
Cellular0/2/0 is up, line protocol is down
Hardware is HSPA/UMTS/EDGE/GPRS-850/900/1800/1900/2100MHz
MTU 1500 bytes, BW 2000 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP TERMsent, loopback not set
Keepalive not supported
Interface is bound to Di3 (Encapsulation PPP)
Last input 00:00:03, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/2/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1500 kilobits/sec
1 minute input rate 0 bits/sec, 0 packets/sec
1 minute output rate 0 bits/sec, 0 packets/sec
336436 packets input, 205597072 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
298008 packets output, 20549654 bytes, 0 underruns
0 output errors, 0 collisions, 18486 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
04-06-2011 02:11 AM
04-06-2011 01:44 AM
Hi Nowak,
I have similar problem.
We have Cisco 2811router with Hwic-3g-HSPA card. When I configure the system everything was fine. Around two weeks everyting was fine.Yesterday I check the sytem and I saw that cellular interface become reseting itself, without stoping.
Network information tab can give us some clue, current service status=Emergency only,servis error=Illegal ME,
How did you solve your problem, can you give me any idea?
Thank you in advande
IZMIR_BURO# sh cellular 0/2/0 all
Hardware Information
====================
Modem Firmware Version = K1_0_2_18AP C:/WS/F
Modem Firmware built = 12/29/08
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 286027450382740
International Mobile Equipment Identity (IMEI) = 011955000180192
Factory Serial Number (FSN) = D66294005801004
Modem Status = Online
Current Modem Temperature = 26 deg C, State = Normal
Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = internet
Authentication = None
Username: , Password:
* - Default profile
Data Connection Information
===========================
Data Transmitted = 17403856 bytes, Received = 201192534 bytes
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Network Information
===================
Current Service Status = Emergency Only, Service Error = Illegal ME
Current Service = Invalid
Packet Service = None
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = TUR, Network = VODAFONE
Mobile Country Code (MCC) = 286
Mobile Network Code (MNC) = 2
Location Area Code (LAC) = 10151
Routing Area Code (RAC) = 11
Cell ID = 21806
Primary Scrambling Code = 124
PLMN Selection = Automatic
Radio Information
=================
Current Band = WCDMA 2100, Channel Number = 10663
Current RSSI = -77 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
Primary Scrambling Code = 0x7C
RSCP = -78 dBm, ECIO = -4 dBm
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
IZMIR_BURO# conf t
04-06-2011 02:04 AM
Hi,
sorry but I didn't find any solution. I changed the device to non Cisco, and now works perfectly.
Regards, Piotr.
04-06-2011 02:16 AM
Hi,
I had two branch office, we are using Cisco 2811 with hwic-3g-hspa.
One of them start reseting and I change it. It works now. But the second one start reseting yesterday and I thougt we can fixed it. But as I can see, this is not possible. I will try few day more to looking forward some solution. Than I will start changing process.
04-06-2011 03:31 AM
Hi Kerimebarus,
From the debugs you provided, it seems to be a configuration issue.
It seems you configured the cellular and/or dialer interface with ms-chap. But in fact you should configure it with pap or chap username/password:
interface Cellular0/2/0
ip address negotiated
...
ppp chap hostname dummy
ppp chap password dummy
If you want please send me the current config and I can have a look.
Steven
04-07-2011 12:09 AM
Morning Steven,
I attached the current configuration, 2 g.shdsl lines are part of the MPLS cloud. 3G line is working as a backup of these g.shdsl lines. And I configure DMVPN on this 3G line. The exaclty same hardware and same config works on another site. This location worked almost two weeks with this config..
It can be a config issue but 3G works all other 11 branch office with the same cellular, dilaer config. But other sites have Cisco 880G series routers.
(Those routers have sierra 3G -hspa card, no Hwic, as you know.)
3G service provider company aks me to configure no username no pasword.
Thank you for your help
04-07-2011 12:19 AM
In the debugs, I see that the cellular modem (HWIC-3G-GSM) is disconnecting the ppp connection:
Ce0/2/0 LCP: I DISCREQ [Open] id 26 len 8 magic 0x9A007A9A
Earlier it proposed to do chap and/or pap but we refused.
So I propose to give it a try with this config:
interface Dialer3
no ppp chap refuse
ppp chap hostname dummy
ppp chap password dummy
If you still have problems afterwards, could you please send me the same debugs again?
Steven
06-16-2011 10:54 PM
Thanks to everyone,
Cisco change the Hwic-3g-hspa card. Whole serises of Card was produce with problem.
Now everything is working perfectly.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide