06-03-2007 11:17 PM - edited 07-03-2021 02:09 PM
Alright So, I am using a Cisco 871W router and currently have this config:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.11.11.1 10.11.11.2
ip dhcp excluded-address 10.11.12.1 10.11.12.2
!
ip dhcp pool Vlan1Pool
import all
network 10.11.11.0 255.255.255.0
dns-server 192.168.0.1
default-router 10.11.11.1
domain-name LocalWired
lease 4
!
ip dhcp pool Vlan2Pool
import all
network 10.11.12.0 255.255.255.0
default-router 10.11.12.1
dns-server 192.168.0.1
domain-name LocalWireless
lease 4
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption vlan 2 mode ciphers tkip
!
ssid WLan2
vlan 2
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 passforcisco
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.2
encapsulation dot1Q 2
!
interface Vlan1
description "VLan for Wired Ports"
ip address 10.11.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan2
description "Wireless LAN"
ip address 10.11.12.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
!!!!!!!!!!!!!!!!!!!!!!!!!!!!
So the DHCP works just fine for the Fast Ethernet Interfaces but the Radio interface doesn't seem to work. I want to have 2 Vlans, 1 for the wireless and 1 for the wired as well as having them both on different subnets (doesn't matter the value) can anyone point me in the direction I need to go? I'd like to not have to bridge anything for that seems easier. Thanks
06-08-2007 07:11 AM
Your configuration seems to be correct for me. But is the client associating without IP address. I mean client will associate with least connectivity. Also, I am not sure about "ip nat inside" command. I think this configuration might be a problem for wireless network.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide