cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
48505
Views
45
Helpful
10
Replies
Mathew John
Beginner

to increase SSH session timeout

Hi

is there a command to increase the session timeout of an AIR-CAP2702I via WLC 5508 or on the AP itself.

Currently the SSH session timeout after 5minutes

software version is 7.6.130.26

thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Matt,

Try this, i think what I previously provided config only for IDLE Session timeout, not exec time out which is by default 10min

LAP1(config-line)#exec-timeout 30

Below is the value once you change only session timeout. As you see exect time out is 10min. 

AP1#show line vty 1
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
2 VTY - - - - - 0 0 0/0 -
Line 2, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600
Status: No Exit Banner
Capabilities: none
Modem state: Idle
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
00:10:00 00:30:00 none not set
Idle Session Disconnect Warning
never
Login-sequence User Response
00:00:30
Autoselect Initial Wait
not set

Test it and let me know

HTH

Rasika

*** Pls rate all useful responses ***

View solution in original post

10 REPLIES 10
Leo Laohoo
VIP Community Legend

config sessions timeout <MINUTES>

Use the command to increase the SSH/Telnet session timeout.

config sessions timeout <MINUTES> works for the controller session and not for the AIR-CAP2702

is there any other command for the AP?

thanks

You can try below command in each AP, but you cannot save these config, so if AP reboot, it will lost these manual configs

LAP1#debug capwap console cli
This command is meant only for debugging/troubleshooting
Any configuration change may result in different
behavior from centralized configuration.
CAPWAP console CLI allow/disallow debugging is on
LAP1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
LAP1(config)#line vty 0 15
LAP1(config-line)#session-timeout ?
<0-35791> Session timeout interval in minutes
LAP1(config-line)#session-timeout 30

HTH

Rasika

*** Pls rate all useful responses ***

Thanks, I have tried this command, but the AP ssh still times out after 10minutes.

is there any other settings I need to do on the WLC to get this working?

kind regards

Mathew,

No, there is no option on WLC to increase the session timeout for the aps. We can only enable the ssh and mention the credentials through wlc

Thanks

Sreejith

Hi Rasika

do I need to add anything else to get this working?

thanks

Mathew

Hi Matt,

Try this, i think what I previously provided config only for IDLE Session timeout, not exec time out which is by default 10min

LAP1(config-line)#exec-timeout 30

Below is the value once you change only session timeout. As you see exect time out is 10min. 

AP1#show line vty 1
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
2 VTY - - - - - 0 0 0/0 -
Line 2, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600
Status: No Exit Banner
Capabilities: none
Modem state: Idle
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
00:10:00 00:30:00 none not set
Idle Session Disconnect Warning
never
Login-sequence User Response
00:00:30
Autoselect Initial Wait
not set

Test it and let me know

HTH

Rasika

*** Pls rate all useful responses ***

View solution in original post

I have something similar: every couple of days i need rebooting my router to make ssh work again. What could be my issue ?


@Mathew John wrote:

config sessions timeout <MINUTES> works for the controller session and not for the AIR-CAP2702

is there any other command for the AP?

thanks


 

Mathew John
Beginner

Thanks Rasika

I tried it once and it is working. I will try again later.

One more question.

what command can I use to revert this timeout setting back to factory default (10minutes) without rebooting/resetting the Access Point

Kind regards

Mathew

Hi Matt,

Good to hear that.

You can use the same commands with 10 min for exec & 0 for session timeout.

LAP1(config)#line vty 0 15
LAP1
(config-line)#exec-timeout 10
LAP1(config-line)#session-timeout 0

You can verify by using below , you should not see above two config lines as they are default settings.

LAP1#sh run | be line vty

HTH

Rasika

Create
Recognize Your Peers
Content for Community-Ad