Showing results for 
Search instead for 
Did you mean: 

Updating Mobility Express - How do I accept the EULA?


I recently installed a single 1815i access point with Mobility Express for home use and plan to add a couple more APs later. Tried to update to latest software via GUI and discovered a SmartNet agreement is required. Fair enough - SmartNet duly purchased and associated with my CCO login.


Current revision installed is Trying to update via GUI, it shows there's an available - even before I "Check Now". If I then click to check for updates, it spins for a bit then throws an error "Download URL exception: Eula form have not been accepted or rejected to continue download" (some quality English there!). The manual says nothing about accepting the EULA to check for new versions, only to update to them.


If I click "Update" the wizard the manual talks about starts. A tab for what release I want to update to, one for whether I want to restart now or later, and then the confirm tab. According to the instructions I should be presented with the EULA when I "confirm". I'm not - it spins for a few seconds then comes up with the same error text as when I do a check for updates (but this time in a popup window, first time is just on the page).


If I go to downloads on, I can select the upgraded version there and download it, accepting the EULA when prompted. Wondered if accepting there would allow the WLC to recognise I accepted the license... it doesn't.


I'd prefer to do the update from the GUI for simplicity. I've tried multiple different browsers including one with no popup blocks enabled etc, but nothing I do seems to get the WLC to prompt me to accept the EULA, which I'm perfectly happy to do to get this updated.


Is there a CLI method to accept it as there is for some router feature licenses? What am I missing here?

1 Accepted Solution