Showing results for 
Search instead for 
Did you mean: 

WLC does not change Ip address on client when it changes ssid

we have two android devices. One works  but the other has problems.
Same modell and same Andoid version 10

Run  cisco 9800-40 version 17.3.2.a , Using PSK
One android client does not change Ip address when it changes ssid on wlc01.
If the client is on (DHCP) on SSID guest and moves to on ssid admin (only Static ip) network, the client still has ip registered on WLC01 under Clients and it does not work. Even if the client has an (SSID Admin) static ip. I can see that its in the right ssid but still has 192.168.1x IP.
But if I move the access point to wlc02 (Same config), it gets it right with the ip addresses and under clients i can see the 10.11.1x static ip.
I have tried to do a factory reset on the client. Tested different models of access points. Restarted access points.
If I move the client back from WLC02 to WLC01 it will get the same error.

Could it be that the mac address is stuck on to the ip on wlc1

Tony Rosolek

What do you mean by static Ip in the SSID admin? Is this static address assigned by a DHCP server, based on a reservation or is it statically configured on the client? 

Is the SSID admin configured as Flexconnect or Local SSID? Is the necessary VLAN allowed on the necessary WLC-/AP ports?

||| Please rate helpful posts. Thanks! |||

No flex connect. 

SSID "admin" does not have dhcp at all. On the device i config static Ip but it does not show in wlc01. It shows the old DHCP address. 

I can se that the client is stuck on State IP Learn. 

It is a very strange problem. 

Other clients on the same ssid works with static IP. It is just this one. Can the clients be stuck in the WLC01 config? 

done a factory reset on client. 




Can you post a RA trace for this client to check whether the client is struck at IP Lean stage?


Also if the design is FlexConnect please take a note on the below.

For the FlexConnect local switching, central authentication deployments, if there is a passive client with a static IP address, it is recommended to disable the Learn Client IP Address feature under the WLAN > Advanced tab.


Arshad Safrulla

Here is a trace log fileSkärmklipp.PNG


172 ip range is ssid guest but client is in ADMIN_No_DHCP_

It is just this client that has that problem. 

No flexconnect.

In the log, we see the client sending dozens of ARP requests to the gateway with its static address. 


Here is a quite new bug which might also affect you. It's only three days old and was discovered on version 17.3.3:


switchover or reload should fix this"

||| Please rate helpful posts. Thanks! |||
Recognize Your Peers
Content for Community-Ad