cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
240
Views
0
Helpful
3
Replies
Highlighted
Beginner

ASR9001 upgrade with SP

We are in the progress of upgrading our ASR9001 from 4.3.0 to 4.3.4.

We are having some issues with the service pack. I prefer to only activate those packages required by the router and no additional ones

 

Install operation 35 '(admin) install activate disk0:*4.3.4* synchronous test' started by user 'cisco' via
CLI at 12:20:06 UTC Wed Jan 28 2015.
Warning:  No changes will occur due to 'test' option being specified. The following is the predicted output
Warning:  for this install command.
Info:     This operation will activate the following packages:
Info:         disk0:asr9k-mini-px-4.3.4
Info:         disk0:asr9k-px-4.3.4.sp5-1.0.0
Info:         disk0:asr9k-mpls-px-4.3.4
Info:         disk0:asr9k-mgbl-px-4.3.4
Info:         disk0:asr9k-mcast-px-4.3.4
Info:         disk0:asr9k-k9sec-px-4.3.4
Info:         disk0:asr9k-fpd-px-4.3.4
Error:    Cannot proceed with the activation because of the following package incompatibility:
Error:      asr9k-adv-video-supp-4.3.4.sp5-1.0.0 needs iosxr-adv-video-4.3.4, or equivalent, to be active on
Error:    the same nodes.
Error:    Suggested steps to resolve this:
Error:     - check the installation instructions.
Error:     - activate or deactivate the specified packages on the specified nodes.
Install operation 35 failed at 12:20:54 UTC Wed Jan 28 2015.
RP/0/RSP0/CPU0:ISLRE021(admin)#

 

We only require those 6 packages and no more. However as in the SP% is also something related to video the upgrade fails. How can we work around this. With 4.3.0 we just selected the patches required for our configuration. I don't like to install patches for protocols we do not use for example

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

hi there,because the SP is

hi there,

because the SP is built of the smu lineup and an aggregate of all smu's that have been released, there was a dependency on some of the video pie/code since hte smu lineup contained some fixes in there.

We have found out a new way to make this more lenient forward, but at this moment for the SP installation on 434 we would need to have the video pie loaded.

The good thing is that if you have it loaded but not configured, the code in the video pie is not exercised whatsoever so you dont have to worry about being exposed to issues in that area if you're not using the feature.

regards

xander

3 REPLIES 3
Cisco Employee

hi there,because the SP is

hi there,

because the SP is built of the smu lineup and an aggregate of all smu's that have been released, there was a dependency on some of the video pie/code since hte smu lineup contained some fixes in there.

We have found out a new way to make this more lenient forward, but at this moment for the SP installation on 434 we would need to have the video pie loaded.

The good thing is that if you have it loaded but not configured, the code in the video pie is not exercised whatsoever so you dont have to worry about being exposed to issues in that area if you're not using the feature.

regards

xander

Beginner

Xander, upgrade is working

Xander,

 

upgrade is working now.

Another question when would you use the

asr9k-mini-px.vm-4.3.4

and when would you use the

asr9k-mini-px.pie-4.3.4

 

Regards

Eelco

Cisco Employee

great awesome eelco!ah the

great awesome eelco!

ah the pie is for upgrading, the vm is for turbobooting.

if you are on release X and want to go to Y via an install add/act procedure, you use the pie one.

if you are in rommon and want to do a clean install with turboboot, then you use the vm.

the vm is the executable of the pie really.

cheers

xander

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards