cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2121
Views
15
Helpful
6
Replies
Highlighted
Beginner

asr9k-mpls-px.pie-6.4.2 is corrupt, during IOS-XR upgrade

Hi, All!

 

Try upgrade IOS-XR from 4.3.4 to 6.4.2. But during install i got error message:

RP/0/RSP0/CPU0:M9-ASR02(admin)#show install log 28 detail 
Mon Sep 24 15:50:30.125 MSK

Install operation 28 started by user 'alex' via CLI at 15:43:03 MSK Mon Sep 24 2018.
(admin) install add /tftp://10.100.7.21/ASR9K-6.4.2/XR/asr9k-mpls-px.pie-6.4.2
Install operation 28 failed at 15:43:40 MSK Mon Sep 24 2018.

Install logs:
    Install operation 28 '(admin) install add /tftp://10.100.7.21/ASR9K-6.4.2/XR/asr9k-mpls-px.pie-6.4.2' started by user 'alex' via CLI at 15:43:03 MSK Mon Sep 24 2018.
    Error:    Cannot proceed with the add operation because the pie file '/tftp://10.100.7.21/ASR9K-6.4.2/XR/asr9k-mpls-px.pie-6.4.2' is corrupt.
    Error:     
    Error:    The following pie was not added due to an error:
    Error:        asr9k-mpls-px.pie-6.4.2
    Install operation 28 failed at 15:43:40 MSK Mon Sep 24 2018.

I checked checksum and size of PIE, but all seems ok. As i know, version 4.3.4 has problem with root certifacate, but before upgrade, i installed new root certificate and also i installed poost-expired SMU (CSCut52232-1.0.0). 

 

RP/0/RSP0/CPU0:M9-ASR02(admin)#show install
Mon Sep 24 15:51:40.756 MSK
Secure Domain Router: Owner

  Node 0/RSP0/CPU0 [RP] [SDR: Owner]
    Boot Device: disk0:
    Boot Image: /disk0/asr9k-os-mbi-4.3.4/0x100305/mbiasr9k-rsp3.vm
    Active Packages: 
      disk0:asr9k-mini-px-4.3.4
      disk0:asr9k-fpd-px-4.3.4
      disk0:asr9k-mcast-px-4.3.4
      disk0:asr9k-mpls-px-4.3.4
      disk0:asr9k-px-4.3.4.CSCut52232-1.0.0

  Node 0/0/CPU0 [LC] [SDR: Owner]
    Boot Device: mem:
    Boot Image: /disk0/asr9k-os-mbi-4.3.4/lc/mbiasr9k-lc.vm
    Active Packages: 
      disk0:asr9k-mini-px-4.3.4
      disk0:asr9k-mcast-px-4.3.4
      disk0:asr9k-mpls-px-4.3.4
      disk0:asr9k-px-4.3.4.CSCut52232-1.0.0
RP/0/RSP0/CPU0:M9-ASR02#show sam certificate brief root 
Mon Sep 24 15:55:39.835 MSK

-------------------- SUMMARY OF CERTIFICATES -------------------

Certificate Location    : root
Certificate Index       : 1
Certificate Flag        : TRUSTED 
  Serial Number  : 90:B6:F4:F9:FF:B8:A9:DB
  Subject:
        emailAddress=jamohamm@cisco.com,CN=CSS Certificate Authority,OU=CSG,O=Cisco Systems,L=San Jose,ST=CA,C=US
  Issued By      :
        emailAddress=jamohamm@cisco.com,CN=CSS Certificate Authority,OU=CSG,O=Cisco Systems,L=San Jose,ST=CA,C=US
  Validity Start : 10:19:42 UTC Thu Oct 09 2014
  Validity End   : 10:19:42 UTC Sun Oct 06 2024



Certificate Location    : root
Certificate Index       : 2
Certificate Flag        : TRUSTED 
  Serial Number  : 32:E0:A3:C6:CA:00:39:8C:4E:AC:22:59:1B:61:03:9F
  Subject:
        CN=Code Signing Server Certificate Authority,O=Cisco,C=US
  Issued By      :
        CN=Code Signing Server Certificate Authority,O=Cisco,C=US
  Validity Start : 01:46:24 UTC Tue Oct 17 2000
  Validity End   : 01:51:47 UTC Sat Oct 17 2015

  CRL Distribution Point
        file://\\CodeSignServer\CertEnroll\Code%20Signing%20Server%20Certificate%20Authority.crl

  CRL Distribution Point
        http://codesignserver/CertEnroll/Code%20Signing%20Server%20Certificate%20Authority.crl

What is going on?

 

6 REPLIES 6
Highlighted
Cisco Employee

Someone else on here was having issues with some of the pie files in later releases, it looks like your certificate was extended which is good. Is it only the mpls file that is showing as corrupt or every pie file for 6.4.2? This will help me narrow down if the issue is with the root certificate or the file etc. Also if you can post the md5 of the file I can check the 6.4.2 image tomorrow in my lab.

 

Thanks,

Sam

Highlighted

Hello!

 

No, i tried install asr9k-mini-px.pie-6.4.2 also , but without success. Installation breaked with same error, after progress reach 95%. I compared md5 hash of original PIE and in file README-ASR9K-iosxr-px-6.4.2 and all of them matched:

 

[root@noc 6.4.2]# cat ./README-ASR9K-iosxr-px-6.4.2 
# This file  README-ASR9K-iosxr-px-6.4.2
# md5 of all the files in the tar file are listed below:

2de496d391f4ab4713fcb44f7657ee7d  asr9k-asr9000v-nV-px.pie-6.4.2
b5c30040972cf9af9a739f93e38348ba  asr9k-bng-px.pie-6.4.2
a7a2e001b8ab28c2af1bc02e029aae68  asr9k-doc-px.pie-6.4.2
49df5013e6f538162e445a4df768af7c  asr9k-fpd-px.pie-6.4.2
69b6b0f656a24e9884bee987b55114d7  asr9k-li-px.pie-6.4.2
0422b17a0d6266a1999af153d8ac445a  asr9k-mcast-px.pie-6.4.2
7c566095b3ca83a3001dbe24ef675166  asr9k-mgbl-px.pie-6.4.2
24a605c028c4e401f16178d05d685ff6  asr9k-mini-px.pie-6.4.2
138608bde3bfd9d87cb6092242a70cba  asr9k-mpls-px.pie-6.4.2
7dc8708b66eb0f016fbe1a58e10a01cb  asr9k-optic-px.pie-6.4.2
a104b5aa15d1871922f443cce8c8c375  asr9k-services-infra-px.pie-6.4.2
f89d186d20ad0635c70d39b6b83ed48d  asr9k-services-px.pie-6.4.2
116034f50d4024bfcfd39218458c3c3c  asr9k-video-px.pie-6.4.2


[root@noc 6.4.2]# md5sum ./asr9k-mini-px.pie-6.4.2 
24a605c028c4e401f16178d05d685ff6  ./asr9k-mini-px.pie-6.4.2
[root@noc 6.4.2]# md5sum ./asr9k-mpls-px.pie-6.4.2 
138608bde3bfd9d87cb6092242a70cba  ./asr9k-mpls-px.pie-6.4.2
[root@noc 6.4.2]# md5sum ./asr9k-mcast-px.pie-6.4.2 
0422b17a0d6266a1999af153d8ac445a  ./asr9k-mcast-px.pie-6.4.2

By the way, today i tried install version 5.3.4 and it installed successfully:

RP/0/RSP0/CPU0:M9-ASR02#show install summary 
Tue Sep 25 10:21:58.967 MSK
Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-mini-px-4.3.4
    disk0:asr9k-bng-px-4.3.4
    disk0:asr9k-fpd-px-4.3.4
    disk0:asr9k-mcast-px-4.3.4
    disk0:asr9k-mgbl-px-4.3.4
    disk0:asr9k-mpls-px-4.3.4
    disk0:asr9k-optic-px-4.3.4
    disk0:asr9k-services-px-4.3.4
    disk0:asr9k-video-px-4.3.4
    disk0:asr9k-px-4.3.4.sp10-1.0.0
  Inactive Packages:
    disk0:asr9k-doc-px-4.3.4
    disk0:asr9k-mini-px-5.3.4
  Committed Packages:
    disk0:asr9k-mini-px-4.3.4
    disk0:asr9k-bng-px-4.3.4
    disk0:asr9k-fpd-px-4.3.4
    disk0:asr9k-mcast-px-4.3.4
    disk0:asr9k-mgbl-px-4.3.4
    disk0:asr9k-mpls-px-4.3.4
    disk0:asr9k-optic-px-4.3.4
    disk0:asr9k-services-px-4.3.4
    disk0:asr9k-video-px-4.3.4
    disk0:asr9k-px-4.3.4.CSCut52232-1.0.0
    disk0:asr9k-px-4.3.4.sp10-1.0.0
  Superceded Packages:
    disk0:asr9k-px-4.3.4.CSCut52232-1.0.0 

 

Highlighted

Reading the Xander´s post.

 

The "official" procedure is to move from say 4.3.4 to a "dual-signed" image such as 5.3.x or 61/62 and from there migrate to the desired release say 6.4,

 

I´ll try to upgrade to the 5.3.4 and towards 6.4.2

 

Keep in touch

Highlighted

Hi @pshadrin1,

I used the turboboot process, towards the 6.4.2 version, the upgrade was successfull

RP/0/RSP0/CPU0:CPD# sh version brief
Wed Nov 7 15:47:55.398 UTC

Cisco IOS XR Software, Version 6.4.2[Default]
Copyright (c) 2018 by Cisco Systems, Inc.

ROM: System Bootstrap, Version 0.71(c) 1994-2012 by Cisco Systems, Inc.

CPD uptime is 10 minutes
System image file is "disk0:asr9k-os-mbi-6.4.2/0x100305/mbiasr9k-rsp3.vm"

cisco ASR9K Series (Intel 686 F6M14S4) processor with 6291456K bytes of memory.
Intel 686 F6M14S4 processor at 2129MHz, Revision 2.174
ASR 9006 4 Line Card Slot Chassis with V2 DC PEM

2 FastEthernet
4 Management Ethernet
503k bytes of non-volatile configuration memory.
6271M bytes of hard disk.
12510192k bytes of disk0: (Sector size 512 bytes).
12510192k bytes of disk1: (Sector size 512 bytes).
RP/0/RSP0/CPU0:CPD#


*******************************************
RP/0/RSP0/CPU0:CPD#sh install active summary
Wed Nov 7 15:45:34.863 UTC
Default Profile:
SDRs:
Owner
Active Packages:
disk0:asr9k-mini-px-6.4.2
disk0:asr9k-services-infra-6.4.2
disk0:asr9k-bng-px-6.4.2
disk0:asr9k-doc-px-6.4.2
disk0:asr9k-fpd-px-6.4.2
disk0:asr9k-li-px-6.4.2
disk0:asr9k-mcast-px-6.4.2
disk0:asr9k-mgbl-px-6.4.2
disk0:asr9k-mpls-px-6.4.2
disk0:asr9k-optic-px-6.4.2
disk0:asr9k-services-px-6.4.2
disk0:asr9k-video-px-6.4.2
disk0:asr9k-k9sec-px-6.4.2
disk0:asr9k-px-6.4.2.CSCvd65810-1.0.0
disk0:asr9k-px-6.4.2.CSCvj08046-1.0.0
disk0:asr9k-px-6.4.2.CSCvk41051-1.0.0
disk0:asr9k-px-6.4.2.CSCvk51963-1.0.0
disk0:asr9k-px-6.4.2.CSCvk57993-1.0.0
disk0:asr9k-px-6.4.2.CSCvk58510-1.0.0
disk0:asr9k-px-6.4.2.CSCvk64594-1.0.0
disk0:asr9k-px-6.4.2.CSCvk68799-1.0.0
disk0:asr9k-px-6.4.2.CSCvm22592-1.0.0

Kind regards
Highlighted

Hello!

No, i also tried install asr9k-mini-px.pie-6.4.2, but without success. Installation breaked with same error, after progress reach 95%. I compared md5 hash of original PIE and in file README-ASR9K-iosxr-px-6.4.2 and all of them matched:

 

[root@noc 6.4.2]# cat ./README-ASR9K-iosxr-px-6.4.2 
# This file  README-ASR9K-iosxr-px-6.4.2
# md5 of all the files in the tar file are listed below:

2de496d391f4ab4713fcb44f7657ee7d  asr9k-asr9000v-nV-px.pie-6.4.2
b5c30040972cf9af9a739f93e38348ba  asr9k-bng-px.pie-6.4.2
a7a2e001b8ab28c2af1bc02e029aae68  asr9k-doc-px.pie-6.4.2
49df5013e6f538162e445a4df768af7c  asr9k-fpd-px.pie-6.4.2
69b6b0f656a24e9884bee987b55114d7  asr9k-li-px.pie-6.4.2
0422b17a0d6266a1999af153d8ac445a  asr9k-mcast-px.pie-6.4.2
7c566095b3ca83a3001dbe24ef675166  asr9k-mgbl-px.pie-6.4.2
24a605c028c4e401f16178d05d685ff6  asr9k-mini-px.pie-6.4.2
138608bde3bfd9d87cb6092242a70cba  asr9k-mpls-px.pie-6.4.2
7dc8708b66eb0f016fbe1a58e10a01cb  asr9k-optic-px.pie-6.4.2
a104b5aa15d1871922f443cce8c8c375  asr9k-services-infra-px.pie-6.4.2
f89d186d20ad0635c70d39b6b83ed48d  asr9k-services-px.pie-6.4.2
116034f50d4024bfcfd39218458c3c3c  asr9k-video-px.pie-6.4.2


[root@noc 6.4.2]# md5sum ./asr9k-mini-px.pie-6.4.2 
24a605c028c4e401f16178d05d685ff6  ./asr9k-mini-px.pie-6.4.2
[root@noc 6.4.2]# md5sum ./asr9k-mpls-px.pie-6.4.2 
138608bde3bfd9d87cb6092242a70cba  ./asr9k-mpls-px.pie-6.4.2
[root@noc 6.4.2]# md5sum ./asr9k-mcast-px.pie-6.4.2 
0422b17a0d6266a1999af153d8ac445a  ./asr9k-mcast-px.pie-6.4.2

By the way, today i tried install version 5.3.4 and it installed successfully:

 

RP/0/RSP0/CPU0:M9-ASR02#show install summary 
Tue Sep 25 10:21:58.967 MSK
Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-mini-px-4.3.4
    disk0:asr9k-bng-px-4.3.4
    disk0:asr9k-fpd-px-4.3.4
    disk0:asr9k-mcast-px-4.3.4
    disk0:asr9k-mgbl-px-4.3.4
    disk0:asr9k-mpls-px-4.3.4
    disk0:asr9k-optic-px-4.3.4
    disk0:asr9k-services-px-4.3.4
    disk0:asr9k-video-px-4.3.4
    disk0:asr9k-px-4.3.4.sp10-1.0.0
  Inactive Packages:
    disk0:asr9k-doc-px-4.3.4
    disk0:asr9k-mini-px-5.3.4
  Committed Packages:
    disk0:asr9k-mini-px-4.3.4
    disk0:asr9k-bng-px-4.3.4
    disk0:asr9k-fpd-px-4.3.4
    disk0:asr9k-mcast-px-4.3.4
    disk0:asr9k-mgbl-px-4.3.4
    disk0:asr9k-mpls-px-4.3.4
    disk0:asr9k-optic-px-4.3.4
    disk0:asr9k-services-px-4.3.4
    disk0:asr9k-video-px-4.3.4
    disk0:asr9k-px-4.3.4.CSCut52232-1.0.0
    disk0:asr9k-px-4.3.4.sp10-1.0.0
  Superceded Packages:
    disk0:asr9k-px-4.3.4.CSCut52232-1.0.0 
 
Highlighted

Hi All,

Sam has recently posted an update for this problem. Hope it will help to work this around in future:
https://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/ios-xr-software/213745-ios-xr-upgrade-changes-certificate-expi.html

 

Plus a note from Xander:

https://community.cisco.com/t5/service-providers-blogs/upgrading-to-6-3-2-plus-releases-coming-from-43x-51x-52x-need-to/ba-p/3714718#M901

 

Thx for reporting this to us.


HTH
Niko

HTH,
Niko
Content for Community-Ad