cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1539
Views
0
Helpful
4
Replies
Highlighted
Beginner

l2vpn not coming with Segment Routing in XR 5.3.3

I have following topology

R1----------R2----------R3

R1 is ASR 9000 series router and R3 is ASR 900 router. Both are enabled with segment routing. I created one l2vpn xconnect from R1 to R3 which is not coming up.

Below is the configuration of both the routers

R1# 

router ospf 1
router-id 5.5.5.5
segment-routing sr-prefer
segment-routing prefix-sid-map advertise-local
area 0
segment-routing forwarding mpls
mpls traffic-eng
segment-routing mpls
interface Loopback0
prefix-sid index 3
!
interface TenGigE0/0/2/0
cost 1
network point-to-point
passive disable
fast-reroute per-prefix
fast-reroute per-prefix ti-lfa enable
!
interface TenGigE0/0/2/2
cost 1
network point-to-point
passive disable
fast-reroute per-prefix
!
!
mpls traffic-eng router-id Loopback0
!

l2vpn
pw-class MPLS
encapsulation mpls
ipv4 source 5.5.5.5
!
!

xconnect group SR-P2P-1
p2p SR-P2P-1
interface Bundle-Ether100.181
neighbor ipv4 3.3.3.3 pw-id 181
pw-class MPLS
!
!
R1#sh version
Thu Jun 22 11:58:01.355 UTC

Cisco IOS XR Software, Version 5.3.3[Default]
Copyright (c) 2016 by Cisco Systems, Inc.

ROM: System Bootstrap, Version 2.04(20140424:063844) [ASR9K ROMMON],

RABDCILABCR01 uptime is 2 weeks, 2 days, 14 hours, 30 minutes
System image file is "bootflash:disk0/asr9k-os-mbi-5.3.3.sp2-1.0.0/0x100000/mbiasr9k-rp.vm"

cisco ASR9K Series (P4040) processor with 8388608K bytes of memory.
P4040 processor at 1500MHz, Revision 3.0
ASR-9001 Chassis

2 Management Ethernet
8 TenGigE
8 DWDM controller(s)
8 WANPHY controller(s)
219k bytes of non-volatile configuration memory.
2868M bytes of hard disk.
3915760k bytes of disk0: (Sector size 512 bytes).

Configuration register on node 0/RSP0/CPU0 is 0x2102
Boot device on node 0/RSP0/CPU0 is disk0:
Package active on node 0/RSP0/CPU0:
asr9K-doc-supp, V 5.3.3[Default], Cisco Systems, at disk0:asr9K-doc-supp-5.3.3
Built on Thu Jan 28 14:43:27 UTC 2016
By iox-lnx-006 in /auto/srcarchive16/production/5.3.3/asr9k-px/workspace for pie

R3#

router ospf 1
router-id 3.3.3.3
segment-routing area 0 mpls
segment-routing mpls
segment-routing prefix-sid-map advertise-local
network 3.3.3.3 0.0.0.0 area 0
network 10.10.10.8 0.0.0.1 area 0
network 192.168.12.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

segment-routing mpls
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
!
connected-prefix-sid-map
address-family ipv4
3.3.3.3/32 index 1 range 1
exit-address-family
!
!

interface Port-channel22

service instance 181 ethernet
encapsulation dot1q 181
xconnect 5.5.5.5 181 encapsulation mpls
!

Both routers are configured with segment routing only

R1# sh l2vpn xconnect detail

Group SR-P2P-1, XC SR-P2P-1, state is down; Interworking none
AC: Bundle-Ether100.181, state is up
Type VLAN; Num Ranges: 1
VLAN ranges: [181, 181]
MTU 9188; XC ID 0xa0000005; interworking none
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
drops: illegal VLAN 0, illegal length 0
PW: neighbor 3.3.3.3, PW ID 181, state is down ( local ready )
PW class MPLS, XC ID 0xc0000008
Encapsulation MPLS, protocol LDP
Source address 5.5.5.5
PW type Ethernet, control word disabled, interworking none
PW backup disable delay 0 sec
Sequencing not set

PW Status TLV in use
MPLS Local Remote
------------ ------------------------------ -----------------------------
Label 24042 unknown
Group ID 0x1e0 unknown
Interface Bundle-Ether100.181 unknown
MTU 9188 unknown
Control word disabled unknown
PW type Ethernet unknown
VCCV CV type 0x2 0x0
(none)
(LSP ping verification)
VCCV CC type 0x6 0x0
(none)
(router alert label)
(TTL expiry)
------------ ------------------------------ -----------------------------
Outgoing Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
MIB cpwVcIndex: 3221225480
Create time: 19/06/2017 14:24:55 (20:48:10 ago)
Last time status changed: 19/06/2017 14:31:42 (20:41:24 ago)
Error: MTU mismatched
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0

Can anyone help me if I am missing something.

4 REPLIES 4
Highlighted
Cisco Employee

Hi,

Hi,

With error from output sh l2vpn xconnect detail from ASR90x router, it says :PW: neighbor 3.3.3.3, PW ID 181, state is down ( local ready ):

this possibly may down due to either PW config or label allocation issue.

best results about this xconnect we can see by using "show l2vpn xconnect" on ASR9k as well. This will help us know what exactly the reason for this circuit down.

On ASR90x im seeing circuit is "local ready" but we dont know the reason for down status at ASR9000.

As far as SR config is concern, i would suggest to move the config at global and if you dont have MPLS TE configured then remove it.

router ospf 1
router-id 5.5.5.5
segment-routing mpls
segment-routing forwarding mpls
segment-routing sr-prefer
segment-routing prefix-sid-map advertise-local
area 0
mpls traffic-eng
interface Loopback0
prefix-sid index 2

you can also check the SR status on both sides of platform using below CLIs.

On ASR9000

    show mpls int  >> to know if SR is enable on interfaces or not
   sh mpls label table detail >> will give you label table detail
   sh mpls forwarding
   traceroute 3.3.3.3  >> traceroute will show the same label:
   sh ospf segment-routing prefix-sid-map active-policy  >> SID map details if correctly applied
   sh ospf 1 database opaque-area  >> TLV/label binding information
   
   On ASR90X
   show segment-routing mpls state >>>> the basic Segment Routing configuration and state on l   local router
   show ip ospf segment-routing
   show ip ospf database opaque-area adv-router 4.4.4.4 >>> Check if the forwarding table is installed with right label forwarding information

 Thanks

Highlighted
Beginner

Hi,

Hi,

Thanks for your reply.

The output of sh l2vpn xconnect detail which I posted in the previous post is from 9K router whereas on 90x router the ouput is 

90x# sh xconnect all  detail

XC               ST Segment 1                          S1               Segment 2                S2
------+------------------------------------------------+---+--------------------------------------+---+--

DN               pri ac Po22:181(Eth VLAN)     UP              mpls 5.5.5.5:181        DN
                    Interworking: ethernet                                Local VC label 43
                                                                                       Remote VC label unassigned

I checked for the above mentioned commands on both 90x and 9K. Output(attached) looks fine to me. But l2vpn is still down

Thanks

Highlighted
Cisco Employee

Re: l2vpn not coming with Segment Routing in XR 5.3.3

In order to work in IOS XR you should enable static label mapping "mpls static label local XXXX remote YYYY" or enable "targeted-hello accept". if you were using BGP EVPN there is no need to enable LDP signaling o static mappings.

 

l2vpn
pw-class MPLS
encapsulation mpls
control-word
!
!
xconnect group TO_XRV7
p2p CUSTOMER1
interface GigabitEthernet0/0/0/3
neighbor ipv4 7.7.7.7 pw-id 100
mpls static label local 2222 remote 7777
pw-class MPLS
!
!
!
!

Highlighted
Contributor

Re: l2vpn not coming with Segment Routing in XR 5.3.3

Cisco has released some support for segment-routing on IOS-XR 5.3.3 so what better time to lab it up. I’ve got four IOS-XRv boxes running 5.3.3:

RP/0/0/CPU0:XR1#sh ver | include XR
Cisco IOS XR Software, Version 5.3.3[Default]

Content for Community-Ad