cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5888
Views
4
Helpful
15
Replies

Network Based Recording (WSAPI /XMF) not working on CUBE-E with TCL

I have CUBE configured with NBR using WSAPI. However recording doesn't kick in if I assign my custom TCL script to incoming dial peer.

My TCL doesn't answer the call and handoff the call to default application after finished processing.

Do I have to do anything else in TCL to for the recording to kick in ?

1 ACCEPTED SOLUTION

Accepted Solutions
ptindall
Cisco Employee

Ashish,

NBR in the presence of TCL scripts simply doesn't currently work.   If you turn on the gateway services API debug you'll see no event messaging generated when there's a TCL script associated with the incoming dial-peer.  For that reason CVP in the call flow isn't supported right now with the NBR model.   As I understand it, this is on the roadmap to be fixed but I don't have details as to when exactly you can expect it.

Paul

View solution in original post

15 REPLIES 15
Raghavendra G V
Cisco Employee

Hi Ashish,

we dont have any TCL command to communicate with WSAPI, you can try below record command.
media record leg_incoming $recordInfo $url

please share the logs with debugs to check your handoff issue.
debug voip app

Thanks,
Raghavendra

Hi Raghavendra,

Thanks for your reply. I think you misunderstood my query.

We have Verint recording platform integrated with cisco platform.

Recording works fine as standard but stops working if we assign TCL script to our inbound dial peer.

Also , there are no handoff issues , I was just trying to explain the function of TCL script.

Thanks

Hello Ashish, how are you? We face exactly the same problem. Did you manage a workround or alternative solution?

Best regards, Jesis Galiano.

ptindall
Cisco Employee

Ashish,

NBR in the presence of TCL scripts simply doesn't currently work.   If you turn on the gateway services API debug you'll see no event messaging generated when there's a TCL script associated with the incoming dial-peer.  For that reason CVP in the call flow isn't supported right now with the NBR model.   As I understand it, this is on the roadmap to be fixed but I don't have details as to when exactly you can expect it.

Paul

View solution in original post

Dear Mr. Tindall. Thank you for answers on this issues.

We are on  the same Ashish´s situation.(When we use the Mr.Yawchen https://communities.cisco.com/people/yawchen Script "play_message_2_calling_then_connect.tcl.zip":

https://communities.cisco.com/docs/DOC-51361, The NBR feature on the CUBE stops.)

  I wondering if you know if there is any update on this matter or at list a workaround to apply.

Best regards,

Jesus.

Yes, the limitation has been fixed in IOS 15.6.


Paul

Thank you Paul for your answer! Have a nice day.

Best Regards,

Jesus.

I am using CUBE-E with NBR (WSAPI with CUCM), IOS is 15.6(1)S2 but TCL still seems to be incompatible with this feature.

When I enable the TCL script on the inbound dial-peer, the call disconnects with this error in the TCL debug:

Apr 17 20:40:34.162: TCL script failure

        Result:

                         Handoff Failed

Apr 17 20:40:34.162:    TCL script failure errorInfo:

                        Handoff Failed

    while executing

"handoff appl leg_incoming default "DESTINATION=$dnis"

If I disable WSAPI, the TCL script executes and call handoff is successful

If I disable the TCL script, the call connects and is being recorded OK via NBR.

Has anybody been able to get both working at the same time?

Hi sebastien,

Please share the logs with below debugs along with wsapi.

"debug voip app"

Thanks,

Raghavendra

Hi Sebastien,

I checked with Dev team, handoff command is not supported with wsapi.

Thanks,

Raghavendra

Thanks for looking into this Raghavendra,

Do you think there is an alternative to using the handoff command that would be supported with wsapi?

Basically, the TCL script just need to play an announcement to the caller before handing off the call.

Did you try to use leg setup command instead of handoff command.

Thanks,

Raghavendra

Hi Raghvendra,

We are hitting this issue as well. We use Leg_Setup command to set up the call , however once the leg setup is successful ( i.e we recive event "ls_000") , we use the handoff command ( handoff appl leg_all default).

We use handoff to clear the TCL session to make sure CPU and memory is released.

However, we have now enabled WSAPI on the CUBE-E and this is resulting in calls being dropped. is there any fix?

Thanks

Ashish

 

Hi Ashish,

I don't find any fix for handoff. Dev team told that handoff command is not supported with WSAPI.

Thanks,

Raghavendra

Create
Recognize Your Peers
Content for Community-Ad