cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2503
Views
15
Helpful
3
Replies
Highlighted
Beginner

Jabber Display Name Change

We're switching from CIPC to Jabber for phone only purposes. We have them set to Phone Only mode, registering to the Call Manager cluster with no CUPS. We would like the display name at the top to be the extension or possibly the full phone number from EXT Number Mask. However all it shows is the username, as seen in the screenshot. I've changed the config file to the following...

 

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
<Directory>
<Nickname>telephoneNumber</Nickname>
</Directory>
<Options>
<DockedWindowVisible>false</DockedWindowVisible>
</Options>
<Voicemail>
<VoicemailService_UseCredentialsFrom>phone</VoicemailService_UseCredentialsFrom>
<VoicemailPrimaryServer>voicemail.XXXX.com</VoicemailPrimaryServer>
</Voicemail>
<Policies>
<PreferredFT>P2P</PreferredFT>
<ServicesDomainSsoEmailPrompt>OFF</ServicesDomainSsoEmailPrompt>
</Policies>
</config>

 

Am I missing something, or can this be changed somewhere else?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Engager

Hi,

It is possible to change the Nickname to ipPhone or telephoneNumber parameter with following jabber-config.xml parameters:

 <Directory>
   <DirectoryServerType>EDI</DirectoryServerType>
   <Nickname>telephoneNumber</Nickname>
   <BDINickname>telephoneNumber</BDINickname>
 </Directory>

After you change the jabber-config.xml file, perform following procedure:

  1. Upload jabber-config.xml to all CUCM TFTP Servers.
  2. Restart Cisco TFTP Service on all CUCM TFTP Servers.
  3. Sign Out from Cisco Jabber client
  4. Reset Jabber and Sign In to Cisco Jabber

Here is the screenshot:

Screenshot_1.png

When you perform this change you will come across two issues:

Issue 1:

It affect all the users and it also affects your contact display. All your contacts will be displayed using their telephoneNumber and not the actual display name. You can change contact display name manually.

 

Issue 2:

When you logout from your Jabber, you will see login display name as telephoneNumber and not the actual display name of the user. This may confuse the user as what login credentials to use. Here is the screenshot:

Screenshot_2.jpg

 

 

 

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

View solution in original post

3 REPLIES 3
Highlighted
VIP Engager

Hi,

It is possible to change the Nickname to ipPhone or telephoneNumber parameter with following jabber-config.xml parameters:

 <Directory>
   <DirectoryServerType>EDI</DirectoryServerType>
   <Nickname>telephoneNumber</Nickname>
   <BDINickname>telephoneNumber</BDINickname>
 </Directory>

After you change the jabber-config.xml file, perform following procedure:

  1. Upload jabber-config.xml to all CUCM TFTP Servers.
  2. Restart Cisco TFTP Service on all CUCM TFTP Servers.
  3. Sign Out from Cisco Jabber client
  4. Reset Jabber and Sign In to Cisco Jabber

Here is the screenshot:

Screenshot_1.png

When you perform this change you will come across two issues:

Issue 1:

It affect all the users and it also affects your contact display. All your contacts will be displayed using their telephoneNumber and not the actual display name. You can change contact display name manually.

 

Issue 2:

When you logout from your Jabber, you will see login display name as telephoneNumber and not the actual display name of the user. This may confuse the user as what login credentials to use. Here is the screenshot:

Screenshot_2.jpg

 

 

 

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

View solution in original post

Highlighted

I've made these changes, including uploading and resetting TFTP a few times, but no changes happen within the Jabber client. Whether I set it to telephonenumber or ipPhone, it still just shows the username with an @ symbol at the end for some reason. Here's my current config file...

 

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
<Directory>
<DirectoryServerType>EDI</DirectoryServerType>
<Nickname>ipPhone</Nickname>
<BDINickname>ipPhone</BDINickname>
</Directory>
<Options>
<DockedWindowVisible>false</DockedWindowVisible>
</Options>
<Voicemail>
<VoicemailService_UseCredentialsFrom>phone</VoicemailService_UseCredentialsFrom>
<VoicemailPrimaryServer>voicemail.XXX.com</VoicemailPrimaryServer>
</Voicemail>
<Policies>
<PreferredFT>P2P</PreferredFT>
<ServicesDomainSsoEmailPrompt>OFF</ServicesDomainSsoEmailPrompt>
</Policies>
</config>

Highlighted

Hi,

Please add presence domain in the jabber-config.xml file:

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
 <Presence>
   <PresenceDomain>yourdomain.com</PresenceDomain>
 </Presence>
</config>

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.