cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Upgrade using WinSCP.pdf

6903
Views
10
Helpful
5
Comments

Hi,

This  document will help you upgrade the TC series codecs using WinSCP. If you have any  additions to be done on this document, please let me know.

Regards,

Mubashshir  Akhtar

TelePresence Support Team

Comments
Beginner

Thank you Mubashshir, this is exactly what I was looking for.

Contributor

Hey Mubashshir,

How is this procedure affected by the TC7+ code now that root access has been removed? Does the temporary privileged account that would have to be obtained through TAC give us the right to SCP files across to CODEC?

I have a user where this might be the only may to update their CODECs and obtaining temporary privileged accounts for each CODEC, every time we want to upgrade is going to be a pain.

Regards,

Chris

 

Chris -

You'll need to contact TAC and get the password to login with the remotesupport account to use WinSCP with the codec unfortunately.

Regarding WinSCP, it's mentioned in the below discussion, Mangus' comment about uploading of software to the codec, Wayne later replies and acknowledged that this method works:

Upload the package to the /tmp folder (remotesupport has write access here) and log in as the remotesupport user.

Then run the command: sudo installimage <package name>

https://supportforums.cisco.com/discussion/12166996/tc71-now-released-and-available-ciscocom

Beginner

I tried the method described with a C20 TC6.2 and loading the s52000tc7_3_2 pkg, but the automatic extract did not start. Tried a restart and reboot still no update. The rights are rw-r--r-- owner root. There is also an upload directory under the upgrade directory. Any idea what may be the issue?

Frequent Contributor

[@joel.stanfield]  - for you, or anyone else who stumbles on this (like I did), you can do the following:

  1. Put s52000tc7_3_6.pkg (or whatever file) in the /upgrade directory with SCP (or SSH on and use cURL or scp to pull it down).  No need to change the filename.
  2. SSH to the endpoint and login as root (note: root login disabled in TC7.1)
  3. run "installimage -f [filename of pkg]" (no quotes)
  4. it will then upgrade (and you can see it progress while the SSH session stays up)

NPM

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards