cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2781
Views
45
Helpful
18
Replies
afaudale
Beginner

AQM and Extension Mobility - Phone Based Recording

I'm trying to understand how to properly configure AQM phone based recording with Extension Mobility. I have been able to get call recording working with a phone that is hard set with an extension and associated to a user account. However, all of our agents use extension mobility as they float desks often. What I don't understand is the line on the phones are set to auto DNs and when I configure them for call recording, I am still unable to pull them into AQM. I'm assuming I am doing this incorrectly, and I have been through the configuration guide and administration guide and can't seem to find a clear answer on how to properly set this up.

 

I do have all the device profiles pulled into AQM users assigned to their appropriate device profiles. But I don't see the phones available to pull in when I search. I do see events in the event logs that say "QM2024 [SEVERE] The user Jane Doe with user loginjdoe is licensed, however not correctly configured for recording."

 

CUCM - 11.5.1

AQM - 11.5.1

 

Thanks in advance for the help!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Graham,

 

We got this figured out. I guess during the configuration of the QM Server a couple months back, I configured a filter in Telephony Groups (filter button next to CDR Configuration button). In that filter I specifically added our Call Center DN range. I don't recall doing this but the documentation must have mentioned otherwise I would have never set that up. I apologize for wasting your time but I really appreciate your help through the troubleshooting process. Your insight was more helpful than Cisco TAC or Calabrio Support during this entire process.

 

Thank you sir!

View solution in original post

18 REPLIES 18
Graham Old
Rising star

On UCM make sure the Built in Bridge is enabled on the phone, don't setup call recording on the phone directory number

On UCM in the users device profile set "Recording Option" to Automatic Call Recording Enabled and select the Recording Media Source. If this user will also be doing silent monitoring then select a "Monitoring Calling Search Space"

On CR in the Quality Management Administration VoIP Devices table, import both the phone by its SEP name and the Users Device Profile. Make sure the Phone is set to Network Recording and you have selected the Signalling Group and Recording Cluster. Leave the Agent setting on the phone to "User Login Required"

On the User Device profile set the Agent to the CR User. Leave the other columns to "No Configuration" and the Recording Type to none.

As long as the user logs into a phone that is listed by its SEP name in the VoIP Devices they will be recorded.

Remember to do the Device Association on UCM so CR can observe the phone.

You may need to get the user to do an EM logout/login cycle for QM to pick up the correct phone if you have just configured this user on CR.

Graham

Hi Graham,

 

Thank you for the thorough information. However, when I go to "Enable Unified CM Device for Recording", I don't see any of the actual phones listed to add. The phones have been added to the Jtapi application user account. BIB is by default set to on globally. But I have tested and set it manually to On but still no dice. Most of these phones have Auto-DNs assigned to Line 1 or none at all. Am I missing something else here? 

 

Thanks for the help!

When you add phones or device profiles to the VoIP Devices table using Enable Unified CM Devices for Recording that uses the AXL interface on UCM and the Soap AXL Interface user you setup in Telephony Groups.

On UCM go to Cisco Unified Serviceability/Tools/Service Activation select the Pub and make sure the "Cisco AXL Web Service" is activated.

In the CR Monitoring and Recording Administrator go to System Configuration/Telephone Groups and select the Unified CM.

Check the Username, Password and UCM version is correct.

Capture.PNG

If it still fails to find any phones change your AXL username and password to the CCM administrator ID. You need a lot of privileges for the AXL user and try again.

Graham

Hi Graham,

 

Thanks again for the helpful detailed information. The service is activated and I confirmed the AXL username, password, and UCM version, but the phones still don't show up. I also changed to the ccm administrator username and password with no luck. I think at this point I will need to engage Cisco TAC. I will follow-up with resolution once we get this figured out.

 

Thanks again for the help!

It uses the UCM AXL interface to load Phones and Device Profiles into the VoIP Devices Table. Once they are in the table it will use Jtapi to monitor them. If you can't get them into the table you are not getting as far as Jtapi.

The version in the screen shot is the UCM version, is that set correctly?

The logs are in: Program Files\Cisco\WFO_QM\log

You need to look at the admin.dbg log and search for the UCM IP Address. You should see something like this:

2019-06-25 20:46:46,089 DEBUG [findTask<4>.1|AxlDeviceQuery#doDeviceQuery:77] AXL SQL: SELECT DISTINCT D.name AS name, NP.dNOrPattern AS extension, PT.moniker AS profType, RP.name as partition FROM Device AS D JOIN typedeviceprofile AS PT ON D.tkdeviceprofile = PT.enum LEFT JOIN DeviceNumPlanMap AS M ON M.fkDevice = D.pkid LEFT JOIN NumPlan AS NP ON NP.pkid = M.fkNumPlan LEFT JOIN RoutePartition RP ON NP.fkRoutePartition = RP.pkid WHERE ((PT.moniker = 'DEVICE_PROFILE_REAL_DEVICE' AND (UPPER(D.name) LIKE 'SEP%' OR UPPER(D.name) LIKE 'LCP%' OR UPPER(D.name) LIKE 'CSF%' OR UPPER(D.name) LIKE 'CIPC%' OR UPPER(D.name) LIKE 'IPC%')) OR (PT.moniker = 'DEVICE_PROFILE_USER_PROFILE')) AND UPPER(D.name) LIKE UPPER('%') ORDER BY D.name, NP.dNOrPattern
2019-06-25 20:46:46,089 DEBUG [findTask<4>.1|AxlConnection#getConnection:209] Trying AXL Connection to url: https://172.17.1.21:8443/axl/
2019-06-25 20:46:46,323 INFO QMPI0000 [findTask<4>.1|AxlConnection#getValidAxlConnection:266] Response Code= 200

The "Response Code = 200" is a 200 OK http response.

Graham

Hi Graham,

 

Yes, I am also seeing the Response Code= 200. However, the timestamp shows 4/4/2019. I don't see a recent timestamp. Should I be seeing a recent timestamp? Attached is a screenshot.

 

Thanks,

When you go into "Enable Unified CM Device for Recording" and click Find the AQM should make a SQL query to the AXL interface on UCM.

The debug output I posted shows it building the SQL query and then this line is it making the request to UCM.

2019-06-25 20:46:46,089 DEBUG [findTask<4>.1|AxlConnection#getConnection:209] Trying AXL Connection to url: https://172.17.1.21:8443/axl/

If you don't see that line with the current time and date then it never made a query to UCM

In Telephoney Groups under the UCM configuration does your setup define the "AXL Provider" ip address.

Untitled.png

On  this system 172.17.1.21 is the UCM publisher

Graham

Hi Graham,

 

Yes, it does show our Publisher IP address in line 1 and our Subscriber node in line 2. Attached is a screenshot of the line for the Publisher. You can also see the version information is set to 11.5.

 

Additionally, I have browsed to https://10.16.133.200:8443/axl/ on the AQM server and was able to successfully validate the server is working and accepting requests. The credentials I entered are the same ones I have in the configuration. See second screenshot "AXL-Working".

 

Thanks