Showing results for 
Search instead for 
Did you mean: 

Cisco Unified CCX Historical Reports - Admin Rights?

We have Cisco CCX 9.0.2 and I'm trying to get Cisco Unified CCX Historical Reports, (version, software to run for a couple of our users.  The problem is Cisco requires this program to be run with administrator rights, and these are just standard users using the software.

Any idea how to do this?

I tried creating a shortcut to save the credentials for a local admin to windows credential manager, but it doesn't seem to start.  I get a cmd prompt for credentials, but after that it just closes and does nothing.

I also tried moving the program out of "Program Files (x86)" which removed the admin rights requirement, but came with a registry error.  I started updating the registry to point to the new location, but jesus christ I've made about 100 registry edits for this program and still have more to go (no idea if this is even going to work or just FUBAR the program completely).

Is there a newer version Cisco has I can install?  The program feels very XPish and requiring admin rights is a bit ridiculous.  

Chris Deren
Hall of Fame Master

CCX 9+ uses CUIC reporting which is accessible from the web not the HR client.

What would be the CUIC web portal be?  When I go to the CCX server the only options are for administration, I don't see anything for end user reporting.  Is CUIC a separate server from CCX?

CUIC is embedded in CCX and can be accessed via https://<server>:8444/cuic/Login.htmx

I'm trying that but the page won't load.  Is CUIC something that is enabled on CCX by default, or does it need to be configured?  

Here is a video showing how to enable it:

You will need to enable it as HRC is the default reporting client in UCCX 9. I don't have UCCX 9 server in front of me but I believe you can change it by going into CCX Administration >> Tools >> Historical Reporting >> Reporting Configuration. After this, you will also need to restart the Cisco Unified Intelligence Center Serviceability Service and Cisco Unified Intelligence Center Reporting Service by going to Cisco Unified CCX Serviceability >> Tools >> Control Center - Network Services.



Is there any other services that need to be restarted?  I can now get to the CUIC login page and I also noticed the client no longer works, however the CUIC login page keeps giving me an "Invalid username or password.  Please try again."  

I just went back into Tools > User Management > Reporting Capability and double checked my login is given this access and it is, so is the default 'uccxadmin' account as well and I am getting the error on both.  I just removed my AD account and re-added it but get the same error.

Did you get a chance to read the documentation?

Yes but nothing mentions not being able to log in.  I just changed back to the client, was able to log into that just fine, and again switched back to the CUIC config and can't log in with any accounts that are set with reporting and/or administration capabilities.

Recognize Your Peers
Content for Community-Ad