cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1058
Views
0
Helpful
23
Replies
mesumbeslin
Beginner

CTI Agent desktop goes to reserved after agent logs in

Hey,

I have a little problem that keeps comming up now and then in my CC.I am running Hosted edition.On some Ext. when agents login to cti agent desktop,the agent is immediately taken to reserved state once they click on ready button.Calls are routed to this agent but being in reserved state..the cti then logs out the agent after some time.

What could really be the cause of this? and how do I resolve it permanently?

23 REPLIES 23

This is common problem however has different causes. The bottom line is an agent may or may not be available or cannot accept the call either call is not presented or he has too short of time so on....

All these cause agent to be put on reseved state so that next call is not offered. Try debugging your script step by step. Also check your group and agent settings for ansewering the calls.

Hi,

i've a similar problem with IPCC enterprise outbound option. When an agent to be reserved for a PersonalCallback call, he go into reserved state and stay here without a real call to do. After the CTI popup an error messege and the agent will be put into not ready state.

This happens only when a personal callback call is attemped to the agent.

thanks in advance for your support.

David

kre8or2007
Beginner

Check to see if any other agents have logged in to that agent's extension

Thanks for the replies.I noticed that when I change the IPphone,configure the new IP phone to use same DN,agents are no longer put in the reserve state. Otherwise,the settings for the old IP phone that puts agents to reserve state looks fine.

That's what I can't understand

I also have a similar problem.

The exact scenario is as follows

1. Agent logs in and goes to ready. IF a call is in queue it will be presented.

2. Internal call is made to same skill group as above and call queues. Hang the call up. Make agent available.

3. The agent goes reserved as the call does not appear to have been 'dropped' by the router and it is a phantom call.

4. The agent will remain in reserved for the default time (30s) but no call will be delivered because it has dropped.

5. External calls are correctly removed from queue when they drop in queue.

This is on IPCC 7.2 with IPIVR 4.1 and CAD.

Can you test this scenario and advise if you get the same results.

I have an open TAC on this and will update when I have more info.

I have exactly the same issue, change the phone and it works. Did anyone find fix for this

Hi,

The problem lies with the device target!Both the NAM and CICM should have a device target entry with HIPCC.You may check and the device target exists,delete and recreate.If possible,delete the device from CCM,re-add it,re-associate it to the ICM user and then add the device target to both the NAM and CICM.

That worked for me.

Will give that a go. Was it a bug or just trial end error.

I can't exactly tell if it is a bug.for three devices,there existed device targets,but the prob had persisted.For the rest,there was no device target on the NAM,but there existed device targets on the CICM.For those I added,it worked,for the three,I deleted and re-added.

Maybe it's a bug,I don't know,but now,everytime I get the problem,I go through the proceedure i gave and all gets fixed.

Content for Community-Ad

Spotlight Awards 2021