cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1358
Views
10
Helpful
4
Replies
Beginner

CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

We are trying to create a new Data Source connection(SQL Server) in UCCX CUIC 11.6. We are able to connect the DB server is SQL Server Management Studio but while creating a new Data Source using the same SQL Credentials in CUIC, we are facing an error saying "Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'". Could any one help me to fix this issue?

 

Let me know if any additional information is required.

Thanks and Regards,
Sathiya Kumar V M
CUIC Developer
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
HMO Beginner
Beginner

Re: CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

Please check the following:

-   MSSQL is listening on 1433

-   Hostname of db or IP can be resolved and is reachable from CUIC

-   The account provided has access to the DB

4 REPLIES 4
HMO Beginner
Beginner

Re: CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

Please check the following:

-   MSSQL is listening on 1433

-   Hostname of db or IP can be resolved and is reachable from CUIC

-   The account provided has access to the DB

Advocate

Re: CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

This may not be relevant to your set up - but this error message is also seen when there is a mismatch between TLS versions on client and server.

Regards,
Geoff

Highlighted
Beginner

Re: CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

Thanks for the answer. In my case I checked the data source and it is working when I replaced Hostname with IP address. Hostname is not working and IP is working.

Thanks and Regards,
Sathiya Kumar V M
CUIC Developer
Advocate

Re: CUIC Data Source Creation Error - Invalid Sub-Protocol Invalid Sub-Protocol 'sqlserver'

Perhaps your CUIC is not configured correctly for DNS lookups. You could log into it at the CLI and check with the following command that is equivalent to nslookup - utils network host NAME

 

utils network host (name)

This command resolves a hostname to an address, or an address to a hostname. This command looks for the host locally first. If it cannot resolve it locally, and DNS is configured, then it does a DNS lookup.

 

Command Syntax

utils network host name

PARAMETER name is the name of the host or address to resolve.

 

So try that with the short name and try it also with the Fully Qualified Domain Name. 

 

The other thing you can do (something that is more relevant to UCCE where there are Primary and Secondary hosts in the datasource for redundancy and there are often a number of CUIC servers) is to put a totally dummy name in the datasource (like "primary") and use the CLI command 

 

set cuic properties host-to-ip 

 

to provide an IP address for the dummy name "primary".

 

set cuic properties host-to-ip

 

This command sets the host-to-ip translation and is used when there is a need to configure and IP address for one of the Unified CCE Databasesthat is unique to the member node from which you are running the command. This command allows for scalability and overrides the default Historical or Realtime database server that is defined in the Data Sources interface.

 

(Not sure if the CUIC used for UCCX is hobbled in some way and not all CLI commands are allowed.)

 

Regards,

Geoff

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards