Showing results for 
Search instead for 
Did you mean: 

CVPv11 DB Element Fails For Long Digits

Faisal Zaidi

I have created a new test app ‘FaisalTest’. In it the caller enters a dnis and the DB dip is made using the entered digits.. if a 6 digit number like 444444 is entered everything succeeds.


But if I enter a longer number string >=8 digits, the app bombs out on the lookup, here is the output for dnis 111111111111 failing on the DB element:,08/11/2016 15:28:28.638,Subdialog Start_01,enter,,08/11/2016 15:28:29.638,Subdialog Start_01,exit,done,08/11/2016 15:28:29.638,Digits_01,enter,,08/11/2016 15:28:29.638,Digits_01,interaction,audio_group,initial_audio_group,08/11/2016 15:28:47.959,Digits_01,interaction,utterance,111111111111,08/11/2016 15:28:47.959,Digits_01,interaction,inputmode,dtmf,08/11/2016 15:28:47.959,Digits_01,interaction,interpretation,111111111111,08/11/2016 15:28:47.959,Digits_01,interaction,confidence,1,08/11/2016 15:28:48.029,Digits_01,data,value,111111111111,08/11/2016 15:28:48.029,Digits_01,data,confidence,1,08/11/2016 15:28:48.029,Digits_01,data,value_confidence,1,08/11/2016 15:28:48.029,Digits_01,data,nbestConfidence1,1,08/11/2016 15:28:48.029,Digits_01,data,nbestUtterance1,111111111111,08/11/2016 15:28:48.029,Digits_01,data,nbestInputmode1,dtmf,08/11/2016 15:28:48.029,Digits_01,data,nbestInterpretation1,111111111111,08/11/2016 15:28:48.029,Digits_01,data,nbestLength,1,08/11/2016 15:28:48.029,Digits_01,exit,done,08/11/2016 15:28:48.029,Database_01,enter,,08/11/2016 15:28:48.029,Database_01,exit,,08/11/2016 15:28:48.029,,element,error,,08/11/2016 15:28:48.029,ERROR ELEMENT,enter,,08/11/2016 15:28:48.029,ERROR ELEMENT,exit,,08/11/2016 15:28:48.029,,end,how,app_session_complete,08/11/2016 15:28:48.029,,end,result,normal,08/11/2016 15:28:48.029,,end,duration,19


The error log shows the following, which looks like a type mismatch between the number 111111111111 and string ‘111111111111’:,08/11/2016 15:28:48.029, The error was: A built-in element encountered an exception of type java.lang.NumberFormatException. The root cause was: java.lang.NumberFormatException: For input string: "111111111111"
com.audium.server.AudiumException: A built-in element encountered an exception of type java.lang.NumberFormatException.
       at com.audium.server.voiceElement.ActionElementBase.service(
       at com.audium.server.controller.Controller.goToAction(
       at com.audium.server.controller.Controller.goToElement(
       at com.audium.server.controller.Controller.continueCall(
       at com.audium.server.controller.Controller.doPost(
       at javax.servlet.http.HttpServlet.service(
       at javax.servlet.http.HttpServlet.service(
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(
       at org.apache.catalina.core.StandardWrapperValve.invoke(
       at org.apache.catalina.core.StandardContextValve.invoke(
       at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
       at org.apache.catalina.core.StandardHostValve.invoke(
       at org.apache.catalina.valves.ErrorReportValve.invoke(
       at org.apache.catalina.core.StandardEngineValve.invoke(
       at org.apache.catalina.connector.CoyoteAdapter.service(
       at org.apache.coyote.http11.AbstractHttp11Processor.process(
       at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
       at java.util.concurrent.ThreadPoolExecutor.runWorker(
       at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.lang.NumberFormatException: For input string: "111111111111"
       at java.lang.NumberFormatException.forInputString(
       at java.lang.Integer.parseInt(
       at java.lang.Integer.valueOf(


I’ve tried a lot of things to force both the CED and variables to numbers and/or string, eg, by using Digits_01.value in the SQL, converting it to a string element variable or session variable first , but the error above persists... any ideas what I need to do differently - I was not having this problem in CVP 9..? Attached is a screenshot of the app also.. thanks in advance..

1 Accepted Solution

Accepted Solutions

Cisco Employee
Cisco Employee

Chances are that you're hitting defect CSCuy80951.  It was fixed in CVP11.0(1)_ES15 so raise a case and ask the TAC for that or a more recent roll-up.


View solution in original post

7 Replies 7

Cisco Employee
Cisco Employee

Chances are that you're hitting defect CSCuy80951.  It was fixed in CVP11.0(1)_ES15 so raise a case and ask the TAC for that or a more recent roll-up.


Thanks Paul - the symptoms appear to be similar although not exactly the same the error text is identical though so this looks promising as a fix! I'll post the outcome of the ES once applied. Thanks again!

Defects are often worded based on the specific conditions which first exposed them so I think this one has wider impact than described. When I investigated the problem and tried to workaround it, it was something that happened wherever variable substitution was being used with numeric data from digit collection as this was being accessed as a number rather than a numeric digit string, hence the overflow.  There's a simple element here you can try that moves the data to another variable first (  src - Box), and you'd then use that instead for substitution.

Thanks Paul - thanks for the element also but the link to it fails.. please can you re post it?

we have a number of complex scripts imported from v9 so the ES is the way to go for our scenario, but your element would be a handy workaround if the ES is going to take time for us to apply..

Link seems to be open for public access but source is attached if you need as last resort.


Faisal Zaidi

ES15 installed and did the trick - thanks again Paul

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers