cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2234
Views
4
Helpful
3
Replies
zebmustafa14
Beginner

Error "Cisco VTG Realm" while sending request to server?

I am working on Admin APIs , When I send the request to the server such as paste the following link in the browser like:

http://192.168.200.151/unifiedconfig/config/skillgroup?summary=true

This give me the pop-up like:

A username and password are being requested by http://192.168.200.151. The site says: "Cisco VTG Realm"

When I check this in POSTER , the pop-up appear that "401: Unauthorized" and the first line of pop-up body is:
"<html><head><title>Apache Tomcat/7.0.25 - Error report</title>". The credentials are correct because we are using the same credentials to access the server directly.

How I reach this problem , some help would be appreciated.

3 REPLIES 3
ewindgat
Contributor

Are you looking for that specific URL, unifiedconfig? Could you send the URL you are trying to reach.

You might be doing this, you need to be logged in as administrator in one tab in a browser, then in a second tab you may call the API.

Dear Edwin,
Thank you for providing requested information.
Actually I want to get the list of skillgroup and for this I am following "Cisco Unified Contact Center Enterprise Developer Reference Release 10.0(x)".
I tried as you told by first login as an adminitrator then try to send API but same error "403 Forbidden"
But bove document telling us that the following APIs are not available for administrators:
- Skill Group API
- Agent Team API

I also tried supervisor credential but I get "401 Unauthorized" error. When I am send request in Firefox POSTER  with the username i-e <adminuser>@domain then I get status "403 Forbidden".

Kindly provide some guidance to resolve this issue.

bcason
Cisco Employee

Zeb, I was experiencing a similar issue resulting from a mis-reading of the documentation. Rather than using a domain user account for the credentials, you should try using a supervisor agent account configured on the ICM instance. Specifically use the "Login Name" field from that agent's config page. That worked for me...

Content for Community-Ad