cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1431
Views
1
Helpful
11
Replies
Beginner

Finesse API - empty Queues

Hi, I have 2 agents with same configuration (roles, team, skills,....). When using API for queues for specific agent {server}/finesse/api/User/{id}/Queues it work only for one of them. The second gets empty list: <Queues/>. But in cisco finesse app on CSQ Report gadget are queues fine for both user, so it seems problem is only in API.

Also during testing this problem for one agent we come to this:

1) API call returns 2 queues (correct)

2) then we remove all agent skills -> API return no queue (correct)

3) then we add skills back -> API return no queues (and we have no idea why...)

Any help is welcome, we are out of ideas...

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Enthusiast

Re: Finesse API - empty Queues

Are you trying this on CCX? You said “CSQ” so I assume so. The Queue API doesn’t work on CCX.

g.

View solution in original post

11 REPLIES 11
Highlighted
Contributor

Re: Finesse API - empty Queues

If everything is the same for both agents, data, roles, etc. All I can think is maybe the browsers are different? Chrome is not supported. Is that the case?

Highlighted
Beginner

Re: Finesse API - empty Queues

It is tested from my computer from same browser - IE.

Highlighted
Enthusiast

Re: Finesse API - empty Queues

Are you trying this on CCX? You said “CSQ” so I assume so. The Queue API doesn’t work on CCX.

g.

View solution in original post

Highlighted
Beginner

Re: Finesse API - empty Queues

Yes on CCX. If I understand it correct API should work, only statistics for queues will be all -1 and not updated. And it work this way for some users:

....finesse/api/User/test1/Queues returns

<?xml version="1.0"?>

<Queues/>

and ....finesse/api/User/test2/Queues returns

<?xml version="1.0"?>

<Queues>

  <Queue>

    <name>q_queue1</name>

    <statistics>

      <agentsNotReady>-1</agentsNotReady>

      <agentsReady>-1</agentsReady>

      <agentsTalkingInbound>-1</agentsTalkingInbound>

      <agentsTalkingInternal>-1</agentsTalkingInternal>

      <agentsTalkingOutbound>-1</agentsTalkingOutbound>

      <agentsWrapUpNotReady>-1</agentsWrapUpNotReady>

      <agentsWrapUpReady>-1</agentsWrapUpReady>

      <callsInQueue>-1</callsInQueue>

      <startTimeOfLongestCallInQueue></startTimeOfLongestCallInQueue>

    </statistics>

    <uri>/finesse/api/Queue/2</uri>

  </Queue>

  <Queue>

    <name>q_chat</name>

    <statistics>

      <agentsNotReady>-1</agentsNotReady>

      <agentsReady>-1</agentsReady>

      <agentsTalkingInbound>-1</agentsTalkingInbound>

      <agentsTalkingInternal>-1</agentsTalkingInternal>

      <agentsTalkingOutbound>-1</agentsTalkingOutbound>

      <agentsWrapUpNotReady>-1</agentsWrapUpNotReady>

      <agentsWrapUpReady>-1</agentsWrapUpReady>

      <callsInQueue>-1</callsInQueue>

      <startTimeOfLongestCallInQueue></startTimeOfLongestCallInQueue>

    </statistics>

    <uri>/finesse/api/Queue/3</uri>

  </Queue>

  <Queue>

    <name>q_queue2</name>

    <statistics>

      <agentsNotReady>-1</agentsNotReady>

      <agentsReady>-1</agentsReady>

      <agentsTalkingInbound>-1</agentsTalkingInbound>

      <agentsTalkingInternal>-1</agentsTalkingInternal>

      <agentsTalkingOutbound>-1</agentsTalkingOutbound>

      <agentsWrapUpNotReady>-1</agentsWrapUpNotReady>

      <agentsWrapUpReady>-1</agentsWrapUpReady>

      <callsInQueue>-1</callsInQueue>

      <startTimeOfLongestCallInQueue></startTimeOfLongestCallInQueue>

    </statistics>

    <uri>/finesse/api/Queue/1</uri>

  </Queue>

</Queues>

Highlighted
Beginner

Re: Finesse API - empty Queues

Hello,

I'm experiencing the same issue.

The Finesse API documentation does not state that the User Queues API works only on CCE

Is this formal?

Thanks,

Eliav

Highlighted
Contributor

Re: Finesse API - empty Queues

Yes, I found out that the documentation will be updated. Agent queues are only available in CCE, not CCX

Highlighted
Beginner

Re: Finesse API - empty Queues

I don't get it. So it is bug in CCX that it works for some agents?

Highlighted
Contributor

Re: Finesse API - empty Queues

The queues are only available in CCE, not CCX. The documentation says they are available in CCX. The documentation will be updated. This is not a product bug, but an issue with the documentation.

Highlighted
Beginner

Re: Finesse API - empty Queues

From our experience, the Queues API for Finesse works if you do not change skills for users.

After you add/modify skills for a specific user, you get an empty list of queues for that user using the API. Only a Tomcat restart gets the list back to being correct.

We have based a project on the availability if this API on CCX and it just didn't work! And instead of getting a patch/workaround from Cisco - we got an answer that's it's a mistake in the documentation and will not be resolved! Annoying!

If anyone has a simple method of getting Queues for a user on CCX - I'd be happy if you could share with us

Thanks

Sent from my iPhone

Highlighted
Beginner

Re: Finesse API - empty Queues

Because we are already using UCCX DB (uccxhruser) we get queues for user from there. It is in rtcsqssummaries table (must be enabled in UCCX administration - Tools &gt; Real-time snapshot configuration) + several joins to other tables.

Highlighted
Rising star

Re: Finesse API - empty Queues

Eliav: Did you ever report this to Cisco? What was their response? I seem to be experiencing the same. I had hoped to use the Finess API to replace direct DB access / CTI API, but with those limitations, it's not really feasible.

CreatePlease to create content
This widget could not be displayed.