cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4527
Views
5
Helpful
29
Replies

My MR PIM is Not comming Up

I have installed CUCM PG, MR PG, and Dialer installed on one Server.

 

My Dialer status is :

baDialer_ip.exe : icm9-Dialer BADialer_IP [CM-A] [CTI-U] [Ports-X] [MR-X] : 01:46:38
 
 
My MR PG status is:
MR_PIM.exe : icm9-PG3A MR_PIM - pim1 - [MRPG_1 ACTIVATING] : 01:45:17
MR_PIM.exe : icm9-PG3A MR_PIM - pim1 - [MRPG_1 IDLE] : 00:36:42
 
pgagent.exe : icm9-PG3A pgagent - (InSvc A:Active B:Disc) : 02:46:50
 
 
Here are my MR PG logs where MR PIm is Getting established but getting closed down.
 
16:00:23:760 PG3A-pim1 Attempting to connect to MR application at IP address: 192.168.1.91, port: 42067.
16:00:23:760 PG3A-pim1 Connection to MR application established.
16:00:23:761 PG3A-pim1 Trace: Transport::RecvBytes. SOCKET_ERROR=10054.
16:00:23:761 PG3A-pim1 Error receiving data from MR application.
  Last API Error [10054]: An existing connection was forcibly closed by the remote host.
16:00:23:761 PG3A-pim1 Trace: MR Application message format error. Missing message body..
16:00:23:761 PG3A-pim1 Trace: MR_Application::Receiver. Problem with receiving application messages.  Exit Receiver thread..
16:00:33:855 PG3A-pim1 Timeout occurred waiting for response to message: OPEN_REQ.
16:00:33:855 PG3A-pim1 TCP connection to MR application has been broken.
16:00:54:756 PG3A-pim1 Process PIM set idle request: peripheral: 5002, going idle.
16:00:54:757 PG3A-pim1 Peripheral: 5002, sending OPC: PIM_OK_ACK, acknowledgment for command: PIM_SET_IDLE_REQ (Trans ID: 284).
16:01:54:756 PG3A-pim1 Process PIM set idle request: peripheral: 5002, going idle.
 
1 Accepted Solution

Accepted Solutions

i see your pim is trying to connect to MR application on port 42067, even if you have specified the port as 38001.

please cycle the dialer and PG and if possible attach logs of badialer and MR pim here, so we can walk through logs.

 

regards

Chintan

View solution in original post

29 Replies 29

Chintan Gajjar
Collaborator
Collaborator

must be config issue, can you please share a dialer installation steps?

and also MR PG installation steps, specifically for MR pim configuration?

 

Chintan

(CVP PG,AW/HDW,ROuter,LOgger) -- 192.168.1.22

(CUCM PG,CTIserver,Dialer,MR PG) -- 192.168.1.91


Dialer Configuration

**Node Manager Properties
Production Mode: Enabled
Auto Start at system startup: Enabled

**Dialer Type
SCCP

**Outbound option Dialer Properties
Campaign Manager Server: 192.168.1.22
CTI Server A: 192.168.1.91
CTI Server Port A: 42067
Heart Beat: 500
Media Routing Port: 38001
CUCM TFTP server 192.168.1.51


MR PG COnfiguration

**Logical Controller ID-- 5002
** Pripheral Interface Managers
Peripheral Name MRPG_1
Peripheral ID 5002
Application Hostname 192.168.1.91
Application Connection Port 38001


** PG Interface 192.168.1.91
Router 192.168.1.22

i see your pim is trying to connect to MR application on port 42067, even if you have specified the port as 38001.

please cycle the dialer and PG and if possible attach logs of badialer and MR pim here, so we can walk through logs.

 

regards

Chintan

Hey Chintan

Attaching the Logs:

MR PG: PIM, PGAG, MDS, OPC

Dialer: Badialer

Logger: BAimport, CampaignManager.

 

also can you tell me is my configuration correct or wrong

is there any dependance on installation on the same server, and also 1 point i in my lab have not configured private IPs are they essential.