cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
378
Views
0
Helpful
2
Replies
Highlighted
Cisco Employee

Not able to get CONFIG_AGENT_EVENT

Hi,

I have specified CONFIG_AGENT_MASK | CONFIG_APPLICATION_MASK as the mask in OPEN_REQ.


I do get the CONFIG_KEY_EVENT event in response to CONFIG_REQUEST_KEY_EVENT. However, all the keys are 0. Is this expected?


I then send a CONFIG_REQUEST_EVENT event with mask 0x00000001. In response, I get the CONFIG_BEGIN_EVENT ConfigType == 1 ConfigurationMask == 0x2, CONFIG_CSQ_EVENT, and then CONFIG_END_EVENT with Status == CONFIG_SUCCESS. I don't get the CONFIG_AGENT_EVENT. I tried the CONFIG_REQUEST_EVENT with different mask - 0x00000002, 0x00000004, x00000008 without any success.


Please let me know,

Saibal Das

2 REPLIES 2
Beginner

Re: Not able to get CONFIG_AGENT_EVENT

I have a similar problem, so I'll add to this discussion rather than create a new topic.

 

In my case, I can send CONFIG_REQUEST_EVENT with a ConfigInformation mask of 4, to get a dump of current agent configuration. That works as expected, and I get CONFIG_BEGIN_EVENT, a bunch of CONFIG_AGENT_EVENT, and CONFIG_END_EVENT. All agents events have a RecordType of Add.

 

However, after that initial dump, the documentation suggests I should get updates, as long as in my OPEN_REQ I include a ConfigMsgMask of 4 (for agent config). I do not. 

 

The documentation could also be read that I need to send another CONFIG_REQUEST_EVENT with a mask of 0 to signal that I am ready to receive updates, the updates being specified in OPEN_REQ. I tried that too, and no updates.

 

So I am at a loss as to how to get updated agent configuration using the CTI. Suggestions?

Beginner

Re: Not able to get CONFIG_AGENT_EVENT

Moving to new topic as this one seems to be old and not the CTI I am using.
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards