cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1038
Views
0
Helpful
7
Replies
skumar0011
Beginner

PCCE 11.6 installation failed

Hi Team,

I am trying to install #PCCE 11 6 lab mode gone through each step of the Cisco installation guide and followed all steps.At the #PCCE admin login page Deployment Type selected as  Packaged  CCE  Lab mode got below erro

Error occurred

Internal Server Error. Try again later or contact your system administrator.
In the Tomcat logs 

Please help me on this issue and get away of this. Appreciate your consideration.

Thanks

Sandeep M

7 REPLIES 7
Omar Deen
Collaborator

Post the Tomcat logs

Hi Omar,

 

Here are tomcat Logs:

 

0000000266: 10.10.34.121: Oct 01 2019 05:07:39.751 -0700: %CCBU_171-DEPLOYMENTTYPEINFO-UPDATE-1-6-REST_API_INFO: Could not find any Routing Clients of type 30 with Logical Controller of type 30 (CUCM PG), 13 (VRU PG)
0000000059: 10.10.34.121: Oct 01 2019 05:07:39.754 -0700: %_171-DEPLOYMENTTYPEINFO-UPDATE-1-4-org.hibernate.engine.jdbc.spi.SqlExceptionHelper: SQL Error: 102, SQLState: S0001
0000000060: 10.10.34.121: Oct 01 2019 05:07:39.754 -0700: %_171-DEPLOYMENTTYPEINFO-UPDATE-1-3-org.hibernate.engine.jdbc.spi.SqlExceptionHelper: Incorrect syntax near ')'.
0000000267: 10.10.34.121: Oct 01 2019 05:07:40.187 -0700: %CCBU_http-bio-127.0.0.1-8080-exec-4-3-REST_API_EXCEPTION: %[exception=com.cisco.ccbu.api.jaxb.error.ApiException: could not extract ResultSet][message_string=uncaught exception thrown by the api]: The REST API has caught an exception
0000000268: 10.10.34.121: Oct 01 2019 05:07:40.190 -0700: %CCBU_http-bio-127.0.0.1-8080-exec-4-3-EXCEPTION_INFO: %[build_date=Jul 28, 2017 3:37 PM][build_type=rel][exception=com.cisco.ccbu.api.jaxb.error.ApiException: could not extract ResultSet
at com.cisco.ccbu.cce.unifiedconfig.async.AsyncResponseGenerator.rethrowException(AsyncResponseGenerator.java:91)
at com.cisco.ccbu.cce.unifiedconfig.async.AsyncResponseGenerator.generateResponse(AsyncResponseGenerator.java:45)

 

Caused by: org.hibernate.exception.SQLGrammarException: could not extract ResultSet

 

Thanks,

Sandeep.M

Hi Sandeep,

 

I also faced the same issue . Please check the Public and Private connectivity for Rogger & PG. (Pairs)

If you do not have Private network please assign Same range of Public IP address with Default Gateway . 

 

Ram.S

 

 

Hi Ram,

 

Thank you very much for the reply.I have verified Public and Private connectivity for Rogger & PG and they looks good.I have restarted AW,PG, Rogger for safe but still getting same error.

 

Tomcat Logs:

 

0000000046: 10.10.34.121: Oct 02 2019 07:23:02.687 -0700: %CCBU_120-DEPLOYMENTTYPEINFO-UPDATE-1-6-REST_API_INFO: Could not find any Routing Clients of type 30 with Logical Controller of type 30 (CUCM PG), 13 (VRU PG)
0000000044: 10.10.34.121: Oct 02 2019 07:23:02.699 -0700: %_120-DEPLOYMENTTYPEINFO-UPDATE-1-4-org.hibernate.engine.jdbc.spi.SqlExceptionHelper: SQL Error: 102, SQLState: S0001
0000000045: 10.10.34.121: Oct 02 2019 07:23:02.699 -0700: %_120-DEPLOYMENTTYPEINFO-UPDATE-1-3-org.hibernate.engine.jdbc.spi.SqlExceptionHelper: Incorrect syntax near ')'.
0000000047: 10.10.34.121: Oct 02 2019 07:23:02.852 -0700: %CCBU_http-bio-127.0.0.1-8080-exec-6-3-REST_API_EXCEPTION: %[exception=com.cisco.ccbu.api.jaxb.error.ApiException: could not extract ResultSet][message_string=uncaught exception thrown by the api]: The REST API has caught an exception
0000000048: 10.10.34.121: Oct 02 2019 07:23:02.854 -0700: %CCBU_http-bio-127.0.0.1-8080-exec-6-3-EXCEPTION_INFO: %[build_date=Mar 04, 2019 6:19 AM][build_type=rel][exception=com.cisco.ccbu.api.jaxb.error.ApiException: could not extract ResultSet
at com.cisco.ccbu.cce.unifiedconfig.async.AsyncResponseGenerator.rethrowException(AsyncResponseGenerator.java:91)

 

 

at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Unknown Source)
Caused by: org.hibernate.exception.SQLGrammarException: could not extract ResultSet

 

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Incorrect syntax near ')'.

 

Could you please help me on this.

 

 

Thanks,

Sandeep.M

Hi Sandeep,

 

I never installed Packaged CCE: Lab mode for UCCE/PCCE .

 

During PCCE 12.0.1 with Duplex Deployment option I faced the same issue " SqlExceptionHelper: SQL Error: 102, SQLState: S0001”. Later I found side-A Private network not able to communicate side-B ( for your case Lab is simplex so it is not applicable for the above statement) 

 

Please try the below steps.

 

I hope you installed SQL 2014 with SP2 on Rogger & AWD (Restart required for SP2 installation)

 

Verify SQL Client Protocols Properties for Logger, AWD machines
1. Shared Memory
2. Named Pipes
3. TCP/IP

 

Open SQL management studio on Logger & AW with sa/ windows credentials and verify the below

select * from Machine_Address
select * from Machine_Host
select * from Machine_Service
select * from Machine_Connection_Profile

 

also verify sa login authentication with Enforce password policy check in Logger & AW SQL instance.

 

Ram.S

Did you ever resolve this?  I'm encountering the same error and cannot find a fix.

 

Thanks

I had faced the same issue during a fresh install of 11.6 ver initially last year. We did realize the issue with domain in the forest was on the older version ( windows 2003) due to which AD authentication use to timeout.

 

After which we used a local window account to access web administration to complete the deployment.

 

I hope this helps. 

 

Thanks/Manjunath

 

 

Content for Community-Ad

Spotlight Awards 2021