cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1745
Views
0
Helpful
8
Replies
tauqeer.nasir1
Enthusiast

Play Audio while waiting for a process to be completed in Decision Element

Dear,

I am trying to play music on hold while an application is processing on the backend. I am using the following properties

Settings.PNG

Here is my application of which I am using simple class and set 100 seconds delay

App.PNG

in the ABC class, I am simply using sleep for 100 seconds. Logically application will play music on hold configured in root settings. But unfortunately, It is not playing anything and not even error.

8 REPLIES 8
janinegraves
Rising star

what version of CVP do you have? And are you using the VVB? I think

there's a bug in 11.5...

I am using 11.5 and using VVB as well.

Yes, there's a bug... not sure if there's a patch yet. You can look. Try

using an Audio element just prior to your delay, and put the fetchaudio

and its URI in the settings tab, it might work from the element level.

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvd98241/?referring_site=bugquickviewclick

Bug Search Tool

Bug Search <https://bst.cloudapps.cisco.com/bugsearch/>

CSCvd98241

Help  |FeedbackFeedback

VVB Null Pointer Exception with FetchAudio

CSCvd98241

Look like it's been patched. I don't have patch access but see the screenshot below.bug.JPG

Thank you for the response. Can you please guide me how can I do this by using audio element?

At the bottom of the Settings tab there's an area called VoiceXML

Properties. Just enter Name and Value there. It's probably best to

configure both fetchaudio and fetchtimeout there.

You'll need to put something in the Audio tab of the Audio element. If

you don't want to play anything, then point to Cisco's silence.wav file

- you can DeSelect the checkbox for use Default Audio Path, and enter

http://ipaddress/en-us/sys/silence.wav

Hi Janine,

Thank you for your response. I am currently using CVP 11.5(1) and this release is not affected but still facing the same issue.

cvp version.PNG

Try setting the fetchaudio and fetchtimeout in an Audio element just

prior to your web service call.

Settings tab: VoiceXML Property

Name: fetchtimeout  Value: 20s

Name: fetchaudio     Value: http://ip/en-us/sys/something.wav

Audio  tab:  Deselect checkbox for UseRecordedAudio

URI: http://ip/en-us/sys/silence.wav

or

URI:  http://ip/en-us/app/pleaseHoldWhileWeLookThisUp.wav

Content for Community-Ad