Showing results for 
Search instead for 
Did you mean: 

UCCX 7x install

Jason Aarons
Frequent Contributor
Frequent Contributor

I built a lab test CallManager 7.0(1) from production DMA export, then a UCCX 7.0(1) server where we restored the scripts/prompt and setup Agents, etc. We got everything tested and working with UCCX 7.0(1).

Now I need to rebuild my test CallManager 7.0(1) with a newer production DMA export. My question is do I have to rebuild UCCX 7.0(1) from scratch to get the UCM 7.0(1) Enterprise Parameters to show IPCC Express Installed, or can I run the sql update IAQInstalledFlag, or run UCCX 7x Repair? I'm hoping I don't have to run a complete rebuild of UCCX 7x.

9 Replies 9


You should be able to use cet.bat and set it back to fresh_install state and go through the initial setup stuff and get this setup.

Steps to do that

1.Navigate to C:\Program Files\wfavvid\ folder. Double click on cet.bat.

Click on ""

2.Double click on the configuration in the right-hand panel.

3.In the menu select the tab

4.Change the Setup State to "Fresh_Install".

5.Login into appadmin with Administrator and ciscocisco as userid and password.

6.Goto directly User Management Page by clicking next in all other pages without modifying

any information and select an user as administrator.

Jason Aarons
Frequent Contributor
Frequent Contributor

UCCX 7x updates the CallManager 7x database in several unique ways, will doing this process re-update the CallManager 7x database?

Hi there.

I'm facing same installation issues;

New Callmanager 7.0.2 with DMA from existing callmanager and new UCCX 7.0.1 with manual creation of data.

Also need to do fresh Callmanager installation with new DMA on a later time (to minimize loss off customer data adn allow time to test) and it seems that will cause me some problems.

Is it posstible to keep UCCX data and reconect to new CUCM, after this has been remade?

And how is it done?


We sort of got it to work that way. It wasn't nearly as clean as I would have hoped and I ended up spending about 3 hours on the phone with TAC.

I pre-built everything and tested. We established a change lock-out window and I rebuilt the CCM Server during that window. Once I did that, the IPCCx Installed flag wasn't set. I ended up running a repair from the UCCX CDs and it set the flag. I was then able to install SR2. At that point, I did the rest of the configuration and everything was working.... Until I did the HR Data Migrator the morning of the move. I ran the HR Data Migrator and pulled the current Historical Data from the IPCCx server. I then ran the tool on the UCCX server and restored the data. When I did that, it blew away all of my RM config and I had to re-input it all by hand! It was very frustrating!!!

The last part was probably the worst part. We had spent about a day and half entering the RM and JTAPI Data just to have to re-enter all the RM data in about 2 hours...

Jason Aarons
Frequent Contributor
Frequent Contributor

After working with TAC on SR610811625 the Cisco SE indicated the UCCX 7x boxes would have to be rebuilt from scratch. We believe we can re-install OS and UCCX and then restore a UCCX backup, reducing the time to we spent customizing UCCX 7x to the same level as 4x.

I'm trying to understand why UCCX has to be rebuilt technically.

Does UCCX write to the CallManager schema somehow via AXL? This is not LDAP integrated.

In the CM config section, you always has a choice to repoint your UCCX to another CUCM cluster. Therefore the enabling of UCCX Ext in CUCM must be done there, otherwise you can't repoint your UCCX to another cluster.

So you're saying it is possible. I would think that we wouldn't have to rebuild it as it should be the same as if their was a failure and you're restoring from that. We just spent the last 3 days doing the same thing as the topic poster did.


I tried the above using CCM 7.1.3 and UCCX 7.0.1 and the ipcc express installed option never changes from false to true in the enterprise parameters.  Any suggestions?

I talked to tac and if you're running into the issue with false in enterprise parameters you can ssh to the callmanager and input this:

run sql update processconfig set paramvalue="T" where paramname like '%nstalled%'

It cleared it up for me right away on version 7.1.3 of callmanager and 7.0.1 of UCCX

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers