cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

7855
Views
10
Helpful
10
Replies
keanej
Participant

UCCX Appadmin - login failure

Unable to login to Appadmin since installing

8.5.1.11001-35 with patch ciscouccx.851SU1.cop

Able to login to all other pages (like OSAdmin) without problem.

Call Manger stores user database and that looks fine - the ipcc option in call manager enterprise settings is true.

Tried the

utils reset_application_ui_administration_name

and

utils reset_application_ui_administration_password

still not working.

Any ideas ??

10 REPLIES 10
pciborowski
Beginner

Hi,

I had the same problem, during installation you chosed administrator user from ldap? Are you 100% sure that user and password are correct? Try to login on cucm with this credentials.

Regards.

Przemek Ciborowski.

Nope we dont use ldap - I can login to CUCM without problem.

Is there a way to reset the administration user on UCCX ?

Page 30 of the UCCX 8.5 CLI guide:

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/configuration/guide/uccx851cli.pdf

admin:set uccx appadmin administrator username

(output from command) UCCX appadmin adminstrator is set to username

so you need to specifically type in:

set uccx appadmin administrator

- username being the exact name (case sensitive) that you are 100% sure that you assigned to be your appadmin and can log into cucm with

This command worked but I am still getting the problem

     - Log on failed - Invalid User ID or Password

I notice that the CTI phone ports for UCCX are all status unknown. Its unusual that the error doesnt say that the AXL service is a problem. I can log into Call manager with the same username and password - no problem.

Please note I am trying to set the username for the Appadmin page to match that of the CLI - is this a potiental problem ??

Seriously thinking of rebuilding the UCCX again.

There are ALWAYS two different user accounts used:

          a) AppAdmin (aka Administrator user)

          b) OS Platform user

- It sounds like you know the OS Platform user credentials since you can log into CLI.

If you are 100% sure what the AppAdmin user account is in CM that you created you can try resetting the password in the CUCM database.

If you are unsure of which user is assisgned to be the AppAdmin user then you can open up a TAC Case and get assistance to reassign the user from the CUCM user database so you can then log into AppAdmin.

If you are 100% sure what the AppAdmin user account is in CM that you  created you can try resetting the password in the CUCM database.

I have tried using different users as APPAdmin which I know work in Call Manager

If you are unsure of which user is assisgned to be the AppAdmin user  then you can open up a TAC Case and get assistance to reassign the user  from the CUCM user database so you can then log into AppAdmin.

I believe this problem maybe around UCCX not being able to correctly communicate with call manager - that would explain the authentication failures with valid users and also the ports appearing as 'unknown' in Call Manager.

Like I said, the first thing you need to be able to do is have the ability to log into AppAdmin.

If you open a TAC case for assistance with not being able to log into AppAdmin you should be able to get past that issue and then have the ability to see why the ports are not showing up correctly in CUCM.

The process to reassign your AppAdmin user can only be done by TAC.

Hi,

 

add new end user in CUCM administration page, then from UCCX use the command:

set uccx appadmin administrator name_of_new_user_from_CUCM

 

This is how it worked for me.

 

Best Regards,

Petko

shshami
Beginner

Hi All,

- Restart the AXL webservice on the CallManager.

- on the CLI of the UCCX:

set uccx provider ip axl

if no success, please open TAC case and we will arrange a webex meeting and check the issue.

Thanks,

Shadi

- Restart the AXL webservice on the CallManager.

- on the CLI of the UCCX:

set uccx provider ip axl

I attempted this and it did not work. Please note the ports are still 'unknown' on Call Manager. Also when I delete the ports and use the wizard on UCCX to recreate them - they appear on CUCM perfectly but alas - they still appear as unknown.

Create
Recognize Your Peers
Content for Community-Ad