cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
282
Views
5
Helpful
8
Replies
Highlighted
Beginner

Workforce Optimization QM Error during install

Hello, I am trying to install the 11.5 version of QM and I am receiving the following error when trying to install JTAPI.

 

The following installation errors occured:

Could not execute JTAPI installer successfully.

 

Found this in the postinstall logfile.

 

INFO QMUT0000 ExternalProcessOutput <E:\Program Files\Cisco\WFO_QM\bin\jtapi_installer.bat >= This version of E:\Program Files\Cisco\WFO_QM\bin\CiscoJTAPIClient.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.

 

I am attempting to install this on Server 2016. Is this compatible?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star

Re: Workforce Optimization QM Error during install

All the post install does is to install JTAPI as normal and then it copies the jtapi.jar file to

E:\Program Files\Cisco\WFO_QM\ext

Copy your V12 jtapi.jar to that location and reboot your QM server, see if that makes the QM work.

Graham

View solution in original post

8 REPLIES 8
Highlighted

Re: Workforce Optimization QM Error during install

Hi Phil, I've ever got the same case as yours while trying to install version 11.5(1)_SR7_ES9. What I did at that time is to replace the CiscoJTAPIClient.exe on installation folder as in your case E:\Program Files\Cisco\WFO_QM\bin\CiscoJTAPIClient.exe with this one: https://drive.google.com/open?id=1AuaIEY-LWvIUhr7xUpKLDmgilG2xG69B That file is CiscoJTAPIClient from version 11. After that, you just follow the installation guide to continue. Hope it works for you.
Highlighted
Rising star

Re: Workforce Optimization QM Error during install

The QM is trying to download and install JTAPI from your UCM and the version mismatch is between your UCM version and 2016. It is not the QM version.

What is your UCM version, I believe you need at least 11.5 to install on 2016.

Graham

Highlighted
Beginner

Re: Workforce Optimization QM Error during install

I am running CM 12.5. 

 

According to the logs that I posted above it is actually trying to install it from the QM directory on the QM server and there is a jtapiclient.exe setup that got installed with the QM installation. The only way I found this out was by digging through the log files. The install guide doesn't make this obvious.

 

 

Highlighted
Rising star

Re: Workforce Optimization QM Error during install

I would suspect the QM has downloaded the JTAPI installer from UCM to that directory and is trying to run it.

Can you manually download the JTAPI installer from UCM and run it on your 2016 server.

When you install JTAPI from within QM you need to run post install and use Tools (on the top) download/install JTAPI

Graham

Highlighted
Beginner

Re: Workforce Optimization QM Error during install

I downloaded the version off of my 12.5 server and it is now a zip file instead of an exe. I guess since Oracle java is licensed now then Cisco doesn't package this anymore.

Highlighted
Rising star

Re: Workforce Optimization QM Error during install

All the post install does is to install JTAPI as normal and then it copies the jtapi.jar file to

E:\Program Files\Cisco\WFO_QM\ext

Copy your V12 jtapi.jar to that location and reboot your QM server, see if that makes the QM work.

Graham

View solution in original post

Highlighted
Beginner

Re: Workforce Optimization QM Error during install


@Graham Old wrote:

All the post install does is to install JTAPI as normal and then it copies the jtapi.jar file to

E:\Program Files\Cisco\WFO_QM\ext

Copy your V12 jtapi.jar to that location and reboot your QM server, see if that makes the QM work.

Graham


That worked and thanks for posting this! There may be a tech note buried deep within the Cisco world on this but I couldn't find anything. Thanks again!

Highlighted
Beginner

Re: Workforce Optimization QM Error during install

This solution fixed my issue.

Thanks.

AbdulSakkeer
Collaboration Engineer
CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey