cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5438
Views
15
Helpful
9
Replies

n3k-c3172-tq-10gt os upgrade [Installation failed. Return code 0x40930014 (configuration copy failed)]

Jun123123
Beginner
Beginner

n3k-c3172-tq-10gt The operating system of the device was started for the first time.

Version: 7.0 (3) I2 (2b)

Version: nxos.7.0.3.I4.8b.bin

-------------------------------------------------------------------------------------------------------
-First OS upgrade attempt-


Switch_3(config)# install all nxos bootflash:nxos.7.0.3.I4.8b.bin
Installer will perform compatibility check first. Please wait.
Installer is forced disruptive

Verifying image bootflash:/nxos.7.0.3.I4.8b.bin for boot variable "nxos".
[####################] 100% -- SUCCESS

Verifying image type.
[####################] 100% -- SUCCESS
[## ] 5% -- SUCCESS

Preparing "nxos" version info using image bootflash:/nxos.7.0.3.I4.8b.bin.
[####################] 100% -- SUCCESS

Preparing "bios" version info using image bootflash:/nxos.7.0.3.I4.8b.bin.
[####################] 100% -- SUCCESS

Collecting "running" plugin(s) information.
[# ] 0%
Collecting plugin(s) information from "new" image.
[# ] 0%
Performing runtime checks.
[####################] 100% -- SUCCESS

Performing module support checks.
[####################] 100% -- SUCCESS

Notifying services about system upgrade.
[####################] 100% -- SUCCESS

 

Compatibility check is done:
Module bootable Impact Install-type Reason
------ -------- -------------- ------------ ------
1 yes disruptive reset Incompatible image

 

Images will be upgraded according to following table:
Module Image Running-Version(pri:alt) New-Version Upg-Required
------ ---------- ---------------------------------------- -------------------- ------------
1 nxos 7.0(3)I2(2b) 7.0(3)I4(8b) yes
1 bios v3.5.0(01/25/2016) v4.0.0(12/05/2016) yes


Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)? [n] ^C

Really abort ISSU? y/n [n]-
DATA_Server_Switch_3(config)# ye installation (y/n)? [n]
^
% Invalid parameter detected at '^' marker.
DATA_Server_Switch_3(config)# show boot
Current Boot Variables:

sup-1
NXOS variable = bootflash:/nxos.7.0.3.I2.2b.bin
No module boot variable set

Boot Variables on next reload:

sup-1
NXOS variable = bootflash:/nxos.7.0.3.I2.2b.bin
No module boot variable set
-------------------------------------------------------------------------------------------------------

After installing the first OS, when asked whether to reload, I accidentally entered a typo and proceeded with OS Install again.

-------------------------------------------------------------------------------------------------------
-Second OS Upgrade-

Switch_3(config)# install all nxos bootflash:nxos.7.0.3.I4.8b.bin
Installer will perform compatibility check first. Please wait.
Installer is forced disruptive

Verifying image bootflash:/nxos.7.0.3.I4.8b.bin for boot variable "nxos".
[####################] 100% -- SUCCESS

Verifying image type.
[####################] 100% -- SUCCESS

Preparing "nxos" version info using image bootflash:/nxos.7.0.3.I4.8b.bin.
[####################] 100% -- SUCCESS

Preparing "bios" version info using image bootflash:/nxos.7.0.3.I4.8b.bin.
[####################] 100% -- SUCCESS

Collecting "running" plugin(s) information.
[# ] 0%
Collecting plugin(s) information from "new" image.
[# ] 0%
Performing runtime checks.
[####################] 100% -- SUCCESS

Performing module support checks.
[####################] 100% -- SUCCESS

Notifying services about system upgrade.
[####################] 100% -- SUCCESS

 

Compatibility check is done:
Module bootable Impact Install-type Reason
------ -------- -------------- ------------ ------
1 yes disruptive reset Incompatible image

 

Images will be upgraded according to following table:
Module Image Running-Version(pri:alt) New-Version Upg-Required
------ ---------- ---------------------------------------- -------------------- ------------
1 nxos 7.0(3)I2(2b) 7.0(3)I4(8b) yes
1 bios v3.5.0(01/25/2016) v4.0.0(12/05/2016) yes


Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)? [n] y


Install is in progress, please wait.

Performing runtime checks.
[####################] 100% -- SUCCESS

Setting boot variables.
[####################] 100% -- SUCCESS

Performing configuration copy.
[####################] 100% -- FAIL.
Return code 0x401E0000 (request was aborted).

Resetting boot variables. Please wait.
[####################] 100%

Install has failed. Return code 0x40930014 (Configuration copy failed).
Please identify the cause of the failure, and try 'install all' again.
DATA_Server_Switch_3(config)#
DATA_Server_Switch_3(config)#
DATA_Server_Switch_3(config)# Install has failed. Return code 0x40930014 (Configuration copy failed).

-------------------------------------------------------------------------------------------------------

However, the command that the configuration copy failed has been issued, and the save to config is currently not possible.
After the second attempt, I forcefully reloaded the equipment, and all configs were lost and the equipment was initialized.

After resetting the backed up content, I tried to save it, but the log below appears, and the config is not saved.

2019 Jan 24:28:03 Switch_3 %SECURITYD-2-INVALID_ADMIN_PASSWD
2019 Jan 24:28:03 Switch_3 %SYSMGR-3-CFGWRITE_SRVFAILED: Service "Security Daemon" failed to store items configuration (error-id 0x404A0052).
2019 Jan 24:28:03 Switch_3 %SYSMGR-2-CFGWRITE_ABORTED: Configuration copy bound.
2019 Jan 24:28:04 Switch_3 %SYSMGR-3-CFGWRITE_FAILED: Configuration copy failed (error-id 0x401E0000).

I wonder if there are any mistakes I made during OS upgrade or if there is any way I can recover them.

1 Accepted Solution

Accepted Solutions

Have you ever tried? Set password for admin account and save config, it would be failed?

View solution in original post

9 Replies 9

Hanfeng Cai
Cisco Employee
Cisco Employee

It looks issue caused by fact that system did not have password defined for ADMIN username. 

 

Please try following cmd:

 

username admin password #%^$#  <<<< set up a new password for admin account

The password for the admin account, the default account, is known to be empty,
I am wondering if it is appropriate to set it separately,

If you set the password for the admin account as you like, you can not save the current config,
I wonder if it will be a solution.

Thank you very much for your reply.

Have you ever tried? Set password for admin account and save config, it would be failed?

I have never tried it.

If you try,

switch (config): username admin privilege15 password (empty)

I wonder if you should try this way.

I know that the default id / pw of the nexus admin account is id: admin, pw: empty (enter).

never set it as empty, you must set an actual pw

Thank you very much for your reply.
I understand that I need to set the PW of the default account admin.
If so, I do not understand the message that comes out as an incompatible image in the OS version.
These messages appeared during the installation process as shown below.

-------------------------------------------------------
Compatibility check is done:
Module bootable Impact Install-type Reason
------ -------- -------------- ------------ ------
1 yes disruptive reset Incompatible image
-------------------------------------------------------

 

I wonder what "collecting running" means below.
Does it mean to copy the current config to the upgraded OS image?
-------------------------------------------------------
Collecting "running" plugin(s) information.
[# ] 0%
Collecting plugin(s) information from "new" image.
[# ] 0%
-------------------------------------------------------

 

The following is a message after Yes to inquire whether to proceed with reboot after OS upgrade.
The OS of the device was installed by installing the recommended version nxos.7.0.3.I4.8b.bin. (https://software.cisco.com/download/home/285001670/type/282088129/release/7.0%25283%2529I4%25288b%2529?i=!pp)

-------------------------------------------------------
Images will be upgraded according to following table:
Module Image Running-Version(pri:alt) New-Version Upg-Required
------ ---------- ---------------------------------------- -------------------- ------------
1 nxos 7.0(3)I2(2b) 7.0(3)I4(8b) yes
1 bios v3.5.0(01/25/2016) v4.0.0(12/05/2016) yes


Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)? [n] y


Install is in progress, please wait.

Performing runtime checks.
[####################] 100% -- SUCCESS

Setting boot variables.
[####################] 100% -- SUCCESS

Performing configuration copy.
[####################] 100% -- FAIL.
Return code 0x401E0000 (request was aborted).

Resetting boot variables. Please wait.
[####################] 100%

Install has failed. Return code 0x40930014 (Configuration copy failed).
Please identify the cause of the failure, and try 'install all' again.
Switch_3(config)#
Switch_3(config)#
Switch_3(config)# Install has failed. Return code 0x40930014 (Configuration copy failed).
^
% Invalid command at '^' marker.
Switch_3(config)# ^C
Switch_3(config)#
Switch_3(config)#
Switch_3(config)#
Switch_3(config)#
Switch_3(config)# show boot
Current Boot Variables:

sup-1
NXOS variable = bootflash:/nxos.7.0.3.I4.8b.bin
No module boot variable set

Boot Variables on next reload:

sup-1
NXOS variable = bootflash:/nxos.7.0.3.I2.2b.bin
No module boot variable set
Switch_3(config)#

-----------------------------------------------------------------------------

 

In the inventory information below, we are currently using the N3K-C3172TQ-10GT.
The OS of the device was downloaded from the recommended version nxos.7.0.3.i4.8b.bin. (https://software.cisco.com/download/home/285001670/type/282088129/release/7.0%25283%2529I4%25288b%2529?i=!pp)
Did I download the wrong OS and proceed with the installation?
The Prod. # Of the device is N3K-C3172TQ-32T, which can be found at (https://www.cisco.com/c/en/us/support/switches/nexus-3172tq-32t-switch/model.html) Product For the ID value,
The model N3K-C3172TQ-10GT is not specified.

-----------------------------------------------------------------------------
NAME: "Chassis", DESCR: "Nexus 3172T Chassis"
PID: N3K-C3172TQ-10GT , VID: V01 ,

NAME: "Slot 1", DESCR: "48x10GT + 6x40G Supervisor"
PID: N3K-C3172TQ-10GT , VID: V01 ,
-----------------------------------------------------------------------------

I suppose this is a cosmetic issue, but I don't have lab to verify it. You could open a TAC case to look into it.

After upgrading to the recommended OS,
I can confirm that the new version has been uploaded,
I can not reboot and force a reboot,
All configurations have disappeared.
This event does not set the PW in the admin account after all, and the boot path is not saved and changed.
Could it be a problem booting to an existing version when rebooting?

Thank you for your reply.

I wonder what kind of problem is the appearance problem.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers