cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
121
Views
0
Helpful
3
Replies
Beginner

Nexus 7010 Port-channel

Hello All , 

 

I want to remove the following interface from Fex Uplink port-channel , but I am getting following error:-

 

pro# show port-channel summary interface port-channel 102
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
102 Po102(SU) Eth NONE Eth1/2(P) Eth1/4(P) Eth2/2(P)
Eth2/4(D) Eth3/2(D) Eth3/4(P)

 

pro(config)# default interface Eth2/4
Interface config wipeout failed for Ethernet2/4 (ifindex: 0x1a083000)
pro(config)#

 

show run interface port-channel 102

!Command: show running-config interface port-channel102
!Time: Tue Nov 13 10:16:40 2018

version 6.2(20)

interface port-channel102
switchport
switchport mode fex-fabric
fex associate 102

pro(config)# show run int Eth2/4, eth 3/2

!Command: show running-config interface Ethernet2/4, Ethernet3/2
!Time: Tue Nov 13 10:17:25 2018

version 6.2(20)

interface Ethernet2/4
switchport
switchport mode fex-fabric
fex associate 102
channel-group 102

interface Ethernet3/2
switchport
switchport mode fex-fabric
fex associate 102
channel-group 102

 

Regards

WAQ

3 REPLIES 3
Cisco Employee

Re: Nexus 7010 Port-channel

Hi @UniWAQ,

Sounds like https://bst.cloudapps.cisco.com/bugsearch/bug/CSCtk83899/?rfs=iqvred but this is already fixed in 5.2(1). Could you please provide me below output? 

 

#show default-interface log

# show system internal mts buffers details

# show system internal ethpm event-history interface ethernet 2/4

# show system internal ethpm event-history interface port-channel 102

#show logging last 50

 

Regards,

MJ

 

Beginner

Re: Nexus 7010 Port-channel

Hello Mojafri,

 

Logs are attached 

 

Regards

Cisco Employee

Re: Nexus 7010 Port-channel

Hi @UniWAQ,

Thanks for sharing the logs. It appears that we have some restriction while using multiple F2 cards in a port-channel for FEX as documented in: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuh86771/?reffering_site=dumpcr (Its not a bug, instead its a behavior which is documented)

 

from Logs:

 

Spoiler
production_demcssd03b# show default-interface log  
`interface Ethernet2/4`
`no channel-group 102 force`   <<<< Script tried to perform "no channel-group 102 force" >>>>
We got below message
Fex connectivity must be symmetric across all the port groups. Port group is a collection of 4 contiguous ports starting with port 1. Port indices across port groups must match. If port(s) {1,3} are used in port-group 1 same port(s) must b e used in other port-groups. Multiple FEX can share a port-group. FEX uplinks ca n be connected to multiple different F2 LC as long as previous is met. Use comma nd 'show interface ethernet <module-num>/ <port-num> capabilities' to check port-group members information `no fex associate 102` <<< Script tried "no fex associate 102">>>
Ignoring configuration on bundle member Ethernet2/4 <<< Command got ignored as its still a port-channel member>>>

I can think of trying below step:

 

Use "# default interface ethernet 2/4, eth3/2"but you might need to include the interface of module-1 as well. As Fex connectivity must be symmetric across all the port groups.

 

Regards,

MJ

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards