Showing results for 
Search instead for 
Did you mean: 

VSUM and N1Kv for vSphere 6.0.0 Issue


Hi all,

I just got a hold of the newest version of VSUM 1.5.5 to our vSphere 6.0.0 environment. This all seemed great until I tried adding a physical host to the DVS. The issue experienced is the following:

vSphere Web Client Home menue --> Cisco Virtual Switch Update Manager --> Nexus1000v --> Configure --> "Choose DC" --> "Choose DVS" --> Manage --> Add host --> "Try and add a host". And when I try accessing either choice, the "An internal error has happened". So the physical hosts cannot be joined to the N1Kv DVS from here.

Trying another approach to add hosts by "right clicking" the N1Kv SW under the Networking Tab gets me a bit further.

Network Tab --> Right click N1Kv DVS --> Add and Manage Hosts... --> Add host --> "Select host" --> Manage physical adapters --> Assign Uplink and choose the manually generated Ethernet Uplink group made in the VSM --> OK --> Then the error message "The number of physical network adapters per host exceeds the number of uplink ports" appears

Which does not make sense as the uplink port created has a upper limit of like 512 uplink ports.

The port profile has a very basic profile:

port-profile type ethernet UPLINK

switchport mode trunk

switchport trunk allowed vlan all

no sh

system enable

vmware port-group

system vlan 100

I tried installing different N1KV versions, but with no luck, got the same outcome.

According to the VSUM documentation this should have been really straight forward.

Any idea on what might have gone wrong?

32 Replies 32

If it helps, we had this issue both *before* and after VSUM was installed. VSUM was installed simply to see if it made any difference (and it did not).




The output you have posted is just what the script displays when generating the log bundle. Its not clear, but I think the logs are created and stored in /root/ajaxLogs. Well this is what I uploaded, i'm not completely sure if that is correct.



Hello, Robert. You wrote me this message:

Farid - this thread is specifically regarding "VSUM". If you have a non-VSUM issue, please start a new thread.

But this is same issue. Doesn't matter you have VSUM installed in you production or not. The same error message, the same problem. Result we cannot add physical adapters to N1KV switch. Our VSM cannot determine VEM module.

So if you need any logs from my production, regarding this issue, I can provide them. I do not think that I have to start new thread.

Thanks, Farid.


Hello. Any news? Can anybody fix it?


I raised a TAC case for this issue. We have been told that the VEM needs to be installed on the host first before adding the host to the switch. This can be done either manually from the CLI within ESXi or using VUM.

We haven't tried this as yet, so I cannot comment as to if this is the solution.

Hello, Niraj

Yes. I installed VEM using CLI on host directly. But the same issue. And without VEM installed it returns completely another error message.

Output of installed VEM module on host. Command: "vem status -v"


Package vssnet-esxesx2015-release


Build 1

Date Sat Aug 15 07:59:51 PDT 2015

VEM modules are loaded

DVS Name         Num Ports   Used Ports  Configured Ports  MTU     Uplinks

Distrib-SW1      1792        9           512               1500    vmnic0

VEM Agent (vemdpa) is running


So this is not VEM issue. Can youn pls provide this in fo to Cisco team. Thanks.

Hello Niraj

Any news from TAC case?

Hi Farid,

Nothing as yet, I am waiting for them to arrange a WebEx to investigate further.

Thanks Niraj. Pls do not forgot to share any information you get from them. Thanks.

I have just come off a call with TAC. This appears to be a bug within the vSphere web client when it interfaces with the N1K. The bug is internal so I don't have visibility of it. Cisco are working with VMWare to resolve the issue.

We managed to get around the issue by following the same process but using the full vSphere client and not the web interface.

Hello, Niraj

Thank you very much for your post. Reinstalled latest version of Software Client. Then tried to add physical adapters. Successful. I tried to use Software Client before as I mentioned on my previous post, but unsuccessful. Interesting point is that the reinstalling of Software Client immediately gives result. Hope this will be useful for someone else. Thanks.

P.S. Thank everybody who take part in this discussion.

Hi Niraj,

Did the TAC engineer mention a VMware PR or SR number by any chance?

I'm trying to find out about this issue from the VMware side.



Hi Manuel

I wan't informed by the TAC engineer of any corresponding VMWare numbers. If it helps the Cisco bug ID is CSCuw55307. I don't have visibility of the bug with my CCO account.


Hi Niraj,

That helps already, thanks!



Hello people.

Anyone have news about this problem? Because this bug was reported 2 MAY 2016 and, for the moment, not exist any news.

I have the same problem, with ESXi 6.0 and Nexus 1000v.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers