cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1055
Views
0
Helpful
1
Replies
Highlighted
Beginner

2901 router and RightFax issues

On a remote site, I have a 2901 router working as a pass through for two T1s to a RightFax server. Tghis router is also connected to our HQ CallManager but the RightFax does not hit that. The office is complaining about intermitent issues. The guys working with them on RightFax do not think it is on their end (of course).

They are seeing errors in Right Fax reading "RLF: 'Loop-Current Drop' on line 10. Count=2 Oldest=0x5124215D."

Thanks for the help!!!!

David

Config:

Current configuration : 12032 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VSMNSRST01

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.151-4.M.bin

boot-end-marker

!

!

card type t1 0 0

card type t1 0 3

logging buffered 51200 warnings

enable secret 5 $1$4p0v$.uUb64cP373QJQp0Gv4hR0

!

aaa session-id common

network-clock-participate wic 0

network-clock-participate wic 3

network-clock-select 1 T1 0/0/0

network-clock-select 2 T1 0/3/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip domain name

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

        quit

voice-card 0

codec complexity medium

dspfarm

dsp services dspfarm

!

!

!

voice service voip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  h225 display-ie ccm-compatible

  call preserve

  session transport udp

  h245 tunnel disable

sip

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice class h323 1

  h225 timeout tcp establish 3

  call start fast

!

!

voice translation-profile Inbound

translate calling 2

translate called 1

!

voice translation-profile SRST

translate calling 50

!

!

fax send transmitting-subscriber $s$

license udi pid CISCO2901/K9 sn FTX1614847T

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-17,24

!

controller T1 0/3/0

cablelength long 0db

pri-group timeslots 1-24

!

controller T1 0/3/1

clock source internal

cablelength long 0db

pri-group timeslots 1-24

!

!

!

!

!

interface Loopback0

no ip address

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.9.254.163 255.255.0.0

duplex auto

speed auto

h323-gateway voip interface

!

interface Serial0/3/0:23

description INTEGRA LS522321 RightFax T1

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/1:23

description INTEGRA LS522322 RightFax T1

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

VSMNSRST01#sh run | b :23

interface Serial0/0/0:23

description INTEGRA LS5202822 Voice T1

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/0:23

description INTEGRA LS522321 RightFax T1

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/1:23

description INTEGRA LS522322 RightFax T1

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 10.9.254.254

ip tacacs source-interface Loopback0

!

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

tacacs-server host 10.5.81.31

tacacs-server directed-request

tacacs-server key 7 021205580A051C32444F1B1C011C1712

!

!

!

control-plane

!

!

voice-port 0/0/0:23

!

voice-port 0/3/0:23

!

voice-port 0/3/1:23

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 172.31.0.11 identifier 1 version 6.0

sccp ccm 172.31.0.10 identifier 2 version 6.0

sccp

!

sccp ccm group 999

associate ccm 2 priority 1

associate ccm 1 priority 2

associate profile 1 register MN_AXXIS_CFB

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

associate application SCCP

shutdown

!

dial-peer voice 71 pots

preference 1

destination-pattern 7[2-9].........

port 0/3/0:23

forward-digits 10

!

dial-peer voice 72 pots

preference 2

destination-pattern 7[2-9].........

port 0/3/1:23

forward-digits 10

!

dial-peer voice 73 pots

preference 1

destination-pattern 71[2-9]..[2-9]......

port 0/3/0:23

forward-digits 11

!

dial-peer voice 74 pots

preference 2

destination-pattern 71[2-9]..[2-9]......

port 0/3/1:23

forward-digits 11

!

dial-peer voice 61 voip

destination-pattern 0202

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 62 voip

destination-pattern 0210

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 63 voip

destination-pattern 024[48]

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 64 voip

destination-pattern 0269

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 65 voip

destination-pattern 040[78]

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 66 voip

destination-pattern 0293

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 67 voip

destination-pattern 0396

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 68 voip

destination-pattern 0418

session target ipv4:10.9.81.22

incoming called-number .

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

ip qos dscp cs3 signaling

no vad

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.9.254.163 port 2000

max-ephones 42

max-dn 100 dual-line

transfer-pattern .......

transfer-pattern ....

voicemail 913012872600

alias 1 8120 to 913012872700

translation-profile incoming SRST

call-forward busy 913012872700

call-forward noan 913012872700 timeout 16

1 REPLY 1
Highlighted

Hi,

how do you integrate your router with  rightfax ? do you use SIP or H323 ?

I have bad experience with SIP. I integrate between call manager and rightfax using inter cluster (H323) and test adding rightfax to call manager as H323 gateway

HTH

Anas

please rate if it is helpful

Content for Community-Ad