cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
596
Views
0
Helpful
7
Replies
Highlighted
Beginner

Calling Party Transformation for different incoming calls with prior number (0) set

Hi community.

If you see my other discussions created the last days I was successfull to configure some functions on our CallManager 6.2.1. that we really needed.

But there's a remaining problem and I'd like to ask you again.

Our internal Cisco Phones have 3-digits extensions, starting from 100 to 999. We've had the problem that a prior 0 was not shown for missed calls which I fixed in a Translation Pattern that adds two "00" to any incoming call. For outgoing calls the first one is deleted by the CallManager (PreDot), so calls work just fine.

BUT:  the translation pattern which adds the two 00 only works 100% with 10-digit external numbers. For example: if a mobile with 0170555yyyy calls an internal number, it is translated to 00170555yyyyy (without translation it's only 170555yyyyy) and call-back works great. If instead a mobile with 0170555yyyyyzz calls an internal number, it is translated to 00555yyyyyzz. The reason for that makes sense to me: the translation is set to "00xxxxxxxxxx". So it only works right with external 10-digit numbers.

What do I have to do to make it work with ANY external number? So whoever calls an internal phone - gets just two leading "0" set to the number followed by the rest of the calling id?

Might be simple - but I don't see the answer. :-(

Thanks. Regards.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Oh I see whats wrong. You dont need any calling party xform mask. Leave it blank and just add the prefix..

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

View solution in original post

Highlighted

Yes sir!

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

View solution in original post

7 REPLIES 7
Highlighted
Beginner

Not sure - but is this something to be implemented on the voice router? Our topology is this:

PRI <> Cisco 2821 <> CCM <> IP Phones

We don't have any translation rules active on the router - everything is send to the CCM as it's coming from the PRI. Is it possible to add the two 00 there and to disable the translation for the external number in CCM?

Highlighted

First of all are you using calling party xformation or translation pattern.

With calling party transformation all you need to do is define the pattern..

eg...

1[2-9]XX[2-9]

then set the prefix to whatever you want eg 0 and for international calls define a pattern as

00! or whatever your international calls are and then set the prefix to 00 or whatever you international dialling is..

If you are using xlation pattern, then you just need to define the translation for your internal dial-plans and then prefi your digits there. Refer to this link for this

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805b6f33.shtml

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts
Highlighted

Not sure if I understand what you mean.


For the "add prefix to missed calls" to work all internal phones are now reachable only via a new translation pattern. In this pattern "xxx" all incoming calls are set to use the prefix 00 via "Calling Party Transformation". The "Calling Party Transform Mask" therefore is "00xxxxxxxxxx".

In the pattern itself it's not possible to use wildcards like "!" - only X,# and * are allowed.

So the questions for me still is - how do I transform incoming calls with more than 10 digits?

Highlighted

Oh I see whats wrong. You dont need any calling party xform mask. Leave it blank and just add the prefix..

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

View solution in original post

Highlighted

Okay - just to double check it:

I keep the option "Use Calling Party's External Phone Number Mask" enabled, but delete everything in the line "Calling Party Transform Mask". Instead of that - I add two "00" in the "Prefix Digits (Outgoing Calls)" line?

Highlighted

Yes sir!

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts

View solution in original post

Highlighted

Thanks aokanlawon.

Will do some more checks tomorrow (as we are in Germany and it's getting late) but looks like your recommendation fixed it! Great work.

Content for Community-Ad