Showing results for 
Search instead for 
Did you mean: 

calling sip line from outside

Level 1
Level 1


any one can help, i have these config in my translation rules

incoming calls are working when i dial 2837555 from outside , but some are saying that when they call from certain numbers the number 2837555 it will be busy.



voice translation-rule 1

rule 1 /2837599/ /599/

rule 2 /2837595/ /595/

rule 3 /2837597/ /597/

rule 4 /2837598/ /598/

rule 5 /2837400/ /100/

rule 6 /2837596/ /596/

rule 7 /.*2837555/ /123/

rule 8 /^1\(.......$\)/ /9\1/

rule 9 /\(^5........$\)/ /90\1/

rule 10 /^9\(.*\)/ /\1/

rule 11 /^.*\(123\)/ /\1/


voice translation-rule 191

rule 1 /^599/ /2837599/

rule 2 /^596/ /2837596/

rule 3 /^595/ /2837595/

rule 4 /^597/ /2837597/

rule 5 /^598/ /2837598/

rule 6 /^3....\*\(.\)/ /\1/

rule 7 /^9\(.*\)/ /\1/

rule 8 /.../ /2837555/



voice translation-profile SIP-IN

translate calling 1

translate called 1


voice translation-profile TP_OUT_SIP

translate calling 191

translate called 191


24 Replies 24

Ayodeji Okanlawon
VIP Alumni
VIP Alumni

can you send a debug ccsip messages and debug voip ccapi inout

Please rate useful posts

Please rate all useful posts


tthanks for your support, please find logs as requested , called from 2835625 to 2837555 but call not going to AA

Hi, here is an analysis of your trace..

+++Your sip provider sends an invite without SDP+++So you are doing delay offer


INVITE sip:2837555@;

user=phone SIP/2.0 Via: SIP/2.0/UDP;


Call-ID: SBCk2aedpp2u2otuptbbfes2okad7aehaec@SoftX3000

From: <12835625>;tag=tpobhu4b-CC-36

To: <2837555>

+++After a couple of trying and invite to CUE, you send a 200 ok to provider with SDP++++.

SIP/2.0 200 OK Via: SIP/2.0/UDP;
From: <12835625>;tag=tpobhu4b-CC-36
To: <2837555>;tag=2E4C4AD0-263D Date: Sat, 02 Jun 2012 08:49:51 GMT
Call-ID: SBCk2aedpp2u2otuptbbfes2okad7aehaec@SoftX3000
telephone-event Remote-Party-ID: <123>;party=called;screen=no;privacy=off
Contact: <2837555> Supported: replaces Call-Info: <>;method="NOTIFY;Event=telephone-event;Duration=2000" Supported: sdp-anat
Server: Cisco-SIPGateway/IOS-12.x Supported: timer Content-Type: application/sdp
Content-Disposition: session;handling=required Content-Length: 251 
o=CiscoSystemsSIP-GW-UserAgent 336 981
s=SIP Call
c=IN IP4
t=0 0
m=audio 17614 RTP/AVP 0 101
c=IN IP4
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15 a=ptime:20

++++++++Now your provider sends an ACK without sdp+++++++++++ (for it to work they need to send an ACK with SDP)

ACK sip:2837555@ SIP/2.0 Via: SIP/2.0/UDP;
Call-ID: SBCk2aedpp2u2otuptbbfes2okad7aehaec@SoftX3000
From: <12835625>;tag=tpobhu4b-CC-36
To: <2837555>;tag=2E4C4AD0-263D CSeq: 1
ACK Max-Forwards: 70 Content-Length: 0

+++Then your provider sends a bye+++++++++++

BYE sip:2837555@ SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bKxnknekbionkvbvoxbnkliiexc
Call-ID: SBCk2aedpp2u2otuptbbfes2okad7aehaec@SoftX3000
From: <12835625>;tag=tpobhu4b-CC-36
To: <2837555>;tag=2E4C4AD0-263D
CSeq: 2 BYE Max-Forwards: 70
Reason: Q.850;cause=41;text="temporary failure"
Content-Length: 0 

+++The ccapi cause code helps us more++++

001281: Jun  2 08:49:51.877: //127822/C058B05B8462/CCAPI/cc_api_call_disconnected:
   Cause Value=96, Interface=0x8738CB14, Call Id=127822

Cause 96 means that a mandatory information element is missing..Now the question is what is the mandatory information your provider is expecting in the 200 answer that you didnt provide..and I think its this sip session attribute

a=sendrecv or a=sendonly

Now according to RFC 3264  An Offer/Answer Model Session Description Protocol , it stipulates that

If the offerer wishes to both send and   receive media with its peer, it MAY include an "a=sendrecv"
   attribute, or it MAY omit it, since sendrecv is the default

However I think Huwaei your sip provider still want to see a session attribute in your offer. Hence the reason for disconnecting the call.

My suggestion is to use early offer from the provider. That way they can send you their attributes and ccme can just ack that.

It is my experience with this provider that they always send a session atrribute even if its  (a=sendrecv) which is the default.

Please rate useful posts

Please rate all useful posts


thanks for your support

i am not sur that i get you

can you specify what to do to solve this issue.


you mean i have to configure early-offer as below

Configuring Delayed-Offer to Early-Offer for SIP Audio Calls at the Global Level

To configure Delayed-Offer to Early-Offer for SIP Audio Calls at the global level, perform the steps in this section.


1. enable

2. configure terminal

3. voice service voip

4. allow-connections sip

5. early-offer forced

6. exit

Yes try that and test again...send the debugs again after you have configured this.

Please rate useful posts

Please rate all useful posts

hi, i tried to add the commands but it doesnt support

Try to create voice class sip-profile. Add the missing header in your 200 OK response and test.

voice class sip-profile 1

Response 200 sdp-header attribute add "sendrecv"

Then assign this profile to your matched dialpeer.


Sent from Cisco Technical Support iPhone App

Hi Baqari,

i tried adding the profile, but the call is not going to autoattend, but it keeps on ringing, if i remove the command from the dial peer, the specific number is not working but other nos are going to the auto attend.

Please share the debig after adding the command


debug as requested

Can you please add this..

voice class sip-profile 1

Response 200 sdp-header attribute add "a=sendrecv"

NB: That the previuos config didnt have a=sendrecv, so you provider was ignoring your 200 ok.

Ensure to apply the profile to the dial-peer going to your sip provider as you did before. Please test again and send debug ccsip messages

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts

Hi Edwin,

In fact its typo mistake I forgot to put "a=" while posting the SIP-Profile. Apologize for this. I can see the SDP header is added as "sendrecv" in your debugs without "a=".

I am pasting the new SIP-Profile with the correction.

voice class sip-profile 1

response 200 sdp-header attribute add "a=sendrecv".

Try now and paste the result.

Thanks to aokanlawon for picking it up


still the same, it keeps on ringing without going to the AA