cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
configure & troubleshoot anyconnect
2166
Views
10
Helpful
7
Replies
Highlighted
Participant

Cause Value=63 while calling from CME to CUCM

Scenario:

Home lab setup. Site A has a CUCM (CUCM V. 8.6) cluster with 2 servers running on ESXi virtual machines. It has one 3825 router with IOS 12.x, and 2 T1 interfaces.

Site B has a CME router (ISR 2911, IOS 15.x) and 2 T1 interfaces.

Routers in Site A and Site B connect to each other through 2 T1 point to point connections. One interface is configured for ISDN pri and another as an Frame relay. I can ping both FR interfaces from each side, no problem.

Calls (POTS) from one site to another work fine through PRI.

Calls from CUCM site to CME site works fine through PRI

Calls (VOIP) from CUCM site to CME site works fine thorugh FR

However, I have not been able to make VOIP calls from CME to CUCM site.

I have configured SIP trunk, necessary router patterns, partitions, CSS and dial-peer. They all look good.

I have attached the file with the output of the 'debug voip ccapi intout' command. If somebody can point to the problem and a solution, that would be a great help.

Thank you

Khanal

Everyone's tags (4)
7 REPLIES 7
Advocate

Cause Value=63 while calling from CME to CUCM

Khanal

Can you supply the CME config and the number being dialled.

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Participant

Cause Value=63 while calling from CME to CUCM

Here is the the Running Config as you requested.

-----------------------------------------------------

! No configuration change since last restart
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BRANCHCME01
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 1
!
no aaa new-model
network-clock-participate wic 0
network-clock-participate wic 1
!
no ipv6 cef
ip source-route
ip cef
!
!
no ip domain lookup
ip domain name khanal.com
multilink bundle-name authenticated
!
!
isdn switch-type primary-ni
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
  ipv4 10.0.0.0 255.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
!
voice translation-rule 5
rule 5 /.*/ /2028848000/
!
!
voice translation-profile DID
translate calling 5
!
!

hw-module ism 0
!
hw-module pvdm 0/1
!
hw-module sm 1
!
!
username admin password 7 152603095438282C6937
!
redundancy
!
!
controller T1 0/1/0
clock source internal
cablelength long 0db
pri-group timeslots 1-4,24
description PRI to PSTN
!
controller T1 0/1/1
clock source internal
cablelength long 0db
channel-group 1 timeslots 15-24
description FameRelay P2P connection to Branch
!
ip ssh version 1
!
translation-rule 1
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 10.11.6.254 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.11.6.254


interface ISM0/0
ip unnumbered GigabitEthernet0/0
service-module ip address 10.11.6.253 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 10.11.6.254
hold-queue 512 out
!
interface GigabitEthernet0/1
ip address 10.11.5.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address dhcp
ip helper-address 10.11.6.254
duplex auto
speed auto
!
interface ISM0/1
description Internal switch interface connected to Internal Service Module
no ip address
!
interface BRI0/0/0
no ip address
shutdown
isdn switch-type basic-ni
isdn point-to-point-setup
!
interface BRI0/0/1
no ip address
shutdown
isdn switch-type basic-ni
isdn point-to-point-setup
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial0/1/1:1
no ip address
encapsulation frame-relay
no keepalive
!
interface Serial0/1/1:1.1 point-to-point
ip address 10.11.7.1 255.255.255.0
frame-relay interface-dlci 100
!
interface GigabitEthernet1/0
ip address 10.99.99.99 255.255.255.0
shutdown
!
interface GigabitEthernet1/1
description Internal switch interface connected to EtherSwitch Service Module
no ip address
shutdown
!
interface Vlan1
no ip address
!
!
!
router eigrp 1
network 10.0.0.0
network 10.11.5.0 0.0.0.255
network 10.11.6.0 0.0.0.255
network 10.11.7.0 0.0.0.255
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip http path flash:
!
ip route 10.11.6.253 255.255.255.255 ISM0/0
!
logging esm config
!
ixi transport http
response size 4
no shutdown
request outstanding 1
!
ixi application cme
no shutdown
!
!
tftp-server flash:SCCP41.9-1-1SR1S.loads
tftp-server flash:SCCP42.9-1-1SR1S.loads
tftp-server flash:apps41.9-1-1TH1-16.sbn
tftp-server flash:cnu41.9-1-1TH1-16.sbn
tftp-server flash:cvm41sccp.9-1-1TH1-16.sbn
tftp-server flash:flash:dsp41.9-1-1TH1-16.sbn
tftp-server flash:dsp41.9-1-1TH1-16.sbn
tftp-server flash:jar41sccp.9-1-1TH1-16.sbn
tftp-server flash:jar42sccp.9-1-1TH1-16.sbn
tftp-server flash:term41.default.loads

control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/1/0:23
local-alerting
!
ccm-manager download-tones
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.11.6.254 identifier 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/0
associate ccm 1 priority 1
associate profile 1 register XCoder
keepalive retries 1
keepalive timeout 10
switchover method immediate
switchback method immediate
switchback interval 5
!
dspfarm profile 1 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
codec g729br8
maximum sessions 4
associate application SCCP
!
dial-peer voice 202884 pots
translation-profile outgoing DID
destination-pattern 202884....
port 0/1/0:23
forward-digits 10
!
dial-peer voice 15099 voip
description VOICE MAIL PILOT
destination-pattern 15099
session protocol sipv2
session target ipv4:10.11.6.253
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 15000 voip
description AUTO ATTENDANT
destination-pattern 15000
session protocol sipv2
session target ipv4:10.11.6.253
dtmf-relay sip-notify
no vad
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 601 voip
preference 2
destination-pattern 14...
session protocol sipv2
session target ipv4:10.11.10.248
!
dial-peer voice 60 voip
destination-pattern 14...
session protocol sipv2
session target ipv4:10.11.10.249
dtmf-relay h245-alphanumeric rtp-nte sip-notify sip-kpml
codec g711ulaw
!
dial-peer voice 62 voip
destination-pattern 82028844004
session protocol sipv2
session target ipv4:10.11.10.249
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
!
!
!
gatekeeper
shutdown

telephony-service
sdspfarm units 5
sdspfarm transcode sessions 4
sdspfarm unregister force
sdspfarm tag 1 XCoder
no auto-reg-ephone
authentication credential cueadmin The0rch!d
xml user xmladmin password The0rch!d 0
max-ephones 50
max-dn 100
ip source-address 10.11.6.254 port 2000
service dnis dir-lookup
system message BRANCH CME
url services http://10.11.6.253/voiceview/common/login.do
url authentication http://10.11.6.254/CCMCIP/authenticate.asp
cnf-file location flash:
load 7914 S00105000400
load 7906 SCCP11.9-1-1SR1S
load 7960-7940 P00308010200
load 7941 SCCP41.9-1-1SR1S
load 7942 SCCP42.9-1-1SR1S
load 7961 term61.default
voicemail 15099
max-conferences 8 gain -6
call-forward pattern .T
web admin system name cueadmin secret 5 $1$MNLH$A1dP7Q63Jnc.O4aLPBlrv.
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 8

create cnf-files version-stamp 7960 Nov 09 2012 18:29:05
!
!
ephone-dn  1  dual-line
number 15000
description Auto-Attendant
name Auto-Attendant
!
!
ephone-dn  5  dual-line
number 15005
description Aayusha Khanal
name Aayusha Khanal
call-forward busy 15099
call-forward noan 15099 timeout 10
!
!
ephone-dn  10  dual-line
number 15010
description Aryan Khanal
name Aryan Khanal
call-forward busy 15099
call-forward noan 15099 timeout 10
!
!
ephone-dn  11  dual-line
number 2024655568
description Local Number
name Local Number
!
!
ephone-dn  12  dual-line
number 19195447040
description National Number
name National Number
!
!
ephone-dn  13  dual-line
number 0119779841889957
description International Number
name International Number
!
!
ephone-dn  14  dual-line
number 911
description Emergency Number
name Emergency Number
!
!
ephone-dn  15  dual-line
number 15015
description Aayusha Khanal
name Aayusha Khanal
call-forward busy 15099
call-forward noan 15099 timeout 10
!
!
ephone-dn  20  dual-line
number 15020
description Puspa Khanal
name Puspa Khanal
call-forward busy 15099
call-forward noan 15099 timeout 10
!
!
ephone-dn  25  dual-line
number 15025
description MainPhone
name MainPhone
!
!
ephone-dn  26  dual-line
number 15026
name Line in Exp module
!
!
ephone-dn  62  dual-line
number 19195447041
name Shine Samuel
call-forward busy 15099
call-forward noan 15099 timeout 10
!
!
ephone-dn  97
number 15097.....
mwi on
!
!
ephone-dn  98
number 15098.....
mwi off
!
!
ephone-dn  100
number 9195441234
description NC Cell Phone
name NC Cell Phone
!
!
ephone  5
mac-address E840.40A2.2B5E
username "HQPhone"
type 7942
button  1:5
!
!
!
ephone  25
mac-address 0006.D744.6AA2
type 7960 addon 1 7914
button  1:25 2:11 3:12 4:13
button  5:14 11:26
!
!
!
ephone  61
description Main Phone
mac-address 0026.0B5D.E687
username "MainPhone"
type 7961
button  2:62
!
!
line con 0
exec-timeout 0 0
password 7 00301B035449080E4E25
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
flowcontrol software
line 131
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 0 0
password 7 00301B035449080E4E25
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp master 5
ntp server 64.90.182.55
end

Participant

Cause Value=63 while calling from CME to CUCM

And the number being dialed is 14XXX (14004) which is the number in my HQ Site (CUCM). Branch CME site has the numbes in the 15xxx range.

Thank you.

Advocate

Cause Value=63 while calling from CME to CUCM

Khanal

As you have a few ip interfaces on your router I strongly suggest that you bind
one of them for SIP.


!
!
voice service voip
sip
bind int g0/0 all
!
!


Can you then retest with a sip mesage debug


debug ccsip messages

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Participant

Cause Value=63 while calling from CME to CUCM

You are awesome and brilliant

Your solved my problem that I had been dealing with for almost a month now. Would you mind elaborating on why my old configuration didn't work?

Anyway, thank you so much for the help even during the weekend!

I give you all the stars possible!

Advocate

Cause Value=63 while calling from CME to CUCM

Khanal,

All the voip protocols like SIP,H323 and MGCP all
cause issues of which ip address they select for outgoing ip packets.

As this link states undeterministic selection.
http://www.cisco.com/en/US/docs/ios/12_3/sip/configuration/guide/chapter7.html

When you have multipled ip addresses in a router it is always
best practise to "BIND" the voip protocol(s).

SIP

!
voice service voip
sip
bind int g0/0
! Obviously you pick a suitable interface
!


H323

!
!
interface GigabitEthernet0/0
ip address 10.11.6.254 255.255.255.0
h323-gateway voip bind srcaddr 10.11.6.254
!

MGCP

!
mgcp bind control source interface g0/0
mgcp bind media source interface g0/0
mgcp
!

So you are configuring which IP address will
be used for sourcing voip traffic.

Not leaving it to chance

Hope this helps

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Rising star

Re: Cause Value=63 while calling from CME to CUCM

Great work Alex (+5), keep up the good work.

Sent from Cisco Technical Support iPhone App

Please remember to rate helpful responses and identify helpful or correct answers.
CreatePlease to create content