cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2631
Views
0
Helpful
26
Replies

Cisco 2199 PX Router Issue

aquaium79
Level 1
Level 1

Just wondering if someone could help with an issue we're having at the moment. We are suddenly not able to receive internal calls or make any external calls. We have contacted our line providers and they have said that everything looks good with the line and are blaming an internal fault with the system.

 

I have done some testing, running the "show ISDN status" command shows the following:

 

pxrouter>show isdn status
Global ISDN Switchtype = primary-net5

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:15 interface
dsl 0, interface ISDN Switchtype = primary-net5
L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003
Layer 1 Status:
DEACTIVATED
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x00000000
Number of L2 Discards = 0, L2 Session ID = 204
Total Allocated ISDN CCBs = 0

 

Layer 1 Status is showing as deactivated. On the router itself, the "AL" light is showing amber. The strange thing is with the cable unplugged the "AL" light on the router is still showing as amber and if I run the "show ISDN status" command, it's still showing "Layer 1 Status: DEACTIVATED"

 

I also ran the "show inventory" command and the interface card is shown with details of serial number so I think the card is not at fault.

 

Below are some pictures of the PX Router and the BT box, could anyone help out and let me know how we can resolve this and if it is in fact in internal issue or an external one with our line providers?

 

 

PX Router (Cisco 2199) - Pink Cable is the connection going to the BT BoxPX Router (Cisco 2199) - Pink Cable is the connection going to the BT Box

 

BT BoxBT Box

 

26 Replies 26

Gregory Brunn
Spotlight
Spotlight

Put a T1 Loopback on your side... does your layer 1 come up?

Sorry, what's a T1 Loopback and how do I get one?

My role as I consultant I actually carry two in my bag, however you can of course always make one.

https://www.cisco.com/c/en/us/support/docs/voice/device-signaling/116492-trouble-t1e1-00.html

 

Basically if you use a loopback and Layer 1 comes up past deactive then it is your carrier or cable between you and them that is your problem.

 

Very interesting, thank you. I'll try and make one by the end of this week and get back with the results.

 

Just out of interest do you know a good website that has detailed instructions on how to make one? I've had a quick look but couldn't find detailed step by step guide.

If your not comfortable making RJ45 you can always buy one.  There are plenty of blogs of there on how to make a T1 cross over. Let me know if you come up short with a search. Happy to assist more.

I'm going to attempt to make one tomorrow and do the test. Is it just a matter of plugging in the test cable and running the "show ISDN status" command? I don't have to configure anything?

Yeah that should at least bring up layer 1, well hopefully at least. If it does it proves your issue with a layer 1 one with the carrier and you can ask them to fix the problem.

So just tested this with my loopback and the alarm does clear. However my layer 1 status only shows as deactivated if I shut down the serial interface.  Layer 1 is always up and active with the loopback not populated. I also verified that if you shut down the serial interface the lights for alarm will still stay on. Are you sure the serial interface is in a up up state?

 

With port shutdown

ISDN Serial0/1/0:23 interface
dsl 0, interface ISDN Switchtype = primary-ni
L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003
Layer 1 Status:
DEACTIVATED
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x00000000
Number of L2 Discards = 0, L2 Session ID = 174


Without loopback

ISDN Serial0/1/0:23 interface
dsl 0, interface ISDN Switchtype = primary-ni
L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x807FFFFF
Number of L2 Discards = 0, L2 Session ID = 174

 

With loopback

ISDN Serial0/1/0:23 interface
dsl 0, interface ISDN Switchtype = primary-ni
L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x807FFFFF
Number of L2 Discards = 0, L2 Session ID = 205

Can you please post your configs on that gateway sanitized of course, lets confirm that the card has not been shutdown administratively.

Sorry, I'm new to all this so please bear with me.

 

Firstly, how do I know if the serial interface is in a up state?

 

Secondly, how can I post the config on the gateway? Do I get to it through Cisco Call Manager?

 

If you can let me know, I'll post the information. Thank you for the help. Much appreciated.

Please ssh or console into the router and issue a show run.

Remove any sensitive info and post.

OK, so got the T1 cable made the results are:

 

With original cable from BT ISDN box: Layer 1 Status: DEACTIVATED

With NO cable: Layer 1 Status: DEACTIVATED

With T1 Loopback Cable: Layer 1 Status: ACTIVATED

 

What does that mean?

 

Below are the results from the show run command:

 

pxrouter#show run
Building configuration...


Current configuration : 2908 bytes
!
! Last configuration change at 12:01:45 BST Wed Aug 7 2019
! NVRAM config last updated at 12:01:45 BST Wed Aug 7 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname pxrouter
!
boot-start-marker
boot-end-marker
!
card type e1 0 0

!
no aaa new-model
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn ABC1234567
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
!
!
!
!
!
interface GigabitEthernet0/0
ip address 10.XXX.XX.X 255.255.255.255
duplex auto
speed auto
ntp broadcast
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.XXX.XX.X
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
cptone GB
!
ccm-manager redundant-host 10.XXX.XX.X
ccm-manager mgcp
ccm-manager music-on-hold bind GigabitEthernet0/0
ccm-manager config server 10.XXX.XX.X 10.XXX.XX.X
ccm-manager config
!
mgcp
mgcp call-agent 10.XXX.XX.X 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
mgcp default-package mt-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.XXX.XX.X identifier 2 priority 1 version 7.0
sccp ccm 10.XXX.XX.X identifier 1 priority 2 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/0
associate ccm 2 priority 1
associate ccm 1 priority 2
associate profile 1 register MTPc89c1d189a58
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 13
associate application SCCP
!
!
!
!
gatekeeper
shutdown
!
!
line con 0

logging synchronous
line aux 0
line vty 0 4

logging synchronous
login
!
scheduler allocate 20000 1000
ntp master 5
ntp server 10.XXX.XXX.XX
end

 

Please edit your previous post to remove the password section from line vty level 7 passwords are easily decrypted.

I would change those if you want to be secure now.

 

deleting not relevant

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: