Showing results for 
Search instead for 
Did you mean: 

Cisco 7940 Registration Issue

 Hello Everyone,

I have an issue with a few Cisco IP Phones (7940) model. it says registration rejected. and when I brought them to the HQ, it registered directly without any issue. 

but the strange this is that, when I connect a 7942 or newer models to the same port of the 7940 s, they will register. I also disabled all the firewall rules on the MikroTik of the other offices, but still the same. I allowed everything on the data center firewall between these two subnets. still rejects the registration.

I have also removed the phone from the CUCM and then added it back. still the same. I changed the firmware to SIP and then reverted back to SCCP. still the same.

I have seen that the Phone DN is empty when I want to check the DN through the IP address of the phone in the Device Information. I have attached a snapshot of it.



The CUCM version is 11.5.

The Boot Load ID of the phones are : PC0303010001

The App Load ID of the phones are : P0030801SR02



I searched for newer firmware. but was not able to find one. 

Any suggestion is appreciated.


Kind Regards,


For anyone that might come across this topic and face the same issue. I did anything that came to my mind and almost anything I found online, but none of them worked. later I found out that the 7940s were using the CUCM TFTP server as a call manager which they shouldn't use it since these servers meant to be used only for downloading firmware and configuration files, and only the 7940s were using it as Call Manager. not the 7942s nor the newer models.



Danar Mahmood

Hi, it’s been one year since the last post on this thread. Just wanted to check if you got resolution for this. We are having exactly same issue... phone is trying to register with tftp... our cucm version is 11.5

The phone will back off to the TFTP and the gateway to register to if it can’t register to the UCM.

Since the 7940 doesn’t support ITL, this happens if the DHCP option isn’t served and it has and old TFTP address, if the config is corrupt, etc.

If the phone can talk to the UCM it usually just spins around with Configuring IP. Registration rejected usually gives you a partial reason.

If you run CAPF and it doesn’t understand the config or trust it , it may back off and will again try router or TFTP by default - erase the phone and re-enroll.

Finally we got to know what was causing the issue..
Our cucm server name was configured in below format
U can see hostname is in cap and domain is in small case..

Once we modified to in below format.. phone started contacting cucm for registration

so everything is in small or caps... it works..
Mix of caps and small doesn’t work..

Having the exact same issue. Do you know if there is an official bug for this. I searched but could not find anything yet.

No, i couldn't find bug for this.

Content for Community-Ad

Spotlight Awards 2021