Showing results for 
Search instead for 
Did you mean: 

Cisco Conf Station 7936 registration issue

Anatoly Fedchik
Level 1
Level 1

Hello, I need help,

There is a problem with 7936, it cannot register by cucm7.0 server and station's LCD displays a message - "Cannot Contact TFTP Server". But 7936 receives right IP address and TFTP address and there is communication between them.

I run network sniffer and see a tftp communication between cucm and 7936, there is sequences downloading SEP-macaddress.cnf.xml and xmldefault.cnf.xml in that order every 15 seconds and no other traffic tcp or skinny only tftp.

It seems to me that 7936 doesnt understand configuration file.

















It doesnt start upgrade firware also. Server cucm have newer version firmware.

After reset to defaults the problem persists.

Firmwire 7936(PC0503031518, 7936.3-3-2).

12 Replies 12

Have you tried to remove device from CM and then add it back? This will remove and create new conf file.

Yes, i did it but without success.

Yes, i did it but without success.

Level 1
Level 1

Did you ever resolve your issue? I am having similar issues after upgrading from 6.1.2 to 7.1.2. I notice the 7936 phones that are failing have the same Boot Load ID that you listed (PC0503031518). Models of the 7936 that are working have a different boot load id (PC0503035353).


yes, I solved the problem. CUCM 7 doesnt support 7936 with such firmware. You need to upgrade conference station firmware.

To upgrade it:

1. You need to setup temp dhcp server or maybe scope with 150 option pointing to server where you need to copy simple xmldefault.cnf.xml file:



you may need to replace ip address(temp tftp server) and firmare version in accordance to your local settings and downloaded firmware file version.

After upgrade firmware will be finished the CUCM 7 without any problem will register it.

Thank you so much - you helped me save an RMA!

Had the exact same issue with 3.2(2) 7936 that would not upgrade to 3.2(20). After applying your workaround it registered to CUCM 8.0 without any problems


Thank you very much for this.  The only thing I would add is that I ran into this issue:

Trying to go from 3.2(2) directly to 3.2(20) caused the upgrade to hang at 50%.  I had to first upgrade to 3.2(12), and then to 3.2(20).  Apart from that one caveat, your workaround worked perfectly for me.  Thanks!


I am in the same boat here.  I recently purchased a 7936 off ebay and the phone is going to the data vlan and cannot see the TFTP server on CM 8.x however I can ping it from the phone.  I tried upgrading the firmware directly from 3.2(0) to 3.2(20) via a small TFTP server I built but it hangs at 50%.  I tried downloading the 3.2(12) code but Cisco in their infinite wisdom does not feel that I should be able to download it.  I can get 3.2(21) but not the older versions.

I have tried everything to get them to allow me to download this and included their own tech note on this problem but they still refuse to allow me to download it.

I will probably end up never buying Cisco equipment over this as I can't see the harm in giving me an older firmware code.  If I can't even get that kind of support from Cisco what good are they!?!?!?!?

Does anyone have the older firmware code or point me to a location that does have it?




I had a coworker check his CCO account (which only has router and switch contacts associated), and his is the same as you: He can download the latest code, but not the older versions.  That's frustrating.  Unfortunately, I don't think Cisco would look to fondly on me sending you their software, even though there's really no reason you shouldn't have access to it.  Maybe someone from Cisco will chime in and give their blessing? 

Thanks for your reply and I was able to get the firmware from another source which fixed the issue. The phone is now working flawlessly ☺.

Hi Nathan

I really hope you can help me, im having the same issue as you did, could you please tell me where you got the other firmware from, you can email it to me if you like to



Thank you for this.  We also had to make a filed named SEP.cnf.xml with the same contents for the phone to pickup.  We used 3.2(13) as our stepping stone and was able to upgrade to that, and ultimately to the current firmware.

On a second phone, the web interface would not show the phone load version and this trick did not work for it, so it may be trash at this point as we don't have Smartnet on it.