cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3959
Views
10
Helpful
4
Replies

CUBE Media Forking Dial Peer Question

kevbo
Contributor
Contributor

Morning all

Could someone please assist with the query below?

 

I am setting up CUBE media forking for call recording.

 

I have configured the following and it works fine.

 

#dial-peer hunt 0

 

#media profile recorder 100

#media-recording 1111

!

#media class 100

#recorder profile 100

!

#dial-peer voice 1111 voip

description SIP Trunk to the recorder for CUBE recording

destination-pattern 1111

session protocol sipv2

session target ipv4:<IP ADDRESS>:5060

session transport tcp

!

#dial-peer voice 5 voip

description *** Match Inbound from CUCM ***

session protocol sipv2

session transport tcp

incoming called-number .

voice-class codec 100

voice-class sip bind control source-interface GigabitEthernet0/0/1

voice-class sip bind media source-interface GigabitEthernet0/0/1

media-class 100

dtmf-relay rtp-nte

no vad

 

However we are setting this up so we can record specific exts outbound to the PSTN (trying to record third party SIP devices that have no BIB)

 

I set up a test dial peer to capture a specific ext e.g. 411483 for recording but it does not work. It still hits the less specific dial peer 5

 

#dial-peer voice 1112 voip

description *** Match Inbound from CUCM ***

session protocol sipv2

session transport tcp

incoming called-number 411483

voice-class codec 100

voice-class sip bind control source-interface GigabitEthernet0/0/1

voice-class sip bind media source-interface GigabitEthernet0/0/1

media-class 100

dtmf-relay rtp-nte

no vad

 

 CUBE#sh call act voice brief | i pid

<ID>: <CallID> <start>ms.<index> (<start>) +<connect> pid:<peer_id> <dir> <addr> <state>

10   : 15578371 837864988ms.1 (16:58:33.939 GMT Wed Nov 22 2017) +12510 pid:5 Answer 411483 active

10   : 15578372 837864998ms.1 (16:58:33.949 GMT Wed Nov 22 2017) +12500 pid:9 Originate <MOBILE NUMBER> active

 

I tested media forking with outbound dial peer and it worked fine..

 

#dial-peer voice 11 voip

description *** CUBE to SBC1 ***

translation-profile outgoing SIP-OUTBOUND

destination-pattern 9<MOBILE NUMBER>

session protocol sipv2

session target ipv4:62.239.36.229

session transport tcp

voice-class codec 100

voice-class sip profiles 100

voice-class sip options-keepalive

voice-class sip bind control source-interface GigabitEthernet0/0/0

voice-class sip bind media source-interface GigabitEthernet0/0/0

media-class 100

dtmf-relay rtp-nte

no vad

 

CUBE#sh call act voice brief | i pid

<ID>: <CallID> <start>ms.<index> (<start>) +<connect> pid:<peer_id> <dir> <addr> <state>

10   : 14890647 325644178ms.1 (18:41:33.136 GMT Thu Nov 16 2017) +4380 pid:5 Answer 411293 active

10   : 14890648 325644178ms.2 (18:41:33.136 GMT Thu Nov 16 2017) +4380 pid:11 Originate <MOBILE NUMBER> active

10   : 14890654 325648568ms.1 (18:41:37.526 GMT Thu Nov 16 2017) +50 pid:1111 Originate 1111 active

 

Any help on this much appreciated.

 

Cisco IOS XE Software, Version 03.16.04a.S - Extended Support Release
Cisco IOS Software, ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(3)S4a, RELEASE SOFTWARE (fc1)

1 ACCEPTED SOLUTION

Accepted Solutions

Jonathan Unger
Rising star
Rising star

Hi There,

 

If you are trying to match the inbound dial-peer based on the calling extension you will need to use the "answer-address <EXT>" command instead of incoming-called number. You will also need to change the way that your dial-peer voice 5 is configured since incoming-called number always takes precedence over answer-address.

If it works for your environment you could remove "incoming called-number ." from peer 5 and insert more of a catch-all pattern in there like "answer-address 4.....". That way all calls which are not caught by your more specific VOIP dial peer 112 (which has forking enabled) will be caught by your generic "non-forking" dial-peer 5.

Have a look at this document, it goes over how incoming and outgoing dial-peers are matched.
https://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html#topic3

Hope this helps!

- Jon

View solution in original post

4 REPLIES 4

Jonathan Unger
Rising star
Rising star

Hi There,

 

If you are trying to match the inbound dial-peer based on the calling extension you will need to use the "answer-address <EXT>" command instead of incoming-called number. You will also need to change the way that your dial-peer voice 5 is configured since incoming-called number always takes precedence over answer-address.

If it works for your environment you could remove "incoming called-number ." from peer 5 and insert more of a catch-all pattern in there like "answer-address 4.....". That way all calls which are not caught by your more specific VOIP dial peer 112 (which has forking enabled) will be caught by your generic "non-forking" dial-peer 5.

Have a look at this document, it goes over how incoming and outgoing dial-peers are matched.
https://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html#topic3

Hope this helps!

- Jon

Hi Jon

 

I did try answer-address but missed the fundamental point that incoming-called is serviced first! I will give your solution a try.

 

 

Thanks for taking the time to respond, much appreciated.

 

Kev

 

 

 

 

Thanks for the helpful vote, let us know if this ends up working for you!

 

- Jon

Just to add to Jonathan's post, be aware of the following:

Incoming called-number. Takes preference over any specifically matched incoming called-number.. This is why you are seeing this behavior. I will suggest you remove incoming called-number.  And replace with a more specific match for your dial peers. This way you can configure specific inbound dial peer using incoming called-number

Please rate all useful posts
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: