cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2661
Views
0
Helpful
6
Replies
Highlighted
Beginner

CUCM 8.6.2.22900-9 and UCCX 8.5.1 jtapi Address is out of service

CUCM 8.6.2.22900-9 - 8.6.2a(SU2)

UCCX 8.5.1.11003-32  - 8.5.1(SU3)

After Upgrade CUCM from 8.6.2aSU1 to 8.6.2aSU2 the following error prevents UCCX from working.

19572: Sep 03 19:34:43.128 CEST %MIVR-SS_TEL-7-UNK: Error while getting unique id.: Exception=com.cisco.jtapi.InvalidStateExceptionImpl: Address is out of service

19573: Sep 03 19:34:43.128 CEST %MIVR-SS_TEL-7-EXCEPTION:com.cisco.jtapi.InvalidStateExceptionImpl: Address is out of service

19574: Sep 03 19:34:43.128 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.IntraProviderAddress.assertValidState(IntraProviderAddress.java:1140)

19575: Sep 03 19:34:43.128 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.ConnectionImpl.assertValidAddress(ConnectionImpl.java:1727)

19576: Sep 03 19:34:43.128 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.ConnectionImpl.getUniqueID(ConnectionImpl.java:1815)

19577: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.wf.subsystems.jtapi.TAPIPortGroup.GetCallConnUniqueID(TAPIPortGroup.java:3095)

19578: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.wf.subsystems.jtapi.TAPIPortGroup$Port$AddressCallObserver.callChangedEvent(TAPIPortGroup.java:5413)

19579: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.ObserverProxy.deliverEvents(ObserverProxy.java:188)

19580: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.ObserverProxy.queueEvents(ObserverProxy.java:145)

19581: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.CallImpl.deliverEvents(CallImpl.java:554)

19582: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.CallManager.deliverEvents(CallManager.java:6739)

19583: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.CallManager.deliverEvents(CallManager.java:6756)

19584: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.CallManager.tryDeliverEvents(CallManager.java:1373)

19585: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.CallManager.newCall(CallManager.java:1624)

19586: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.AddressCallObserver.newCall(AddressCallObserver.java:221)

19587: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.AddressCallObserver.newCall(AddressCallObserver.java:211)

19588: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.jtapi.LineObserverImpl.NewCall(LineObserverImpl.java:196)

19589: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.client.implementation.Line.fireNewCall(Line.java:1118)

19590: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.client.implementation.Line.handleEvent(Line.java:889)

19591: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.client.implementation.Provider$EventThread.messageReceived(Provider.java:572)

19592: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.util.MessageThread.deliver(MessageThread.java:358)

19593: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.util.MessageThread.deliverAll(MessageThread.java:327)

19594: Sep 03 19:34:43.129 CEST %MIVR-SS_TEL-7-EXCEPTION:    at com.cisco.cti.util.MessageThread.run(MessageThread.java:282)

RP and CTI ports are registering to CUCM normally, UCCX shows all services as "In Service" and RTMT shows RP and CTI Ports as in Service.

When calling to one of the RP it signals fast busy back.

Call will never end up on UCCX.

JTAPI resync done and it's telling that all is fine, Data resync it's prompting for out of sync so just created a test RP with new CCG afterwards fine.

Does anybody have the same issue on their end?

If reverting back to CUCM 8.6.2aSU1 all is back up again.

Cheers

Minh

6 REPLIES 6
Highlighted
Hall of Fame Master

Have you tried restarting CTI Mgr on CUCM side? How about restarting CCX Engine on UCCX side?

Chris

Highlighted

Is the associated script running fine when debugged in the editor?

Regards,

Erik

Sent from Cisco Technical Support iPad App

Highlighted

2 words: same same

CTI Manager and CCX Engine restarted several times.

Script already tested. it's never arriving at script debug.

also tested on putting a CFA destination at CTI port to a DN of a phone. If calling it will be forwarded to it. (all other CFwds are not working) so no CTI error etc.

Highlighted

Did you find the resolution to this issue?

Highlighted

try forcing the CTI RPs to use IPv4 Only (i suppose thats what you are using anyways)...there was a bug in previous versions with similar behaviour...

Highlighted
Beginner

Yes the issue was resolved by just waiting and doing nothing.

It looks like synchronization between CUCM and UCCX took more than a day to get back working also when it does not show up.

I left the systems running in my lab and after coming back with some time after a few days i tried to call in again and it seems to work.

I did not had the time to reproduce it again.

Some similar issue occured with Directory Sync of UCCX to CUCM after deactivating LDAP Sync and Auth on CUCM. It's not doing it immediately.

I know that ths doesn't help very much but at least it was running afterwards. For production environment not too comfortable.

Content for Community-Ad