cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2849
Views
5
Helpful
7
Replies

CUCM "Parallel Upgrade"

TONY SMITH
Spotlight
Spotlight

Hi,

I'm referring to a cluster upgrade, in cases where the chosen path is to upgrade all the servers first, then do a switch version afterwards.   According to documentation, in these cases you should be able to start the upgrade on a Subscriber as soon as the Publisher upgrade has reached the stage that the new version shows in the inactive partition.   Documentation details the log messages that indicate this stage, but I've also sometimes just checked "show version inactive" on the Pub.

What I've found over quite a few upgrades is that sometimes you can do this, and sometimes the Subscriber won't start the upgrade until the Pub has completely finished.  For example yesterday I was doing an 8.6 to 9.1 (so not a refresh) and SFTPing the image to each server took over an hour, so it would have been very helpful to have been able to start that process as early as possible.

I was just wondering whether there is any rule indicating when this parallel upgrade is going to be available, and when not.  I'm guessing it might depend on the exact version you're upgrading from.

Thanks, Tony S

7 Replies 7

Manish Gogna
Cisco Employee
Cisco Employee

Hi Tony,

During the upgrade of the first node, view the installation log, install_log_<date+time>.log, by using the Software Installation/Upgrade window in Cisco Unified Communications Operating System Administration or the command line interface (CLI). You can begin the upgrade of the subsequent nodes after the following information displays in the log:

PRODUCT_TARGET is <product target id>

PRODUCT_NAME is <product name>

PRODUCT_VERSION is <product version to which you are upgrading, such as 7.1(2)>

 

More details here

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/cucos/7_1_2/cucos/osg_712_cm/iptpch7.html#wp1179699

 

HTH

Manish

Same applied to 9.x upgrade as well as mentioned in the upgrade guide for 9.0

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/upgrade/9_0_1/CUCM_BK_U8D523AB_00_upgrade-guide-cucm-90/CUCM_BK_U8D523AB_00_upgrade-guide-cucm-90_chapter_010.html

 

Manish

Hello,

I'm doing an upgrade right now and I can say that the possibility of parallel upgrade after the messages of PRODUCT_TARGET, PRODUCT_NAME, and PRODUCT_VERSION is not true.

 


My Publisher node already showed

|PRODUCT_TARGET is UCM|<LVL::Info>
09/19/2015 14:42:18 post_upgrade|PRODUCT_NAME is Cisco Unified Communications Manager|<LVL::Info>
09/19/2015 14:42:18 post_upgrade|PRODUCT_VERSION is 10.5.2.12901-1|<LVL::Info>
09/19/2015 14:42:18 post_upgrade|PRODUCT_VERSION_DISPLAY is 10.5.2.12901-1 Unrestricted|<LVL::Info>

 

But on the Subscriber node I still receive the message "The version obtained from the name does not match the active or inactive version of the publisher."

 

So it's not true that when the messages of PRODUCT_TARGET, PRODUCT_NAME, and PRODUCT_VERSION are shown, I can begin the installation on the subscriber.
 

Here's attached the two screenshots of the Publisher and the Subscriber statuses.

 

 

Wish me good luck for the few next hours _/\_

Hope the upgrade went OK.    I'm also glad I'm not the only one who's found this issue.   I'm sure that I have used the feature in the past, but can't remember which versions were involved.

Can anyone report versions where this has worked?  I mean where it's actually been seen to work, not just "should work according to the documentation".

TONY SMITH
Spotlight
Spotlight

Thanks for the replies, I was aware of the documented behaviour.  

What I was pointing out was that this does not always work, and the upgrade last week was an example where it did not.  The subscriber install would not start until the publisher had completed and was waiting for the switch version, even after those messages had appeared in the log.

Have you found that a parallel upgrade is always available in your upgrades?

I remember for sure that it did not work during one of my early 8.x projects, and in some lab builds.  I can't remember whether the issue has arisen with other versions, since in a lot of cases we may do the upgrade and switch in one go, so parallel upgrade of subscribers would not be appropriate.

It would be useful to understand why this path is available in some cases and not in others.

William Bell
VIP Alumni
VIP Alumni

For anyone who is doing more recent upgrades, the issue Tony points out is also a problem with 11.0 "parallel upgrades". The procedure in the 11.0 guide is the same as in previous guides. I am doing an 11.0 upgrade now. I can confirm that even though the publisher node has identified the correct version in the install logs (and reports the new version as the inactive master) the subscriber still bulks at starting the upgrade. 

In my situation, I mounted the upgrade ISO to perform a local upgrade. 

The word that comes to mind: lame.

-Bill (@ucguerrilla)

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Cheers, glad I'm not the only one finding it doesn't work.  I didn't even try when I did and 11->11 upgrade recently, but there was no particular time pressure in that case.

Raking my memory I have a suspicion that last time that parallel upgrade actually worked was in 8.0 or maybe 8.5 (8.0->8.5 upgrade).  I don't have my logbook from that project.   Maybe the change/defect came about when support was added for Refresh Upgrade?

By the way, how are you finding 11.0?  We've been running it since last June or July and the only real issue I've found is that Cisco aren't releasing up to date dial plan or phone load .COP files in compatible format - which I guess shows Cisco's presumption that it's not being deployed in production.