cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1998
Views
0
Helpful
9
Replies
Shahzad Ayub
Beginner

CUE SMTP Settings for Office365

Hi,

 

I am trying to set SMTP settings in Cisco Unity Express but its not working. Our emails are hosted on Office 365 and we are on workgroup.

 

smtp.office365.com

port 587 TLS

sayub@xxx.com

 

I am getting following error when try to send  a test email.

Our ultimate goal is to get voicemail notifications via email.

 

Test Result: Could not connect to SMTP host: smtp.office365.com, port: 587

 

Thanks

​Shahzad

9 REPLIES 9
Nathan Compton
Enthusiast

You have to be on CUE 8.6 for support of TLS.  It sounds like you may be setting up SMTP and just changing the port number.  Here are the GUI instructions for enabling SMTP:

 

Configuring the SMTP Server
Use this procedure to configure the SMTP server.
Step 1 Choose System > SMTP Settings. The System SMTP Settings window appears.
Step 2 Enter the hostname or IP address of the external SMTP server.
Step 3 Select the security mode from the drop-down menu. Select one of the following:
• None: No security setting is enabled.
• SSL: Specifies that SSL is enabled.
• STARTTLS: Specifies that STARTTLS is enabled.
Step 4 Enter the port number used to connect to the SMTP server.
Step 5 Enter the username and password for the server. 
Step 6 Click Apply to save your settings.

 

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/unity_exp/rel8_6/online_help/admin/GUI_PDF/gui_pdf.pdf

Hi Nathan,

 

Thank you for your reply.

I have tried both SSL(465) and STARTTLS(587) but its not working for me.

 

Even I tried with hotmail, Gmail and office365 accounts but nothing is working for me.

One thing i need to mention that I cannot access internet from ISM module but am not sure if its necessary to have internet access on ISM as we are not using local SMTP server.

 

Thanks

Shahzad

 

CUE absolutely needs full IP connectivity to the SMTP server.  Since Office 365 is on the internet, CUE will require internet access.

Hi,

 

You need to have connectivity to O365 in order to relay mails. Best design is to build SMTP relay server internally using IIS (Windows Server 2008 or 2012) which has connectivity to O365. Then all SMTP forwarding applications to point to this server as smart host using port 25. 

 

In this way you have only one server accessing internet and rest of SMTP traffic is internal. Also, you don't need to worry about your internal applications if they support TLS or not as they will connect to relay server over port 25. IIS will take care of secured connection to O365.

 

You will have best control over SMTP external traffic instead of having multiple connections to internet.

Hi Mohamed,

 

We have a local DNS server running on Windows Server 2012, can we build it as SMTP relay server and also please guide me the steps in form of any documents if you have.

 

Thanks

Shahzad

I am posting here the configuration of my router where 10.10.10.2 is ip of ISM module and 10.10.10.1 is its gateway, I am doing NAT for all local pools including 10.10.10.0 and from router I can ping office SMTP server from source 10.10.10.1 but i don't know why I am unable to ping it from ISM module.

 

!
interface Loopback0
 ip address 212.12.179.169 255.255.255.248
!
interface Loopback1
 no ip address
!
interface Loopback25
 ip address 10.100.25.3 255.255.255.255
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description WAN
 bandwidth 9000
 ip address 172.27.176.54 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 load-interval 30
 duplex auto
 speed auto
 crypto map CRYPTOMAP
!
interface ISM0/0
 ip unnumbered GigabitEthernet0/1
 service-module ip address 10.10.10.2 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 10.10.10.1
!
interface GigabitEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex full
 speed 1000
!
interface GigabitEthernet0/2
 ip address 172.29.40.222 255.255.255.252
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface ISM0/1
 description Internal switch interface connected to Internal Service Module
 no ip address
!
interface GigabitEthernet0/0/0
 switchport access vlan 825
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/0/1
 no ip address
!
interface GigabitEthernet0/0/2
 no ip address
!
interface GigabitEthernet0/0/3
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan825
 ip address 172.27.163.34 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 load-interval 30
!
router bgp 64967
 bgp log-neighbor-changes
 neighbor 172.27.163.33 remote-as 29684
 neighbor 172.27.176.53 remote-as 29684
 !
 address-family ipv4
  network 212.12.179.168 mask 255.255.255.248
  neighbor 172.27.163.33 activate
  neighbor 172.27.163.33 weight 50
  neighbor 172.27.163.33 soft-reconfiguration inbound
  neighbor 172.27.176.53 activate
  neighbor 172.27.176.53 weight 150
 exit-address-family
!
ip forward-protocol nd
!
ip http server
ip http access-class 5
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
no ip nat service sip udp port 5060
ip nat inside source list NAT interface Loopback0 overload
ip nat inside source static 10.100.0.10 212.12.179.170
ip nat inside source static tcp 10.100.4.4 3389 212.12.179.172 3390 extendable
ip nat inside source static tcp 10.100.4.5 3389 212.12.179.172 3391 extendable
ip route 10.10.10.2 255.255.255.255 ISM0/0
ip route 10.100.0.0 255.255.252.0 10.10.10.5
ip route 10.100.4.0 255.255.255.0 10.10.10.5
ip route 10.100.8.0 255.255.252.0 10.10.10.5
ip route 10.100.12.0 255.255.252.0 10.10.10.5
ip route 10.100.16.0 255.255.248.0 10.10.10.5
ip route 10.100.25.0 255.255.255.0 10.10.10.5
ip route 10.200.7.156 255.255.255.252 172.29.40.221
!
ip access-list extended ALDARA-KFSH-VPN
 permit ip 10.100.0.0 0.0.31.255 10.99.1.0 0.0.0.255
 permit ip 10.100.0.0 0.0.31.255 host 195.242.197.156
ip access-list extended NAT
 deny   ip host 10.100.4.4 10.99.1.0 0.0.0.255
 deny   ip 10.100.0.0 0.0.31.255 10.99.1.0 0.0.0.255
 permit ip 10.100.4.0 0.0.0.255 any
 permit ip 10.100.12.0 0.0.3.255 any
 permit ip 10.100.0.0 0.0.3.255 any
 permit ip 10.100.8.0 0.0.3.255 any

permit ip 10.10.10.0 0.0.0.255 any
!
access-list 5 permit 10.0.0.0 0.255.255.255
!

Can you ping 10.10.10.2 from a local PC?  It is possible the rest of the network doesn't know how to get to 10.10.10.2.

Yes am able to ping it from my PC which is on 10.100.0.0/24.

 

Thanks

Shahzad

 

 

is this issue resolved? I am facing same issue now... can some one help ?
Content for Community-Ad

Spotlight Awards 2021