cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
508
Views
10
Helpful
10
Replies
Highlighted
Enthusiast

FXO Call Termination with Code 47

Hello Everyone,

 

 I have a strange issue with one remote site. The setup is very simple:

CUCM è H323 GW è FXO Card.

 

The call is working fine for seconds or minutes, sometimes more than 10 minutes. Suddenly the call disconnects. I checked the debug I found the cause code is: Cause Value=47: resource unavailable.

 

However, as per my understanding of the debug the disconnect signal comes from Telco side (FXO). In addition the call use codec G711ulaw from GW to IP Phone and no MTP or transcoders are involved.

10 REPLIES 10
Highlighted
Enthusiast

This is a sample from the output:

*Jan  3 8:15:01.320: htsp_process_event: [0/0/0, FXOLS_OFFHOOK, E_DSP_SUP_DISCONNECT]fxols_outgoing_sup_disc
*Jan  3 8:15:01.320: htsp_timer - 1000 msec
*Jan  3 8:15:02.320: htsp_process_event: [0/0/0, FXOLS_OFFHOOK, E_HTSP_EVENT_TIMER]fxols_disc_confirm
*Jan  3 8:15:02.320: htsp_timer_stop
*Jan  3 8:15:02.320: htsp_timer_stop2
*Jan  3 8:15:02.320: htsp_timer_stop3
*Jan  3 8:15:02.320: //208/80BA6B7C3801/CCAPI/cc_api_call_disconnected:
   Cause Value=47, Interface=0x22937820, Call Id=208
*Jan  3 8:15:02.320: //208/80BA6B7C3801/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=47, Retry Count=0)
*Jan  3 8:15:02.320: //207/80BA6B7C3801/CCAPI/ccConferenceDestroy:
   Conference Id=0x47, Tag=0x0
*Jan  3 8:15:02.320: //207/80BA6B7C3801/CCAPI/ccConferenceDestroy:
  

Highlighted

Can you please post the show run and complete debugs which you have collect. also share the show version from VGW.

Br,

nadeem ahmed

PS: Please rate all useful post.

Br, Nadeem Please rate all useful post.
Highlighted

Hello,

Kindly find the debug in the attachment and I will upload the show run ASAP

Highlighted

is it the same debug in which you were getting resources unavailable with cause_value 47?

Br,

Nadeem

Br, Nadeem Please rate all useful post.
Highlighted

Sorry, I have replaced the file and I added the show run.

Highlighted

Hello,

Have you configured supervisory disconnect on the FXO port? If yes, please don't use "anytone". Also can you share voice port configuration. If using custom cptone then make sure you are using the correct disconnect frequency and cadence. Invalid values might cause abrupt call disconnect like this.

Highlighted

Hello,

I'm using the following configuration under the port


voice-port 0/0/0
 trunk-group OutGoing
 supervisory disconnect dualtone mid-call
 cptone BE
 timeouts initial 5
 timeouts interdigit 3
 timeouts call-disconnect 3
 timeouts ringing 5
 timeouts wait-release 1
 timing hookflash-out 500
 timing guard-out 300
 impedance complex2
 caller-id enable
!

as you can see I'm using dual tone.

when I saw this line during my troubleshooting:

*Jan  3 8:15:01.320: htsp_process_event: [0/0/0, FXOLS_OFFHOOK, E_DSP_SUP_DISCONNECT]fxols_outgoing_sup_disc

I removed this line from the configuration :

supervisory disconnect dualtone mid-call

But I had FXO disconnect issue, " line keeps off hook"

Regards,

Highlighted

Hi,

You can see "E_DSP" which means DSP detected a disconnect tone.There are two options you can try

1. Configure a custom CPTONE instead of standard CPTONE for disconnect. I need packet capture to find out correct disconnect tone. Remove dual tone command make a call and disconnect the call from PSTN side. The IP phone will hear a disconnect tone. Can you capture this tone using wireshark by connecting PC on the back of phone? I can tell you correct frquency and cadence if you can provide the capture

2. change the CPTONE from BE to something else. For ex; BR

Highlighted

Hello, I recorded the disconnection tone and I added a custom cp-tone. still the same issue but the disconnect cause now: 86

//296/D0035D9B8150/CCAPI/cc_api_call_disconnected:
   Cause Value=86, Interface=0x22937820, Call Id=296

any idea?

Highlighted
Beginner

Yoo cheking FXO port connector pinout. Because cannot open FXO port and The FXO port does not have enough power .  You rebuild connector jack.