cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
442
Views
0
Helpful
3
Replies
Highlighted
Beginner

H323 - RTP from fxs port starts before call_connect

Hello,


I am encoutering an very strange behaviour.

ECOS - FXS port on FXS112 - SCCP - CUCM cluster - H323 - VoiceRouter - E1 - Provider

We have an ECOS system, which is an emergency system that sends out a message in case of emergency. The system dials internal numbers, national numbers and national mobile numbers, and when the called person answers the call, the system starts to send a voice message on the line.

The ECOS system is connected through several analog lines to FXS ports of an analogue voice gateway. The analogue gateway is connected to the CUCM cluster via SCCP.

The Voice Router that we use to send out the calls, is configured via H323.

The config of my dial-peer is:

dial-peer voice 400 pots

trunkgroup 1

description to BGC

destination-pattern [01]T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

no digit-strip

          

For internal calls and national calls, the system works fine.
We have problems when the system dials out to mobile numbers. When the system calls out, it starts to send the message before a call_connect is sent from the provider. So when the called person answers the call, the message is already playing and he misses the beginning of the message.
Calls to mobile numbers are using the same call setup and dial-peer as calls to normal national numbers.

I have tried to send the call over a voice router that uses MGCP, and it works fine then.

I also tried to send the call over a voice dial-peer without the progress indicators, and the problem remains.

For this particular site, we can not configure the Voice Router with MGCP, we have to keep the H323 setup.

Sending out the call over another site, via MGCP, is also not a solution, because if we have problems, the call should be sent over the local external line.

Can anyone help please, I don't know where to start with troubleshooting...

Btw, this emergency system is used for a nuclear power plant, so you can imagine that it is really important. :-)

Thanks a lot!

Antoine

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Can you check if the device support answer supervsion via battery reversal?

That is the only way so it can know that the call ans been answered remotely, and start media.

View solution in original post

3 REPLIES 3
Highlighted
Hall of Fame Master

Can you check if the device support answer supervsion via battery reversal?

That is the only way so it can know that the call ans been answered remotely, and start media.

View solution in original post

Highlighted

Hello Paolo,

I will check this and let you know.

Thanks for your reply!

Best regards,

Antoine

Highlighted
Beginner

Hi Paolo,

Disabling the battery-reversal solved the problem.

Thanks a lot!

Antoine

Content for Community-Ad