cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2752
Views
0
Helpful
14
Replies
Beginner

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hello,

I am trying to integrate my Nortel Option 61C with my  Cisco 2901 and CUCM. The telco carrier 2 PRI go into the Nortel, and then I have another PRI between the two PBXs.  I have asked my Nortel PBX vendor to follow the Document 12986 ( Case Study: Nortel 61C PBX to Cisco IP Telephony Migration ) Starting Step 9. http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_white_paper09186a00801115e0.shtml

My Nortel vendor mentions he has a D channel mismatch on his side.

On the Cisco Gateway, ISDN status indicates Layer 1 is shutdown.  The pins are correct as I had this up before I rebooted the cisco gateway.  Any suggestions will be helpful.

vg01#show isdn status
Global ISDN Switchtype = primary-dms100

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-dms100
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        SHUTDOWN
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x00000000
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0

On my cisco side I have the following relevant config

++++++++++++++++++++++++++++++++++++++++++

card type t1 0 0

logging buffered 51200 warnings

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

no ipv6 cef

ipv6 spd queue min-threshold 62

ipv6 spd queue max-threshold 63

no ip source-route

ip cef

ip multicast-routing

!

isdn switch-type primary-dms100

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call carrier capacity active

voice rtp send-recv

application

global

service alternate DEFAULT

hw-module pvdm 0/0

!

controller T1 0/0/0

cablelength short 110

pri-group timeslots 1-24 service mgcp

!

ip ssh version 2

!

class-map match-any MetroQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-any MetroQoS-VoIP-Control-Trust

match ip dscp cs3

match ip dscp af31

!

!

policy-map MetroQoS-Policy-Trust

class MetroQoS-VoIP-RTP-Trust

priority percent 70

class MetroQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default

fair-queue

!

interface Port-channel47

description BONDED-INTERFACE

ip address 192.168.124.4 255.255.255.0

service-policy output MetroQoS-Policy-Trust

hold-queue 150 in

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description PRIMARY-INTERFACE

no ip address

duplex auto

speed auto

channel-group 47

!

interface GigabitEthernet0/1

description SECONDARY-INTERFACE

no ip address

duplex auto

speed auto

channel-group 47

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

voice-port 0/0/0:23

!

ccm-manager switchback immediate

ccm-manager fallback-mgcp

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.15.11

ccm-manager config

!

mgcp

mgcp call-agent mcucm01 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Port-channel47

mgcp bind media source-interface Port-channel47

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

14 REPLIES 14
Highlighted
Contributor

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi

What is the controller status ?

Nortel has set the 23 channel for signalling?

Sent from Cisco Technical Support iPhone App

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Thank your reply

I am not sure if Nortel has set the 23 channel for signalling. From the Cisco doc, it may be 19.

Below here is controller T1 status.

vg01#show controller T1

T1 0/0/0 is down.

  Applique type is Channelized T1

  Cablelength is short 110

  Receiver has remote alarm.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20100222, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  CRC Threshold is 320. Reported from firmware  is 320.

  Data in current interval (365 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 365 Unavail Secs

  Total Data (last 69 15 minute intervals):

     0 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 62100 Unavail Secs

Build the D-Channel
The D-channel is used for signaling between the two systems for call setup and teardown. You have to configure the new D-channel so that it knows:

•Clock source.

•Bandwidth allocation.

•Loop association.

The D-channel is built and administered in load 17. This example shows the new D-channel configuration. The bold text shows that the clock source is external, the new D-channel is associated with loop 19, and the bandwidth allocation for the D-channel is 64 KC.

Note: The bandwidth allocation for the D-channel is set with the D-channel transmission rate (DRAT) prompt.

ADAN DCH 1
CTYP MSDL
DNUM 9
PORT 2
DES CISCO-LOOP19
USR PRI
DCHL 19
OTBF 127
PARM RS422 DTE
DRAT 64KC
CLOK EXT
IFC D100
SIDE USR
CNEG 1
RLS ID **
RCAP ND2
T200 3
T203 10
N200 3
N201 260
K 7

vg01#show controller T1

T1 0/0/0 is down.

  Applique type is Channelized T1

  Cablelength is short 110

  Receiver has remote alarm.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20100222, FPGA: 13, spm_count = 0

  Framing is ESF, Line Code is B8ZS, Clock Source is Line.

  CRC Threshold is 320. Reported from firmware  is 320.

  Data in current interval (365 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 365 Unavail Secs

  Total Data (last 69 15 minute intervals):

     0 Line Code Violations, 0 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 62100 Unavail Secs

I have asked the Nortel vendor to follow the cisco doc

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_white_paper09186a00801115e0.shtml

Build the D-Channel
The D-channel is used for signaling between the two systems for call setup and teardown. You have to configure the new D-channel so that it knows:

•Clock source.

•Bandwidth allocation.

•Loop association.

The D-channel is built and administered in load 17. This example shows the new D-channel configuration. The bold text shows that the clock source is external, the new D-channel is associated with loop 19, and the bandwidth allocation for the D-channel is 64 KC.

Note: The bandwidth allocation for the D-channel is set with the D-channel transmission rate (DRAT) prompt.

ADAN DCH 1
CTYP MSDL
DNUM 9
PORT 2
DES CISCO-LOOP19
USR PRI
DCHL 19
OTBF 127
PARM RS422 DTE
DRAT 64KC
CLOK EXT
IFC D100
SIDE USR
CNEG 1
RLS ID **
RCAP ND2
T200 3
T203 10
N200 3
N201 260
K 7

Highlighted
Contributor

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi

Ok

But i see here that the layer 1(physical layer is down)

Most propably that the cable that you use is not the correct

Did you use a cross-over T1 cable?

http://support.red-fone.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=1

Some other issues that you have to check when the layer 1 is down

*clock reference

*framing

*line coding

*switch type

Ensure one side of the connection is providing clock and the other site is deriving clock

Ensure both sides are configured with the same framing and line coding

Regards

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Contributor

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi

Did you manage to solve your issue?

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi ,

Issue not resolved as yet.

The integration was set up correctly and Layer 1 was up with primary isdn switch type ni 2.

I was able to make calls from the cisco phones to the phones hanging off the Nortel PBX.  However I was not able to make calls from the cisco ip phones to any external PSTN numbers.

I was also able to recieve calls on the cisco ip phones internal & external.

telco pri(2) ---- Nortel PBX ------cross over cable---------------cisco VG-----------CAT5-------------CUCM

Since I was not able to make calls from the cisco ip phones to any external PSTN numbers, the Nortel PBX vendor and I agreed to try primary isdn switch type DMS-100(follow the above doc)

I am to provide clocking, I have changed that to LINE, Internal, and now they are not working at all.

Will different setting on clocking , USER, NETWORK affect layer 1 ?

Thanks

Highlighted
Contributor

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi

For sure affect layer 1..

If you put network then you are giving the clocking. By put user then nortel must give the clocking.. if you sent the calls for pstn ( route pattern 9! To the mgcp connection with nortel then nortel must perform the other steps

Sent from Cisco Technical Support iPhone App

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi,

I have set the clocking to internal and the  Layer 1 has changed to ACTIVE,.

Layer 2 awaiting establishment ?

#show isdn status
Global ISDN Switchtype = primary-dms100

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-dms100
        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 114
    Total Allocated ISDN CCBs = 0

Highlighted
Contributor

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Try in gw:

no mgcp

mgcp

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Participant

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Sorry to jump in late, Clock was our issue with this.

only the PBX that has the Provide PRI should provide the clock. if Cisco provides the Clock but Nortel has the provider PRI this will bomb in about 30 days, clocks will go out of sync and call flow will die altogether.

We will be finishing our converstion from Nortel PBX's here in 60 Days.

Highlighted
Participant

Help :Nortel 61C PBX to Cisco IP Telephony Migration

So the Cisco Phones can Call Nortel,

Nortel can call Cisco.

Cisco cannot call PSTN.

     Easy Fix, you must pass the out dialing digit to the Nortel.So if the Nortel is required "9" for PSTN, dont strip the 9 on the cisco side, send it to Nortel.

Highlighted
Beginner

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Hi,

I cannot make calls from cisco to Nortel either way , I get a fast busy.

Separately,

I have specified the following for my PBX vendor:

Build the D-Channel (taken from http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_white_paper09186a00801115e0.shtml)

The D-channel is used for signaling between the two systems for call setup and teardown. You have to configure the new D-channel so that it knows:

  • Clock source. (Cisco GW is providing the clocking )


  • Bandwidth allocation.


  • Loop association. (Loop 19)   <----- What do I need to specify on the Cisco Gateway ?  Do I need to specify which is my D Channel.  19 ? I am using MGCP  (see above config)


The D-channel is built and administered in load 17. This example shows the new D-channel configuration. The bold text shows that the clock source is external, the new D-channel is associated with loop 19, and the bandwidth allocation for the D-channel is 64 KC.

Highlighted
Participant

Help :Nortel 61C PBX to Cisco IP Telephony Migration

Here are a couple of screen shots of our PRI Setup.

Here is are some specifics of the Nortel setup of the PRI.

1st  is a TNB on loop 79  channel 1    note you have 3 tie line T-1’s to CISCO 79,95, & 60

2nd Route data block for route 30, cicsco tie lines, all one group

3rd  A snapshot (frozen in time ) of loop 79  23 B-channels and 1 D-channel

4th  Programing of the D- channel

>

OVL000
>

OVL000
>

OVL000
>ld 20


PT0000
REQ: prt

TYPE: tnb

TN   79 1

DATE

PAGE

DES


DES  CISCO
TN   079 01
TYPE TIE
CDEN SD
CUST 0
TRK  PRI
PDCA 1
PCML MU
NCOS 6
RTMB 30 1
B-CHANNEL SIGNALING
TGAR 0
AST  NO
IAPG 0
CLS  UNR DTN CND ECD WTA LPR APN THFD HKD SPCD
     P10 VNL
TKID
AACR NO
DATE  5 AUG 2010


NACT

REQ:

REQ PRT
TYPE: ****
OVL000
>

OVL000
>ld
AUD000
21

PT1000

REQ: prt

TYPE: rdb

CUST 0

ROUT 30


TYPE RDB
CUST 00
ROUT 30
DES  CISCO
TKTP TIE
M911P NO
ESN  NO
CNVT NO
SAT  NO
RCLS EXT
VTRK NO
NODE
DTRK YES
BRIP NO
DGTP PRI
ISDN YES
    MODE PRA
    IFC  ISGF
    SBN  NO
    PNI  00000
    NCNA NO
    NCRD NO
    CHTY BCH
    CTYP UKWN
    INAC NO
    ISAR NO
    CPFXS YES
    DAPC NO
    INTC NO
MBXR NO
DSEL VOD
PTYP PRI
AUTO NO
DNIS NO
DCDR NO
ICOG IAO
SRCH LIN
TRMB YES
STEP
ACOD 7783
TCPP NO
PII NO
AUXP NO
TARG
CLEN 1
BILN NO
OABS
INST
IDC  NO
DCNO 0 *
NDNO 0
DEXT NO
ANTK
SIGO STD
ICIS YES
TIMR ICF  512
     OGF  512
     EOD  13952
     NRD  10112
     DDL  70
     ODT  4096
     RGV  640
     GRD  896


PAGE 002

     SFB  3
     NBS  2048
     NBL  4096

     IENB  5
     TFD  0
     VSS  0
     VGD  6
DRNG NO
CDR  YES
INC  NO
LAST NO
QREC NO
OAL  YES
AIA  YES
OAN  YES
OPD  NO
NATL YES
VRAT NO
MUS  NO
FRL  0 0
FRL  1 0
FRL  2 0
FRL  3 0
FRL  4 0
FRL  5 0
FRL  6 0
FRL  7 0
OHQ  NO
OHQT 00
CBQ  NO
AUTH NO
TDET NO
TTBL 0
ATAN NO
PLEV 2
ALRM NO
ART  0
SGRP 0
ARDN NO
AACR NO

REQ: ****
OVL000
>ld 60

DTI000
.stat 79


PRI*  TRK  LOOP 79 - ENBL
FFMT/LCMT/YALMT:  ESF/B8Z/FDL
TRACKING
SERVICE RESTORE: YES
YEL ALM PROCESS: YES
ALARM STATUS : NO ALARM
CH 01 - IDLE TIE   VOD  *           CH 02 - IDLE TIE   VOD  *
CH 03 - IDLE TIE   VOD  *           CH 04 - IDLE TIE   VOD  *
CH 05 - IDLE TIE   VOD  *           CH 06 - IDLE TIE   VOD  *
CH 07 - IDLE TIE   VOD  *           CH 08 - IDLE TIE   VOD  *
CH 09 - IDLE TIE   VOD  *           CH 10 - IDLE TIE   VOD  *
CH 11 - IDLE TIE   VOD  *           CH 12 - IDLE TIE   VOD  *
CH 13 - BUSY TIE   VOD  *           CH 14 - BUSY TIE   VOD  *
CH 15 - BUSY TIE   VOD  *           CH 16 - IDLE TIE   VOD  *
CH 17 - IDLE TIE   VOD  *           CH 18 - BUSY TIE   VOD  *
CH 19 - BUSY TIE   VOD  *           CH 20 - BUSY TIE   VOD  *
CH 21 - BUSY TIE   VOD  *           CH 22 - BUSY TIE   VOD  *
CH 23 - BUSY TIE   VOD  *           CH 24 - DCH 79
.*****
OVL000
>

OVL000
>

OVL000
>ld 22

PT2000

REQ  prt

TYPE adan dch 79


ADAN     DCH 79
  CTYP MSDL
  GRP  2
  DNUM 11
  PORT 1
  DES  CISCO
  USR  PRI
  DCHL 79
  OTBF 32
  PARM RS422  DTE
  DRAT 64KC
  CLOK EXT
  IFC  ISGF
    PINX_CUST 0
    ISDN_MCNT 300
  CLID OPT0
  CO_TYPE  STD
  SIDE USR
  CNEG 1
  RLS  ID  **
  RCAP COLP NDI CCBI PRI DV3I CTI  QMWI
  PR_TRIGS DIV 2 3
           CNG 2 3
  PR_RTN NO
  MBGA NO
  OVLR NO
  OVLS NO
  T310 120
  T200 3
  T203 10
  N200 3
  N201 260
  K    7

REQ  ****
OVL000
>

OVL000
>

OVL000
>

OVL000
>

Highlighted
Beginner

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Thank you all for suggestions etc.

I finally got this to work.

Using ISDN switch type 5 ESS and Network on the Cisco side, and USER on the Nortel side.

Highlighted
Contributor

Re: Help :Nortel 61C PBX to Cisco IP Telephony Migration

Glad to hear that

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
CreatePlease to create content