cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
239
Views
5
Helpful
11
Replies
Highlighted
Beginner

No Ringback on Calls Transferred Off-net

Cisco Unified CM Administration System version: 10.5.2.12901-1

I have two clusters where both use SIP trunks from the same carrier.

The issue is that ringback from blind transferred calls to an external phone number on cluster "A" is not heard by the calling party.

Cluster "B" works as it should. The calling party will hear ringback.

Also, if the call in transferred to an internal number on either cluster, the calling party hears rinback as expected.

This does not appear to be a media resource group or annunciator issue although I haven't tried resetting the annunciator.

Is there some related service that would need to be restarted or some configuration that needs to be verified?

 

The Cisco phones in the following examples are model 8841 & 8851 SIP.

 

Cluster "A" No Ringback Call Example
DN 1234 calls DN 5678.
DN 5678 presses Transfer key.
DN 1234 now hears MOH.
DN 5678 dials external number 9,1-213-555-1212 and then presses transfer key again to complete transfer.
DN 1234 now hears dead air until the external number answers call.

 

Cluster "B" Ringback Works Call Example
DN 1234 calls DN 5678
DN 5678 presses Transfer key.
DN 1234 now hears MOH.
DN 5678 dials external number 9,1-213-555-1212 and then presses transfer key again to complete transfer.
DN 1234 now hears ringback until the external number answers call.

11 REPLIES 11
Highlighted
Beginner

Any insight on this would be appreciated.

Is resetting the annunciator service affecting?

Highlighted
Participant

Step 1
From the Cisco Unified CM Administration user interface choose System > Service Parameters.

Step 2
On the Service Parameter Configuration window choose the Cisco Unified CM server you want to configure from the Server drop-down list.

Step 3
Choose Cisco CallManager (Active) from the Service drop-down list.

Step 4
Choose True from the Block OffNet to OffNet Transfer drop-down list. The default value specifies False.

Step 5
Click Save.

Highlighted
Participant

We need check on three locations that devices trunk and service permaters

 

Step 1
From Cisco Unified CM Administration, choose Device > Gateway.

The Find and List Gateways window displays.

Step 2
To list the configured gateways, click Find.

The gateways that are configured in Unified Communications Manager display.

Step 3
Choose the gateway that you want to configure as OffNet or OnNet.

Step 4
In the Call Classification field choose OffNet or OnNet. If you have enabled clusterwide restrictions an all gateways, configure each gateway to Use System Default (this reads the setting in the Call Classification service parameter and uses that setting for the gateway).

Step 5
Click Save.

Highlighted
Participant

Step 1
From Cisco Unified CM Administration, choose Device > Trunk.

The Find and List Trunk window displays.

Step 2
To list the configured trunks, click Find.

The trunks that are configured in Unified Communications Manager display.

Step 3
Choose the trunk that you want to configure as OffNet or OnNet.

Step 4
From the Call Classification drop-down list, choose one of the following fields:

OffNet - When you choose this field, this identifies the gateway as an external gateway. When a call comes in from a gateway that is configured as OffNet, the system sends the outside ring to the destination device.

OnNet - When you choose this field, this identifies the gateway as an internal gateway. When a call comes in from a gateway that is configured as OnNet, the system sends the inside ring to the destination device.

Use System Default - When you choose this field, this uses the Unified Communications Manager clusterwide service parameter Call Classification.

Note
If you have enabled clusterwide restrictions an all trunks, configure each trunk to Use System Default (this reads the setting in the Call Classification service parameter and uses that setting for the trunk)

Step 5
Click Save. 

 

This three configuration need to be checked.

Highlighted
Participant

Enable PSTN access in the voice gateway if its MGCP voice gateway

Highlighted
Participant

Cisco parameter correct in the configuration

Product: Cisco MGCP E1 Port

 

Device Protocol: Digital Access PRI

End Port Name* S0/SU1/DS1-0@HQ-1

Description S0/SU1/DS1-0@HQ-1

Highlighted

Thanks for all your suggestions however; in checking all of these settings between both clusters I see all are configured the same. In my mind, if it works on one cluster it should work on both. No recent changes have been made to either cluster. This did work at one point. Not sure what broke it.

Highlighted
Beginner

Maybe I should have mentioned that the Cisco phones involved are 8841 & 8851 SIP.

Highlighted
Beginner

I still haven't figured this out. Any additional suggestions from anyone would be appreciated.

Highlighted

Hi,

Even though its same carrier depending on which country you are, they might
deliver different settings. Try to enable 100rel/PRACK on site B. Also, if
your provider is SIP trunk (not PRI), enable that midcall media changes are
allowed on CUBE.

**** please remember to rate useful posts
Highlighted

Thanks for the response. I will try your suggestions. This is SIP trunking. Not sure how to enable 100rel/PRACK or midcall media. Site "B" works as it should. Site "A" has the issue.

 

Not sure I described this entirely correct.

If this is a carrier or SIP trunk issue, why is it that the person transferring the call can hear the initial ringback and when they complete the transfer the original calling party listens to dead air rather than getting ringback?

 

DN 5279 calls DN 5244.

DN 5244 presses TRF key and gets dial tone.

Meanwhile, DN 5279 hears MOH.

After DN 5244 gets dial tone, he dials 912135551212 and hears ringback then presses Transfer key.

DN 5279 now hears dead air until the transferred to number answers call.  

Content for Community-Ad