cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
275
Views
0
Helpful
14
Replies
Highlighted
Beginner

SIP CUBE Faxing to CUCM - RightFax not working

Hi All,

 

I need some help, we have recently started moving from MGCP Gateways to SIP CUBE on our Routers as the PRI quality was not good.

 

I have Ported my Fax Range to the new ISP and currently having trouble receiving Faxes when it hits my CUBE.

 

Please we have a SIP Trunk between CUCM and our RightFax Server and I can confirm is working for all MGCP Gateways.

When doing a call to my FAX number using the CUBE I do hear the Fax tones but the call is dropped after 3 seconds.

 

This means all routing is correct but it seems like connection is dropping.

 

I have read online it might be because I'm sending g729 and g711ulaw to my Fax but can confirm when changing the Codec the call fails instantly.

 

I have not worked with Faxing before and it's extremely hard to troubleshoot.

 

any suggestions or ways to use RTMT to see what the issue is. 

 

Or has someone else using RightFax used their CUBE Gateway for Faxing and got it working.

 

Thanks in advance.

Everyone's tags (3)
14 REPLIES 14
Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Could you please post your dial-peer configuration from CUBE to CUCM, also the router configuration

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi,

 

So under Global Config:

 

voice service voip
ip address trusted list
mode border-element
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip

 

Dial Peer incoming Fax number from ISP ----- CUBE

 

dial-peer voice 101 voip
description ##Inbound Calls from SIP##
translation-profile incoming IS-SIP-PWC-CUBE
session protocol sipv2
incoming called-number 27127XXX... (hidden)
voice-class codec 2 (Changed this to a class that support g711ulaw and alwaw to see if this fixes the issue) Generally it sets to g729
dtmf-relay rtp-nte sip-kpml
no vad

 

Dial Peer incoming Fax number from CUBE-----CUCM

dial-peer voice 12 voip
description ##Incoming_CUCM##
preference 1
destination-pattern 27127XXX... (hidden)
session protocol sipv2
session target ipv4:10.XX.XX.XX
voice-class codec 2 (Changed this to a class that support g711ulaw and alwaw to see if this fixes the issue) Generally it sets to g729
voice-class sip bind control source-interface Loopback0
voice-class sip bind media source-interface Loopback0
dtmf-relay rtp-nte sip-kpml

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi,

 

could you please try to directly hard code this to the dial-peers, don't use Voice class codec 2 (or just use one codec here)

 

codec g711ulaw

fax rate 14400

 

Also, use 

 

fax protocol t38 version 0 ls-redundancy 2 hs-redundancy 0 fallback none

 

 

 

let me know if it makes a difference.

 

Thanks!

Jinto.

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi Jinto,

 

I have tried the following you have suggested as before but the issue always remains. 

 

Running a Pcap on the Fax Server I get the following 488 not acceptable media -does not matter if it's g711 or g729

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi Jinto,

 

Please see attached is the error from RTMT.FAX error.PNG

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

In the signaling Diagram can you specify these signals from Which servers, you can replace the IP address with a name for example 

 

if your CUCM IP is 192.168.0.12 replace it with CUCM in the signaling diagram so that it will be easier for me to understand the SIP signals.

 

Can you post that complete Invite message that CUCM sends what codec are you seeing in that, What's the region settings on your SIP trunk from CUCM to the FAX server (Make sure that its 711ulaw)

 

488 can be mostly due to a codec mismatch, but we would want to know where it's happening and based on that we can change settings to resolve this.

 

 

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi Jinto

 

Sorry about that, let me explain quick.

 

First Line is my CUBE Router 192.168.1.10

Second line is my First Subscriber 192.168.1.11

3rd Line is my Second Subscriber 192.168.1.12 - Not sure why it's going to both Subscribers

4th Line is the connection to the RightFax Server over a SIP Trunk - lets say 192.168.1.50 is the IP.

 

Please note we did have two Right Fax Servers for Redundancy and one is currently offline, there is also two SIP Trunks Pointing to Both RightFax Server.

 

When Testing a working solution to Right Fax as seen below the call only hits the one Subscriber and Routes successfully to my Fax Server.

 

Subscriber 1 --------------- RightFax Server 

This is when dialing the Fax number from a cellphone.

 

Fax Working.PNG

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

If you click those sip signaling diagram on RTMT you can View the contents on it (Click on invite and you can see complete Invite sip signal), from your non-working configuration can you post the contents of each message such as Invite, trying and also the contents of 488 SIP message so that I can review what's happening between CUCM and Rightfax.

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi Jinto,

 

I will try to get this to you as RTMT takes forever to load the messages and I need to remove IP's

Can you maybe specify which ones are needed most so I can get it to you, or is all the messages needed?

 

As Kevin also mentioned, we are definitely using t.38 on the FAX Server as I did see RTP messages on a call that worked and a few t.38 messages coming through.

 

No t.38 messages are present when a call comes from the SIP Cube.

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

I would like to see below interaction,

 

SIP.JPG

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Have a couple more questions, Please confirm below diagram is correct if this is correct your CUCM is sending 488 Media not acceptable, Do you have "MTP Required" option checked in the SIP trunk (If yes remove it), are you using standard SIP profile (If no use the standard SIP profile for this trunk)?  in the SIP trunk security profile for outgoing requests have you set it as UDP ("The default is TCP but for the right fax, it should be UDP ")

 

Also in SIP trunk under SDP Information make sure that you have to Send send-receive SDP in mid-call INVITE

 

488notacceptable_Media.jpg

 

SDP.JPG

 

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Try adding no modem passthrough to your dial-peer.  We had to add this in to get our fax server working.  Also, are you sure it's not trying to use t.38 vs g711/729?

***Please Mark and Rate helpful posts***
Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Hi Kevin,

 

Yes it does use T.38 I did see the T.38 request coming through when doing a test from a PRI where Fax is working. I did also then notice that G711alaw PCM was used in the Wireshark traces and that's why I was under the impression that I might be sending the wrong Codec.

 

When adding no modem passthrough to my Dial Peer from Cube to CUCM the fax still fails.

Beginner

Re: SIP CUBE Faxing to CUCM - RightFax not working

Have you verified with your SIP provider that they do support T.38?  Can you run a capture at CUBE?

***Please Mark and Rate helpful posts***
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards