Showing results for 
Search instead for 
Did you mean: 

Sip Trunk Stopped Working



For the life of me I cannot figure out why my sip trunk stopped working.  If I look at the debugs these are the errors that I keep getting:

2811voice#REGISTER SIP/2.0

Via: SIP/2.0/UDP;branch=z9hG4bK18A1C84

From: <>;tag=3197250-C7F

To: <>

Date: Thu, 12 May 2011 17:53:13 GMT

Call-ID: 86135A3E-7BF711E0-8003DD75-791FFF66

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1305222793


Contact: <sip:2279854920@>

Expires:  200

Supported: path

Content-Length: 0


047832: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Error/act_sent_register_wait_100: act_sent_regist

er_wait_100: Out of retries

047833: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIDecrementOverloadCount: Count:Local 0 G

lobal 0

047834: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Error/ccsip_api_register_result_ind: Message Code

Class 4xx Method Code 100 received for REGISTER

047835: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_spi_register_free_rcb: Freeing rcb [0x4


047836: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_register_reset_dns_cache: CCSIP_REGISTE

R:: registrar 0 DNS resolved addr reset

047837: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Error/ccsip_api_register_result_ind: SIP Registra

tion Retries Exhausted

047838: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPIRegPthruProcessResponse: Processing re

sponse w/ resp code == 408

047839: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIGetRPCBFromRCB: Retreiving RCB [0x4ACC0

400] from RPCB [0x0]

047840: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Error/sipSPIRegPthruProcessResponse: Error NO RPC


047841: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/ccsipRegisterStartRCBTimer: Starting timer fo

r pattern 2279854920 for 120 seconds

047842: May 12 12:53:17.535 CDT: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIDeleteContextFromTable: Context for key

=[396] removed.

047843: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPIUdeleteCcbFromUACTable: ****Deleting f

rom UAC table.

047844: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPIUdeleteCcbFromTable: Deleting from tab

le. ccb=0x4A5EC5E8 key=86135A3E-7BF711E0-8003DD75-791FFF66

047845: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPIFlushEventBufferQueue: There are 0 eve

nts on the internal queue that are going to be free'd

047846: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPI_ipip_free_codec_profile: Codec Profil

es Freed


047847: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/ccsip_offer_ans_delete:

047848: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/ccsip_iwf_delete:

047849: May 12 12:53:17.535 CDT: //395/000000000000/SIP/Info/sipSPIUfreeOneCCB: Freeing ccb 4A5EC5E8

2811voice#show sip-ua register status

Line                             peer       expires(sec) registered P-Associ-URI

================================ ========== ============ ========== ============

2279854920                       -1         114          no

Any ideas on why this could be happening?  I was running version 15.1(3)M and upgraded to 15.1(4)M, but still the problem persists.


13 Replies 13

Mike Lydick

are you using DNS to resolve the SIP SBC host name? Did IP address change?

408 usually means request timeout.

sipSPIRegPthruProcessResponse: Processing response w/ resp code == 408

Yes, I am using dns, and it was working....

So I just changed everything from to ipv4:, and I still have the same error messages.


No changes, then the provider changes something. Maybe upgraded their cisco router from 12.4.x  to 15.1.3 and forgot to trust your network .

Do you want to post your redacted config so the forum can review?


BTW I assume that SBC address is in your IP trust list?


No changes on my end happened....

voice service voip

ip address trusted list


allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip


  registrar server expires max 250 min 200



credentials username 2279851457 password 7 12345 realm

authentication username 2279851457 password 7 12345 realm

no remote-party-id

retry invite 4

retry response 3

retry bye 2

retry cancel 2

retry register 5

timers trying 1000

timers connect 100

timers register 250

registrar ipv4: expires 200

sip-server ipv4:


Try adding their address to your IP trust list.

Still no go with this:

voice service voip

ip address trusted list



allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip


  registrar server expires max 250 min 200


voice class h323 1

  h225 timeout tcp establish 3

Docs on the IP trust feature...

I had to do that in order to let the Call Manager to route calls too it, that is why there is the ip : in the list.

But still no sip trunk connection...

What is this:

072468: May 12 20:03:50.935 CDT: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIGetRPCBFromRCB: Retreiving RCB [0x4ABB1098] from RPCB [0x0]

072469: May 12 20:03:50.935 CDT: //592/000000000000/SIP/Error/sipSPIRegPthruProcessResponse: Error NO RPCB

Cannot see from the supplied log that they are responding.

Maybe turn on additional sip debugging will give more insight or a local packet capture off the SBC will get plenty of information.

Either way I believe I would be contacting the carrier with questions about what changed. They will need to help indicate if something is off with their security.

Redacted, great word. Plus 5!

Found out it was my ISP blocking it.

Could you please clarify on what they were blocking?


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers