03-11-2013 05:22 PM - edited 03-16-2019 04:12 PM
Hi All,
Currently using a cisco router as my SIP GW. My hope is to use this router as my sip trunk to my provider. When i call the number assigned to the gw im getting the following two entries in the debug.
//12/0E601AFD8035/SIP/Error/sipSPI_ipip_copy_sdp_to_channelInfo: failed to update call entry
//-1/xxxxxxxxxxxx/SIP/Error/sipSPIGetContentQ931: No Inbound Container Created !!!
below is my run.
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.03.11 20:15:33 =~=~=~=~=~=~=~=~=~=~=~=
Using username "gwAdmin".
Using keyboard-interactive authentication.
Password:
VoIPGw>en
Password:
VoIPGw#sh run
Building configuration...
Current configuration : 3271 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoIPGw
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password Mansoor91111
!
aaa new-model
!
!
!
!
aaa session-id common
--More-- !
!
dot11 syslog
ip source-route
ip cef
!
!
!
!
ip domain name VoIPGw
ip name-server 8.8.8.8
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
voice service voip
allow-connections sip to sip
redirect ip2ip
sip
bind control source-interface FastEthernet0/0
--More-- bind media source-interface FastEthernet0/0
header-passing
sip-profiles 1
!
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
!
!
!
!
voice class sip-profiles 1
response ANY sip-header Allow-Header modify "invite, options, bye, cancel, ack, prack, update, refer, subscribe, notify, info, register" "invite, bye, cancel, ack, prack, subscribe, notify, info, register"
response 183 sip-header Allow-Header modify "ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY" "ACK, BYE, CANCEL, INFO, INVITE, PRACK, refer, notify"
response ANY sip-header Allow-Header modify "INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER" "INVITE, BYE, CANCEL"
response ANY sip-header Allow-Header modify "INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER" "INVITE, BYE, CANCEL, ACK, PRACK, SUBSCRIBE, NOTIFY, INFO, REGISTER"
--More-- !
!
!
!
!
!
!
!
!
!
voice-card 0
no dspfarm
!
!
!
username gwAdmin password 0 Mansoor91111
!
!
!
archive
log config
hidekeys
!
--More-- !
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0/0
ip address <removed> 255.255.255.240
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
shutdown
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
--More-- !
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface Vlan1
description MGMT Vlan
ip address 192.168.10.52 255.255.255.0
!
interface Vlan4
description Server Vlan
no ip address
!
ip default-gateway <removed>
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
--More-- no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
--More-- voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control
description Music On Hold Port
!
!
!
dial-peer voice 100 voip
destination-pattern <removed>
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
no vad
!
!
sip-ua
--More-- credentials username 138957_yup password 7 10620C0D1613423D5C0D3A6565 realm 138957_yup
authentication username 138957_yup password 7 10620C0D1613423D5C0D3A6565
registrar dns:newyork.voip.ms expires 3600
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
password cisco
transport input ssh
!
end
VoIPGw# exit
Solved! Go to Solution.
03-12-2013 04:30 AM
Is this the dial-peer you are using to send calls to your ITSP
dial-peer voice 100 voip
destination-pattern
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
no vad
It is not configured correctly..You need to add
session protocol sipv2
Add that do another test and send
debug ccsip messages
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
03-12-2013 04:30 AM
Is this the dial-peer you are using to send calls to your ITSP
dial-peer voice 100 voip
destination-pattern
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
no vad
It is not configured correctly..You need to add
session protocol sipv2
Add that do another test and send
debug ccsip messages
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
03-12-2013 04:36 AM
DOH! Clicked the wrong button
The dial peer im using is trying too to deliver inbound calls to CUCM.
03-12-2013 04:48 AM
below is my updated dial peer config with sip messages.
dial-peer voice 100 voip
destination-pattern
voice-class sip options-ping 60
session protocol sipv2
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
VoIPGw#
VoIPGw#
VoIPGw#
*Mar 12 12:23:07.697: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:XXXXXX7522@XX.XX.134.24:5060 SIP/2.0
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK2d8e8860
Max-Forwards: 70
From: "GARRETT "
To: <>>XXXXXX7522@XX.XX.134.24:5060>
Contact:
Call-ID: 5313cd90691bd5cd3a12d9b76bdeaaf7@74.63.41.218:5060
CSeq: 102 INVITE
User-Agent: voip.ms
Date: Tue, 12 Mar 2013 11:39:59 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Remote-Party-ID: "GARRETT "
Content-Type: application/sdp
Content-Length: 268
v=0
o=root 615418521 615418521 IN IP4 74.63.41.218
s=voip.ms
c=IN IP4 74.63.41.218
t=0 0
m=audio 15710 RTP/AVP 0 18 101
a=rtpmap:0 PCMU/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=sendrecv
*Mar 12 12:23:07.713: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK2d8e8860
From: "GARRETT "
To: <>>XXXXXX7522@XX.XX.134.24:5060>
Date: Tue, 12 Mar 2013 12:23:07 GMT
Call-ID: 5313cd90691bd5cd3a12d9b76bdeaaf7@74.63.41.218:5060
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0
*Mar 12 12:23:07.713: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:XXXXXX7522@192.168.10.51:5060 SIP/2.0
Via: SIP/2.0/UDP XX.XX.134.24:5060;branch=z9hG4bK1F488
Remote-Party-ID: "GARRETT " <>>XXXXXX1293@XX.XX.134.24>;party=calling;screen=no;privacy=off
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=28C918C-3B4
To:
Date: Tue, 12 Mar 2013 12:23:07 GMT
Call-ID: 6E47F727-8A4611E2-80D8EADC-2EFD56DE@XX.XX.134.24
Supported: 100rel,timer,resource-priority,replaces
Min-SE: 1800
Cisco-Guid: 1850090159-2319847906-2161306332-788354782
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1363090987
Contact: <>>XXXXXX1293@XX.XX.134.24:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 294
v=0
o=CiscoSystemsSIP-GW-UserAgent 4747 6170 IN IP4 XX.XX.134.24
s=SIP Call
c=IN IP4 XX.XX.134.24
t=0 0
m=audio 17316 RTP/AVP 18 101 19
c=IN IP4 XX.XX.134.24
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:19 CN/8000
a=ptime:20
*Mar 12 12:23:07.721: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP XX.XX.134.24:5060;branch=z9hG4bK1F488
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=28C918C-3B4
To:
Date: Tue, 12 Mar 2013 11:39:59 GMT
Call-ID: 6E47F727-8A4611E2-80D8EADC-2EFD56DE@XX.XX.134.24
CSeq: 101 INVITE
Allow-Events: presence
Content-Length: 0
*Mar 12 12:23:07.721: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 503 Service Unavailable
Via: SIP/2.0/UDP XX.XX.134.24:5060;branch=z9hG4bK1F488
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=28C918C-3B4
To:
Date: Tue, 12 Mar 2013 11:39:59 GMT
Call-ID: 6E47F727-8A4611E2-80D8EADC-2EFD56DE@XX.XX.134.24
CSeq: 101 INVITE
Allow-Events: presence
Warning: 399 cucm "Unable to find a device handler for the request received on port 5060 from XX.XX.134.24"
Content-Length: 0
*Mar 12 12:23:07.729: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:XXXXXX7522@192.168.10.51:5060 SIP/2.0
Via: SIP/2.0/UDP XX.XX.134.24:5060;branch=z9hG4bK1F488
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=28C918C-3B4
To:
Date: Tue, 12 Mar 2013 12:23:07 GMT
Call-ID: 6E47F727-8A4611E2-80D8EADC-2EFD56DE@XX.XX.134.24
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0
*Mar 12 12:23:07.729: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK2d8e8860
From: "GARRETT "
To: <>>XXXXXX7522@XX.XX.134.24:5060>;tag=28C919C-737
Date: Tue, 12 Mar 2013 12:23:07 GMT
Call-ID: 5313cd90691bd5cd3a12d9b76bdeaaf7@74.63.41.218:5060
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=63
Content-Length: 0
*Mar 12 12:23:07.813: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:XXXXXX7522@XX.XX.134.24:5060 SIP/2.0
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK2d8e8860
Max-Forwards: 70
From: "GARRETT "
To: <>>XXXXXX7522@XX.XX.134.24:5060>;tag=28C919C-737
Contact:
Call-ID: 5313cd90691bd5cd3a12d9b76bdeaaf7@74.63.41.218:5060
CSeq: 102 ACK
User-Agent: voip.ms
Content-Length: 0
03-12-2013 04:54 AM
Do you have a sip trunk configured on callmanager pointing to the ip address of your gateway?
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
03-12-2013 05:40 AM
Hello Aokanlawon.
Yes I do.
03-12-2013 05:54 AM
im now getting a 503 error message with an error code of
Unable to find a device handler for the request received on port 5060 from
The ip address that's referenced in the error (removed from post) is the public IP address of the router.
So i went into CUCM and changes the IP address to be the public IP and still getting the same error.
03-12-2013 06:06 AM
I removed the bind command in the router and the sip messages are now showing the local ip address going to CUCM.
03-12-2013 06:12 AM
This has been fixed.
A few things i needed to change which is odd... but what ever at this point.
I needed to add vad to the dial peer, added sipv2 session in the dial peer, and clicked media termination point required on the sip trunk.
below is my running config.
VoIPGw#sh run
Building configuration...
Current configuration : 3588 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoIPGw
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password Mansoor91111
!
aaa new-model
!
!
!
!
aaa session-id common
--More-- !
!
dot11 syslog
ip source-route
ip cef
!
!
!
!
ip domain name VoIPGw
ip name-server 8.8.8.8
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
voice rtp send-recv
!
voice service voip
allow-connections sip to sip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
sip
--More-- header-passing
early-offer forced
midcall-signaling passthru
g729 annexb-all
sip-profiles 1
!
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
!
!
!
!
voice class sip-profiles 1
response ANY sip-header Allow-Header modify "invite, options, bye, cancel, ack, prack, update, refer, subscribe, notify, info, register" "invite, bye, cancel, ack, prack, subscribe, notify, info, register"
response 183 sip-header Allow-Header modify "ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY" "ACK, BYE, CANCEL, INFO, INVITE, PRACK, refer, notify"
response ANY sip-header Allow-Header modify "INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER" "INVITE, BYE, CANCEL"
--More-- response ANY sip-header Allow-Header modify "INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER" "INVITE, BYE, CANCEL, ACK, PRACK, SUBSCRIBE, NOTIFY, INFO, REGISTER"
request ACK sdp-header Audio-Attribute modify "sendonly" "sendrecv"
!
!
!
!
!
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
username gwAdmin password 0 Mansoor91111
!
!
--More-- !
archive
log config
hidekeys
!
!
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0/0
ip address XX.XX.134.24 255.255.255.240
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
shutdown
--More-- !
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface Vlan1
description MGMT Vlan
ip address 192.168.10.52 255.255.255.0
!
interface Vlan4
description Server Vlan
no ip address
!
--More-- ip default-gateway XX.XX.134.17
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
--More-- voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control
description Music On Hold Port
!
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
--More-- maximum sessions 8
shutdown
!
!
dial-peer voice 100 voip
destination-pattern XXXXXX7522
voice-class sip options-ping 60
session protocol sipv2
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
!
!
sip-ua
credentials username 138957_yup password 7 10620C0D1613423D5C0D3A6565 realm 138957_yup
authentication username 138957_yup password 7 10620C0D1613423D5C0D3A6565
registrar dns:newyork.voip.ms expires 3600
!
!
!
line con 0
no modem enable
--More-- line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
password cisco
transport input ssh
!
end
03-12-2013 06:17 AM
You dont need MTP...I suggest you dont use it..
FIrst of all you need to configure an inbound dial-peer from your ITSP
Eg..
dial-peer voice xx voip
session protocol sipv2
incoming called number xxx (where XXX = is your DDI/DN pattern)
dtmf relay rtp-nte
no vad
Try this and remove the MTP on the sip trunk
On the Bind..
I noticed that the gateway is asking CUCM to send response back to the 50.20.134.24 ip....Can CUCM connect to this IP from the local interface?
What Interface does CUCM use to talk to the CUBE? Which IP have you configured for your sip trunk..You should put your bind on that IP
From the traces...
INVITE sip:XXXXXX7522@192.168.10.51:5060 SIP/2.0
Via: SIP/2.0/UDP 50.20.134.24:5060
The CUBE is sending invite to CUCM on ip 192.168.10.51
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
03-12-2013 06:32 AM
HI,
Removing the media term point still allows calls to be placed.
When i change my dial-peer to be as follows... the calls no longer route. The deubg shows that there is no dial-perr match
dial-peer voice 100 voip
voice-class sip options-ping 60
session protocol sipv2
session target ipv4:192.168.10.51
session transport udp
incoming called-number XXX9177522
dtmf-relay rtp-nte
03-12-2013 06:38 AM
You need two dial-peers..I didnt say remove dial-peer 100..
You need an inbound and outbounbd dial-peer
Configure inbound dial-peer as follows
dial-peer voice 101 voip
voice-class sip options-ping 60
session protocol sipv2
session transport udp
incoming called-number XXX9177522
dtmf-relay rtp-nte
Configure outbound dial-peer as follows
dial-peer voice 100 voip
destination-pattern XXXXXX7522
voice-class sip options-ping 60
session protocol sipv2
session target ipv4:192.168.10.51
session transport udp
dtmf-relay rtp-nte
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
03-12-2013 09:58 AM
I have to admit that im really having a hard time here...
With your config i can get calls comming in with out issues. I removed my programming and went directly with yours.
When i try and do an out bound call... well that failes.
I created the following dial peers. my CUCM will present 1+area code+ 7 digits
dial-peer voice 201 voip
voice-class sip options-ping 60
session protocol sipv2
session transport udp
incoming called-number 1.*
dtmf-relay rtp-nte
!
dial-peer voice 200 voip
destination-pattern 1.*
voice-class sip options-ping 60
session protocol sipv2
session target dns:neywork.voip.ms
session transport udp
dtmf-relay rtp-nte
below is my sip trace. Specific inforation removed and replaced with X's
*Mar 12 17:37:40.471: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:XXX9177522@50.20.134.24:5060 SIP/2.0
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK05a308ce
Max-Forwards: 70
From: "GARRETT "
To:
Contact:
Call-ID: 0468fe2415fdcd47074de44c25f3f433@74.63.41.218:5060
CSeq: 102 INVITE
User-Agent: voip.ms
Date: Tue, 12 Mar 2013 16:54:32 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Remote-Party-ID: "GARRETT "
Content-Type: application/sdp
Content-Length: 268
v=0
o=root 805135302 805135302 IN IP4 74.63.41.218
s=voip.ms
c=IN IP4 74.63.41.218
t=0 0
m=audio 16470 RTP/AVP 0 18 101
a=rtpmap:0 PCMU/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=sendrecv
*Mar 12 17:37:40.487: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK05a308ce
From: "GARRETT "
To:
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 0468fe2415fdcd47074de44c25f3f433@74.63.41.218:5060
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0
*Mar 12 17:37:40.487: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:XXX9177522@192.168.10.51:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.10.52:5060;branch=z9hG4bK6B2285
Remote-Party-ID: "GARRETT "
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=3AC8B58-E0D
To:
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 5F5575A3-8A7211E2-831CEADC-2EFD56DE@192.168.10.52
Supported: 100rel,timer,resource-priority,replaces
Min-SE: 1800
Cisco-Guid: 1599316115-2322731490-2199317212-788354782
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1363109860
Contact:
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 69
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 297
v=0
o=CiscoSystemsSIP-GW-UserAgent 6223 2315 IN IP4 192.168.10.52
s=SIP Call
c=IN IP4 192.168.10.52
t=0 0
m=audio 19064 RTP/AVP 18 101 19
c=IN IP4 192.168.10.52
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=rtpmap:19 CN/8000
a=ptime:20
*Mar 12 17:37:40.495: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.10.52:5060;branch=z9hG4bK6B2285
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=3AC8B58-E0D
To:
Date: Tue, 12 Mar 2013 16:54:32 GMT
Call-ID: 5F5575A3-8A7211E2-831CEADC-2EFD56DE@192.168.10.52
CSeq: 101 INVITE
Allow-Events: presence
Content-Length: 0
*Mar 12 17:37:40.499: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:17175193304@192.168.10.52:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.10.51:5060;branch=z9hG4bK122b41b544
From: "GARRETT "
To: <17175193304>17175193304>
Date: Tue, 12 Mar 2013 16:54:32 GMT
Call-ID: 81ab5980-13f15dc8-13-330aa8c0@192.168.10.51
Supported: timer,resource-priority,replaces
Min-SE: 1800
User-Agent: Cisco-CUCM8.0
Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY
CSeq: 101 INVITE
Contact:
Expires: 180
Allow-Events: presence
Supported: X-cisco-srtp-fallback
Supported: Geolocation
Cisco-Guid: 2175490432-0000065536-0000000019-0856336576
Session-Expires: 1800
P-Asserted-Identity: "GARRETT "
Remote-Party-ID: "GARRETT "
Max-Forwards: 68
Content-Length: 0
*Mar 12 17:37:40.511: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.10.51:5060;branch=z9hG4bK122b41b544
From: "GARRETT "
To: <17175193304>17175193304>
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 81ab5980-13f15dc8-13-330aa8c0@192.168.10.51
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0
*Mar 12 17:37:40.511: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.10.51:5060;branch=z9hG4bK122b41b544
From: "GARRETT "
To: <17175193304>;tag=3AC8B70-218F17175193304>
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 81ab5980-13f15dc8-13-330aa8c0@192.168.10.51
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=1
Content-Length: 0
*Mar 12 17:37:40.515: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:17175193304@192.168.10.52:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.10.51:5060;branch=z9hG4bK122b41b544
From: "GARRETT "
To: <17175193304>;tag=3AC8B70-218F17175193304>
Date: Tue, 12 Mar 2013 16:54:32 GMT
Call-ID: 81ab5980-13f15dc8-13-330aa8c0@192.168.10.51
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: presence
Content-Length: 0
*Mar 12 17:37:40.519: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 192.168.10.52:5060;branch=z9hG4bK6B2285
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=3AC8B58-E0D
To:
Date: Tue, 12 Mar 2013 16:54:32 GMT
Call-ID: 5F5575A3-8A7211E2-831CEADC-2EFD56DE@192.168.10.52
CSeq: 101 INVITE
Allow-Events: presence
Reason: Q.850;cause=1
Content-Length: 0
*Mar 12 17:37:40.523: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:XXX9177522@192.168.10.51:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.10.52:5060;branch=z9hG4bK6B2285
From: "GARRETT " <>>XXXXXX1293@newyork.voip.ms>;tag=3AC8B58-E0D
To:
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 5F5575A3-8A7211E2-831CEADC-2EFD56DE@192.168.10.52
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0
*Mar 12 17:37:40.527: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK05a308ce
From: "GARRETT "
To:
Date: Tue, 12 Mar 2013 17:37:40 GMT
Call-ID: 0468fe2415fdcd47074de44c25f3f433@74.63.41.218:5060
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=1
Content-Length: 0
*Mar 12 17:37:40.611: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:XXX9177522@50.20.134.24:5060 SIP/2.0
Via: SIP/2.0/UDP 74.63.41.218:5060;branch=z9hG4bK05a308ce
Max-Forwards: 70
From: "GARRETT "
To:
Contact:
Call-ID: 0468fe2415fdcd47074de44c25f3f433@74.63.41.218:5060
CSeq: 102 ACK
User-Agent: voip.ms
Content-Length: 0
03-12-2013 11:17 AM
i have this solved but not how i wanted too.
I went into my VoIP proivder and turned off the authenication for inound calls. Since the GW will have a static, i told my VoIP proivder the IP and it will deliver every call too that IP.
every time i entered the below commands... my inbound and outbound calls failed
config t
voice service voip
sip
outbound-proxy dns:newyork.voip.ms
03-13-2013 06:21 AM
Oh I can see where the error is..The destination-pattern is pointing back to CUCM. It should point to your sip provider
Try this..
Configure inbound dial-peer as follows
dial-peer voice 101 voip
voice-class sip options-ping 60
session protocol sipv2
session transport udp
incoming called-number . ( use . here)
dtmf-relay rtp-nte
Configure outbound dial-peer as follows
dial-peer voice 100 voip
destination-pattern XXXT ( this will match all the numbers you want to send out, change this to meet your dialled numbers)
voice-class sip options-ping 60
session protocol sipv2
session target ipv4:YYYYYYY (yyy=sip provider ip address
session transport udp
dtmf-relay rtp-nte
Please rate all useful posts
"opportunity is a haughty goddess who waste no time with those who are unprepared"
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide