cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3136
Views
10
Helpful
13
Replies

Unified Messaging test failing for a mailbox User CUCxN 8.6 and Exchange 2010

fuhrersk8
Level 3
Level 3

                   Hello guys!

The Test for Unified Messaging for a user account reflects the following results:

Failed accessing jdoe@motor.net on 10.199.100.58.Diagnostic=[] Verb=[] url=[] request=[] response=[]
The system failed to perform a typical calendar operation.Refer to other warnings and errors generated by the tool, and check the Tomcat log file for details.The system failed while trying to make an API call.

I verified the Active Directory Account Used to Access Exchange with the domain\ in front of username and password is correct.

The Exchange server is set to Web-Based Authentication Mode Basic and Web-Based Protocol set for HTTPS but with no validation for certificates. Even thou, I uploaded the Exchange server certificates into the Unity Connection but with no success for the mailbox user account test.

Also, the certificates in the Exchange are in the format .cert. In which format the certificates should be uploaded into the Unity Connection and what type (tomacat-trust, etc.)?

Please any help is welcome, Thanks in advanced guys!

13 Replies 13

Chris Deren
Hall of Fame
Hall of Fame

Please post screen shot of your unified messaging service configuration.

Chris

Hi Chris and thanks for your reply!

The screenshot:

Your service account needs to be defined in as user@domain form rather than domain/user. Please change that.  Also, if you are using certs you should be pointing to FQDN and not IP address.

HTH,

Chris

Hello Chris;

     I changed the service account as user@domain from and replace the ip address of the Exchange for its domain name but same result when testing the User account.

What happens when you perform the test under the unified messaging service page?

What version of Exchange are you using?

Chris

The test result for the Unified Messaging is as follows:

Exchange is 2010.

Can you provide similar screen shot of the user test?

Yes, please take a look (it is set to use Corporate e-mail provided by LDAP AD):

It looks like your Exchange account may not have proper impersonation rights setup, did you follow the UM guide for running the powershell on Exchange?

Chris

Yes. But I will double check the procedure again. Just in case. What about the certificates? Since I disable the checkmark, are certs being verified?

Thanks again!

Hi Chris!

     Tomcat traces show that it is sending 401 error code:

16:04:59.129 |22551,,,CsEws,10,[CsEws/CsEwsClient.cpp:527]: HTTP request failed with error: Bad response from server, HTTP code returned: 401, HTTP status code: 401, for ews URL: https://prmaiex03.motorambar.local/EWS/Exchange.ASMX, verb: POST
16:04:59.129 |22551,,,CsEws,10,FAILED HTTP Request:

http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">





MaLopez@motorambar.net




http://schemas.microsoft.com/exchange/services/2006/messages"
xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">

Default




MaLopez@motorambar.net





16:04:59.129 |22551,,,CsEws,10,FAILED HTTP Response:

16:04:59.167 |22551,,,CsEws,10,[CsEws/CsEwsClient.cpp:527]: HTTP request failed with error: Bad response from server, HTTP code returned: 401, HTTP status code: 401, for ews URL: https://prmaiex03.motorambar.local/EWS/Exchange.ASMX, verb: POST
16:04:59.167 |22551,,,CsEws,10,FAILED HTTP Request:


xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages"
xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">





MaLopez@motorambar.net



http://schemas.microsoft.com/exchange/services/2006/messages"
xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">

IdOnly















16:04:59.167 |22551,,,CsEws,10,FAILED HTTP Response:

16:04:59.168 |22551,,,CCL,11,[ccl/CsCclSession.cpp:665]: unable to connect to server "prmaiex03.motorambar.local" for user "malopez": E_FAIL.
16:04:59.168 |22551,,,CCL,11,[ccl/CsCclSession.cpp:336]: unable to add provider for server prmaiex03.motorambar.local for user malopez: E_FAIL.
16:04:59.168 |22551,,,CCL,11,Java_com_cisco_unity_ccl_CCLSession_addProvider__IIIIIZZZZZZZZZLjava_lang_String_2Ljava_lang_String_2Ljava_lang_String_2Ljava_lang_String_2Ljava_lang_String_2Ljava_lang_String_2Ljava_lang_String_2: Unable to add provider to CCL session for ad-hoc ESA for server: prmaiex03.motorambar.local: E_FAIL
16:04:59.168 |22551,,,CuESD,0,Thread=http-8443-15 Add provider to CCLSession with parameters  ServerType=4 LoginType=0 SecTransType=1 AuthMode=1 ExchServerType=1 IsSvcEnabled=true IsActCalEnabled=true IsSvcSupportCal=true isActMeetingEnabled=false isSvcSupportMeeting=false isUseSvcCred=true isVerifySvcCert=false isPrimaryMtgSvc=false server=prmaiex03.motorambar.local serverAlias=MOTORAMBNT\CiscoUM servicePwd=LSA839bOP03X6uL1DY6wew== userId=null userPwd=null userEmailAddress=MaLopez@motorambar.net Proxy server=null Impersonation=true
16:04:59.168 |22551,,,CuESD,0,Thread=http-8443-15 Failed to add provider for an ad hoc esa

I've just fixed it. Changed to NTML and is working now. Thanks for your support!

Oh yeah, that will get you as well, I've been there before myself :-)

Chris