cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2647
Views
30
Helpful
13
Replies
Highlighted
Beginner

Upgrade issue with 69xx

Hello Guys,

I have problem to upgrade my 6921 phones from 9-1-1-0

When I try to upgrade them from the specified version to the last one (9-3-3-2) we have the following behavior:

     - Phone reboot;

     - Phone download the new firmware;

     - Phone start;

     - Phone "can't register";

     - Loop on old firmware/new firmware.

I have the same behavior with phone running firmware 9-1-1-2-sr.

In the phone logs I have the following:

[13:58:14, 06/18/2013] upgrade SCCP69xx.9-3-3-2.zz.sgn from   10.31.1.10

[13:58:14, 06/18/2013] upgrade   DSP69xx.12-4-122-02-121029.zz.sgn success

[13:58:04, 06/18/2013] upgrade   DSP69xx.12-4-122-02-121029.zz.sgn from 10.31.1.10

[13:58:01, 06/18/2013] SEP54781a6a8cb0 Get ip from DHCP server   : 10.161.15.81

[13:57:31, 06/18/2013] system boot up (SCCP 9.1.1.0)

[13:57:15, 06/18/2013] trigger reboot from UPGRADE_LOADS   (system up time : 33434 ticks, 1

minute 6 seconds)

[13:57:15, 06/18/2013] upgrade SCCP69xx.9-1-1-0.zz.sgn success

[13:56:37, 06/18/2013] upgrade SCCP69xx.9-1-1-0.zz.sgn from   10.31.1.10

[13:56:37, 06/18/2013] upgrade DSP69xx.0-0-0-4.zz.sgn success

[13:56:31, 06/18/2013] upgrade DSP69xx.0-0-0-4.zz.sgn from   10.31.1.10

[13:56:31, 06/18/2013] XMLDefault.cnf.xml.sgn (HTTP)

[13:56:31, 06/18/2013] can't download configuration file SEP54781A6A8CB0.cnf.xml.sgn   from

10.31.1.10

[13:56:31, 06/18/2013] ITL installed

[13:56:31, 06/18/2013] ITLSEP54781A6A8CB0.tlv updated   successfully

[13:56:31, 06/18/2013] ITLSEP54781A6A8CB0.tlv (HTTP)

[13:56:31, 06/18/2013] ITLSEP54781A6A8CB0.tlv updating

[13:56:31, 06/18/2013] CTLSEP54781A6A8CB0.tlv not found in   10.31.1.10

[13:56:31, 06/18/2013] CTLSEP54781A6A8CB0.tlv updating

[13:56:30, 06/18/2013] XMLDefault.cnf.xml.sgn (HTTP)

[13:56:30, 06/18/2013] can't download configuration file   SEP54781A6A8CB0.cnf.xml.sgn from

10.31.1.10

[13:56:30, 06/18/2013] ITL installed

[13:56:30, 06/18/2013] ITLSEP54781A6A8CB0.tlv updated   successfully

[13:56:30, 06/18/2013] ITLSEP54781A6A8CB0.tlv (HTTP)

[13:56:30, 06/18/2013] ITLSEP54781A6A8CB0.tlv updating

[13:56:30, 06/18/2013] CTLSEP54781A6A8CB0.tlv not found in   10.31.1.10

[13:56:30, 06/18/2013] CTLSEP54781A6A8CB0.tlv updating

[13:56:28, 06/18/2013] XMLDefault.cnf.xml.sgn (HTTP)

[13:56:28, 06/18/2013] can't download configuration file   SEP54781A6A8CB0.cnf.xml.sgn from

10.31.1.10

[13:56:28, 06/18/2013] ITL installed

[13:56:28, 06/18/2013] ITLSEP54781A6A8CB0.tlv updated   successfully

[13:56:28, 06/18/2013] ITLSEP54781A6A8CB0.tlv (HTTP)

[13:56:28, 06/18/2013] ITLSEP54781A6A8CB0.tlv updating

[13:56:28, 06/18/2013] CTLSEP54781A6A8CB0.tlv not found in   10.31.1.10

[13:56:28, 06/18/2013] CTLSEP54781A6A8CB0.tlv updating

[13:56:26, 06/18/2013] SEP54781a6a8cb0 Get ip from DHCP server   : 10.161.15.81

[13:56:12, 06/18/2013] DSPALLOC: AER instance 0, max_tail =   200 ms, usage = ( HS HeS HF

GL_HS GL_HeS )

[13:56:12, 06/18/2013] DSPALLOC: AER instance 1, max_tail = 60   ms, usage = ( HS HeS GL_H

S GL_HeS )

[13:56:12, 06/18/2013] ROOT: Hardware ringer :FALSE

[13:56:12, 06/18/2013] Network: nw_create() ipstack_mode=2

[13:56:10, 06/18/2013] system boot up (SCCP 9.3.3.2)

[13:56:10, 06/18/2013] DLM: Cannot alloc mem for internal msg   (2)

[13:56:10, 06/18/2013] DLM: Cannot alloc mem for internal msg   (1)

[13:56:10, 06/18/2013] DLM: Cannot alloc mem for internal msg (1)

[13:55:54, 06/18/2013] trigger reboot from UPGRADE_LOADS   (system up time : 120038 ticks, 4

minutes )

[13:55:54, 06/18/2013] upgrade SCCP69xx.9-3-3-2.zz.sgn success

[13:54:00, 06/18/2013] upgrade SCCP69xx.9-3-3-2.zz.sgn from   10.31.1.10

[13:54:00, 06/18/2013] upgrade   DSP69xx.12-4-122-02-121029.zz.sgn success

[13:53:50, 06/18/2013] upgrade   DSP69xx.12-4-122-02-121029.zz.sgn from 10.31.1.10

[13:52:25, 06/18/2013] SEP54781a6a8cb0 Get ip from DHCP server   : 10.161.15.81

[13:51:55, 06/18/2013] system boot up (SCCP 9.1.1.2.sr)

Thanks for your help !

Herve Jacquemin

13 REPLIES 13
Highlighted
Beginner

Upgrade issue with 69xx

No one has an idea about this ?

Highlighted

Upgrade issue with 69xx

I have exactly the same problem. FYI, My old firmware is 9.3.1.3.

Highlighted
Beginner

Upgrade issue with 69xx

I opened a TAC case, when I have a solution, I will update the topic !

Highlighted

Upgrade issue with 69xx

thank you very much. hopefully there will be a solution

Highlighted
Beginner

Upgrade issue with 69xx

I had an answer from the tac:

In the TFTP service logs we found:

12:46:55.122 |   CReqContext::tftp[0xaf0234a0~15~10.161.15.81~1030] SEP54781A6A8CB0.cnf.xml.sgn file not found. Checking [SEP54781A6A8CB0.cnf.xml] to sign

12:46:55.122 |CReqContext::FindAndServe SignFileFlag[1]

12:46:55.123 |CCtftpChangeNotifyServer::HasWaitingEvent(), Empty List or pkid

12:46:55.123 |CReqContext::FindAndServe(1)[0xaf0234a0~15~10.161.15.81~1030],Not signing[SEP54781A6A8CB0.cnf.xml], on fly

12:46:55.123 |-->HTTPEngine::sendNak[0xaf0234a0~15~10.161.15.81~1030][1]

12:46:55.123 |   HTTPEngine::sendNak[0xaf0234a0~15~10.161.15.81~1030][1] FileName[SEP54781A6A8CB0.cnf.xml.sgn], Version[HTTP/1.1]

12:46:55.123 |   HTTPEngine::sendNak[0xaf0234a0~15~10.161.15.81~1030][1] [64][HTTP/1.1 404 Not Found

>> Phone requests general configuration file “XMLDefault.cnf.xml.sgn” and gets it:

12:46:55.142 |   HTTPEngine::sendResponse[0xaf023e80~16~10.161.15.81~1031] FileName[XMLDefault.cnf.xml.sgn], Version[HTTP/1.1], Size[9947]

12:46:55.142 |   HTTPEngine::sendResponse[0xaf023e80~16~10.161.15.81~1031] [85][HTTP/1.1 200 OK

Content-length: 9947

Cache-Control: no-store

Content-type: */*

]

12:46:55.142 |-->HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Socket[17], Length[85]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Send Complete, Size[85], Sent[85]

12:46:55.142 |<--HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |-->HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Socket[17], Length[9947]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Send Complete, Size[9947], Sent[9947]

>> Phone requests firmware “9-1-1-0” and gets it:

12:46:55.142 |   HTTPEngine::sendResponse[0xaf023e80~16~10.161.15.81~1031] FileName[XMLDefault.cnf.xml.sgn], Version[HTTP/1.1], Size[9947]

12:46:55.142 |   HTTPEngine::sendResponse[0xaf023e80~16~10.161.15.81~1031] [85][HTTP/1.1 200 OK

Content-length: 9947

Cache-Control: no-store

Content-type: */*

]

12:46:55.142 |-->HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Socket[17], Length[85]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Send Complete, Size[85], Sent[85]

12:46:55.142 |<--HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |-->HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Socket[17], Length[9947]

12:46:55.142 |   HTTPEngine::sendMessage[0xaf023e80~16~10.161.15.81~1031] Send Complete, Size[9947], Sent[9947]

>> Phone requests firmware “9-1-1-0” and gets it:

12:46:56.683 |   HTTPEngine::sendResponse[0xaf026fe0~21~10.161.15.81~1036] FileName[SCCP69xx.9-1-1-0.loads], Version[HTTP/1.1], Size[481]

12:46:56.683 |   HTTPEngine::sendResponse[0xaf026fe0~21~10.161.15.81~1036] [59][HTTP/1.1 200 OK

And this goes into a loop from there.

The "Not signing[SEP54781A6A8CB0.cnf.xml], on fly” would mean taht the CUCM doesn't provide the secure configuration file to the phone. And he advice me to install the latest device pack on the CUCM.

WIll keep you updated if my problem is solved after or not !

Highlighted

Upgrade issue with 69xx

Hello,

Thanks for the update. By device pack, do you mean this: http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/devpack_comp_mtx.html
?

Anyways, what is your CUCM version? Mine is 8.5.1

Highlighted
Beginner

Upgrade issue with 69xx

Highlighted

Upgrade issue with 69xx

Hello hjacquemin,

Thanks a lot for the information. Please update if you are able to solve the issue . I will also download and try at my side

Highlighted
Beginner

Upgrade issue with 69xx

Your welcome Aldred.

I juste have a bad news our customer won't patch the cluster. The holiday period is approching, and he will upgrade in 9.x at the end of July.

He wants take any risk !

But keep me updated on your problem !

Highlighted

Upgrade issue with 69xx

Haha i see. It's good to upgrade to version 9. But what I know is the licensing model changes dramatically in version 9. I think you need to consult with TAC regarding that issue

Anyways I will try to install the device pack and update here.

Highlighted
Beginner

Upgrade issue with 69xx

Indeed the licensing is very different ! And presence too all is manage by CUCM now.

Apparently the issue is at the CUCM side and version should solved my problem if I understand well. So wait and see !

Highlighted
Beginner

Upgrade issue with 69xx

Hello hjacquemin,

Did TAC provide any bug ID for this issue?

I am running 8.6.2.22900-9 and I have this issue also.

Thank you

Beginner

Upgrade issue with 69xx

Finally I have installed the latest device pack for CUCM 8.6(2) and that fixed my issue with the 6945 of my customer.  They finally upgraded succesfully to latest software load 9.3.3SR1.

Thank you.

CreatePlease to create content