10-12-2011 12:26 PM - edited 03-16-2019 07:28 AM
Hello Cisco experts,
I had a question about how to use a loopback address as the IP address that is used for registering the GW to the CallManager.
Right now the GW uses the ip address of the LAN interface but that will be changing soon and the new LAN IP is not going to be reachable by the CallManager so I want to use a Loopback and give it the existing IP of the LAN interface (currently reachable from CM)
Can someone please help??
Solved! Go to Solution.
10-12-2011 12:58 PM
Hi,
You are spot on hear.
You should always use a bound loopback address when you have multiple ip addressed interfaces.
Add this to your config
!
mgcp bind media source interface loopback0
mgcp bind signal source interface loopback0
mgcp
!
Make sure you advertise the loopback via your BGP or OSPF and test that it has connectivity throughout your voip network as your CUCM, phones and other gateways will need 2 way comms for RTP streams etc. TTest this before you implement the config change.
HTH
Alex
10-12-2011 12:37 PM
Sorry.. additional detail.. this is an MGCP configuration.
vamer-laframet1-1394743#show run
Building configuration...
Current configuration : 3702 bytes
!
! Last configuration change at 17:20:04 GMT Wed Oct 12 2011 by admin
! NVRAM config last updated at 17:22:49 GMT Wed Oct 12 2011 by admin
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
service password-encryption
!
hostname vamer-laframet1-1394743
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$UoZ4$6c5p8qLCGSk9at0fhVp8Y/
!
aaa new-model
!
!
!
aaa session-id common
clock timezone GMT 0
clock calendar-valid
network-clock-participate wic 2
!
!
ip cef
!
!
no ip bootp server
no ip domain lookup
ip domain name virginam.com
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username GNOuser password 7 110D325C1634202406
username admin password 7 13061E010803
!
!
controller T1 0/2/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/2/1
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
ip ftp source-interface Loopback0
ip tftp source-interface Loopback0
!
!
!
interface GigabitEthernet0/0
ip address 172.19.4.4 255.255.255.0
duplex full
speed auto
!
interface GigabitEthernet0/1
ip address 10.16.0.42 255.255.255.252
duplex auto
speed auto
!
interface Serial0/2/0:0
ip address 10.14.0.42 255.255.255.252
fair-queue
!
interface Serial0/2/1:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/3/0
no ip address
encapsulation frame-relay IETF
shutdown
no fair-queue
frame-relay lmi-type cisco
!
router ospf 1
log-adjacency-changes
redistribute bgp 65012 subnets
network 10.16.0.40 0.0.0.3 area 0
default-information originate
!
router bgp 65012
no synchronization
bgp router-id 10.14.0.42
bgp log-neighbor-changes
network 10.14.0.40 mask 255.255.255.252
network 10.17.4.0 mask 255.255.255.0
network 10.18.4.0 mask 255.255.255.0
network 10.19.4.0 mask 255.255.255.0
network 172.19.1.0 mask 255.255.255.0
network 172.19.4.0 mask 255.255.255.0
redistribute ospf 1
neighbor 10.14.0.41 remote-as 1803
no auto-summary
!
ip forward-protocol nd
!
ip as-path access-list 1 permit ^$
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
ccm-manager redundant-host 172.20.9.200
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.20.9.200
ccm-manager config
!
mgcp
mgcp call-agent 172.20.9.201 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
!
privilege exec level 0 traceroute
privilege exec level 1 ping ip
privilege exec level 0 ping
privilege exec level 0 send
privilege exec level 0 show configuration
privilege exec level 0 show
!
line con 0
exec-timeout 30 0
password 7 13013C4B0A2A2F0229
stopbits 1
line aux 0
exec-timeout 30 0
password 7 121D2E4E132D272C28
no exec
stopbits 1
line vty 0 4
exec-timeout 30 0
password 7 045F205F0E0767660B
transport input telnet
!
scheduler allocate 20000 1000
ntp clock-period 17180293
ntp source Loopback0
ntp update-calendar
ntp server 146.170.64.132 prefer
ntp server 146.170.124.133
!
end
10-12-2011 12:58 PM
Hi,
You are spot on hear.
You should always use a bound loopback address when you have multiple ip addressed interfaces.
Add this to your config
!
mgcp bind media source interface loopback0
mgcp bind signal source interface loopback0
mgcp
!
Make sure you advertise the loopback via your BGP or OSPF and test that it has connectivity throughout your voip network as your CUCM, phones and other gateways will need 2 way comms for RTP streams etc. TTest this before you implement the config change.
HTH
Alex
10-12-2011 01:57 PM
thank you very much!!! thats what i was leaning towards doing and you just confirmed.. thank you!!!!!!
10-13-2011 12:11 AM
There is a known defect in IOS that can cause the MGCP GW to register with another address then the one used in the bind statements. This only happens the first time the MGCP GW registers after the bind statements have been issued. The defect causes the GW to use the address of the interface closest to the CM. To check if this has happened look at the IP address that the GW have registered with in CM.
If this happens use the below commands.
no mgcp
no mgcp bind media source interface loopback0
no mgcp bind signal source interface loopback0
mgcp bind media source interface loopback0
mgcp bind signal source interface loopback0
mgcp
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide