cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
635
Views
5
Helpful
4
Replies
Highlighted
Participant

vg350 & Elevator phones w/ PLAR

We have a tricky issue with elevator phones connected to analog ports on a vg350. I configured them for PLAR in CUCM (11.5) and it appears to work well, but many of the devices themselves have been historically programmed to dial certain numbers via DTMF. Our Avaya phone system ignored the digits it sent since I'm told it sends DTMF of its own. The VG350 appears to be opening two call legs each time the phone goes off-hook so I see the call routing via PLAR through CUCM, but the elevator experiences one-way audio, presumably because the phone is configured to dial another number.

 

In some elevators (different models), I can disable the PLAR, give it dial-tone and let it dial the number. Others, I can match the ringdown to the number it's trying to dial. Some of the older elevators are dialing nonexistent numbers and I need the input ignored. I'd like to standardize this effort as I'm talking a couple hundred elevators and have been told reprogramming them all is not an option.

 

IOS version on the vg350s is 15.6(3)M1

 

Thanks for any ideas.

4 REPLIES 4
Highlighted
Cisco Employee

How do you have the FXS ports on these VG's ? MGCP or SCCP ?
When you say two legs, well that is fine. Every call needs to have two legs so that part is correct.
Are you having these audio issues within a VG or calls across two different VG's ?

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted

Skinny. What I meant by two legs is more like two paths. I haven't run a debug to confirm though. The issue is within a single VG. The reason I say two call paths is because we had a different elevator phone that was programmed to dial 1234, for example. The PLAR target was 4321. This resulted in one-way audio to 4321. If I changed the PLAR target to 1234 and forwarded it to 4321, the call worked with audio both ways.

Highlighted

If it's within the same VG, then the audio will be in-band without any DSP in the path. If you can reproduce it, check the outputs for "show call active voice brief" multiple times during the active call.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted
Participant

Replying for posterity...this turned out to be an issue with the device (Talkaphone). By default, it will not open two-way audio until it hears a dial tone. Since PLAR is configured, no dial tone is played. Manual programming needed to be done on the phone to override this behavior.

 

Another prime example of an IT guy overcomplicating the issue.

Content for Community-Ad